SoGE is a Star Wars Total Conversion for SoaSE: Rebellion with it's roots in the Homeworld 2 mod Star Wars: Warlords which features the two primarily sides of the Galactic Civil War, the Clone Wars, and the Yuuzhan Vong War. The current public version works for Sins of a Solar Empire: Rebellion 1.90 and, with or without, all DLC. Rated #6 players choice in MOTY 2014. An editors choice in MOTY 2015.

Report OUTDATED - SoGE 4.10.1 for SOASE Rebellion 1.82
Filename
SoGE_4.10.1_Patch.zip
Category
Patch
Uploader
Lavo
Added
Size
87.98mb (92,251,866 bytes)
Downloads
16,036 (1 today)
MD5 Hash
e310f27ec1aa076e4ab42af541ab4c6e
Embed Button
Embed Widget
Description

Sins of a Galactic Empire 4.10.1 patch for Sins of a Solar Empire: Rebellion 1.82, a Star Wars total conversion mod for Sins of a Solar Empire. Requires an existing installation of 4.10.0 to function.

Preview
OUTDATED - SoGE 4.10.1 for SOASE Rebellion 1.82
Comments  (0 - 50 of 53)
Supersejer
Supersejer

What's new in this update? :)

Reply Good karma Bad karma+2 votes
MiWadiAddiction
MiWadiAddiction

Stuff! Awesome stuff! :D

Reply Good karma Bad karma0 votes
Guest
Guest

This comment is currently awaiting admin approval, join now to view.

MiWadiAddiction
MiWadiAddiction

Honestly though. What's in this patch?

Reply Good karma Bad karma+1 vote
Lavo Author
Lavo

Added patch notes to the description:
Fixed the Acclamator FPS bug, fixed the Mandator mesh bug, added in a lot of new maps, added reflective seas for most planets that have seas, updated the GSD for easier map creation, plus a bunch of other minor fixes.

Reply Good karma+1 vote
Guest
Guest

Does the AI have problems with any of the new maps? Or are these meant for human players

Reply Good karma Bad karma0 votes
Lavo Author
Lavo

They are all AI-compatible to my knowledge. A human will be better on them obviously, but the AI shouldn't be a slouch.

Reply Good karma+1 vote
Astraeos
Astraeos

I'm really loving the new maps, like a lot. One thing that is really annoying though, is the randomized start positions. Would it be possible to release versions with Fixed positions as alternates?

Or, could you tell me how to correctly change that in the Galaxy editor and actually have the maps show up in game?

For example, I DL'd the updated GalForge, opened The Mid Rim map, changed randomized positions from true to false, saved it as The Mid Rim(fixed), but I cannot get the fixed version to show up in game!

Reply Good karma Bad karma+1 vote
Lavo Author
Lavo

The Mid Rim has randomized starting positions as it's not a lore specific/preset map. That said, the best way to "see" this map is to put it into your "...\Sins of a Solar Empire Rebellion\GalaxyForge" folder. Then the map will show up in the "Galaxy Forge" map tab.

Reply Good karma+1 vote
Wingstorm
Wingstorm

Hi, I have been playing SoGE 4.10.1 for a couple of hours now and I'm loving it! However, I'm noticing 2 bugs/issues(?) while playing the mod.
*I have the Large Address flagged on my game's .exe

1) Every now and then, if I'm zoomed in to view the units, the screen would suddenly become stuck with a weird flickering (non-interactable) image of the game screen. The only way I could get rid of it is to alt-tab to desktop and alt-tabbing back into the game. Sometimes the effect would persist and I would have to zoom out quickly, once I'm back in the game.

By stuck, I mean I can hear things be selected if I move my mouse, but the screen would be overlayed with a flickering, non-moving nor interactable image of the game.
This bug pops up every now and then, but it only appears when I'm looking at the game models, it does not appear when I'm just seeing the icons of the units (zoomed out).

2) The game slows down a lot after playing it for an hour or so. This happens even in smaller maps like 3-4 player, less then 50 planets maps.

If I save and reload the game, the game speeds back up for a little while before slowing down again.

It seems to happen towards the mid-late game. Is this just due to the large number of units in the game? Having too many factions or a memory leak?

I'm running most graphics on low-mid on my com. But this slow down of the game only appear badly when running SoGE.

My com's stats:
i7-3610QM @ 2.30hz
8GB
GTX-660M

Is there anyway to resolve these two issues? I'm not having them when I'm playing other mods.
Thanks in advance!

Reply Good karma Bad karma+2 votes
Lavo Author
Lavo

1) This sounds really weird, I've never heard of this happening with Sins before. I would suggest trying to run the game in windowed mode and seeing if that helps.

2) This sounds like late game lag hitting early. It is likely due to your weak laptop CPU; it just cannot handle the strain of single core limited Sins.

Reply Good karma+1 vote
Wingstorm
Wingstorm

Thanks for the reply.

1) After trying out a couple of other mods, I notice the image stuck bug do pop up every now and then on mods too. Often right after loading a game, aka game is running, but image shown is the loading screen.
It is just a lot more common in SoGE.

As the bug pops up so inconsistently, I'm placing this down as just an isolated issue with my computer, maybe something to do with the graphics card or even the CPU issue.

2) On the game slowing down, I didn't know that sins is a Single CPU game! Thanks for this info. I guess it is just something I have to live with.

Thanks for helping with these issues.

Really hope to see more from SoGE in the future. :)

Reply Good karma Bad karma+1 vote
Lavo Author
Lavo

Now that you've noticed that image stuck bug with other mods, I have a feeling it's tied to late game lag.

Reply Good karma+1 vote
Astraeos
Astraeos

I keep getting crashes when trying to load maps, with a pop up that says "90% you did not install LAA correctly, etc, etc"

Now, I've 100% installed LAA correctly, yet I get these crashes all the time. What have I done wrong? Anything I can do to potentially help this issue?

Reply Good karma Bad karma+1 vote
Lavo Author
Lavo

If you're getting a crash when trying to load maps, then my first guess is that something went wrong with either your 4.10.0 or 4.10.1 download and corrupted one or more of the mod's mesh (model) files. Try redownloading the patch, and failing that, redownload 4.10.0; specifically for both try our NexusMods mirror: Nexusmods.com

Reply Good karma+1 vote
evertonj2000
evertonj2000

hi, this is my first time playing sins of a galactic empire i really loved your mod, fighting massive space battles with star wars factions are just amazing! however i have this problem with cis, the munificent class and a couple other class of ships dont have any model details, instead, they are just a grey thing in the shape of the ship. And not long into the game, it just crashes. Is there a fix for these two problems? thanks

Reply Good karma Bad karma+1 vote
evertonj2000
evertonj2000

the grey model problem has been fixed :) but the crash i just have ti every time i play :( and the explosions on ships are expressed by white squares. this time is crashed to desktop without saying "soase had stopped working" :( pls help

Reply Good karma Bad karma+1 vote
Lavo Author
Lavo

If you are getting a crash to desktop without warning, please make sure you have read over the installation instructions in their entirety, in particular the section that talks about Large Address Aware.

Reply Good karma+1 vote
Guest
Guest

thabk you for your reply. i have done what the instruction said aboit the large address aware. but fkr some reason it didnt work. but this time it works! and i had a lot of fun with your mod! great job with the mod!

Reply Good karma Bad karma+1 vote
Lavo Author
Lavo

Glad to hear it's working now.

Reply Good karma+1 vote
Guest
Guest

Hi, I just wanna be sure. After whole instalation the correct and proper status is this?

TXT
Version 0
enabledModNameCount 3
enabledModName "SoGE Addon - Nightmare AI"
enabledModName "SoGE Addon - Reduced Weapon Ranges"
enabledModName "SoGE 4.10.1"

and If i want some special mods i should put then to "enable" in game ? :)

Reply Good karma Bad karma0 votes
Lavo Author
Lavo

Assuming you have those addons and assuming you renamed your mod folder to "SoGE 4.10.1" (as it normally is named "SoGE 4.10.0") then yes that is correct.

Never "enable" a mod in game. Always edit EnabledMods.txt before starting a game; no exceptions.

Reply Good karma+1 vote
Guest
Guest

thank you :) Its awesome, but is here possibility to reduce a number of strike craft? with a max fleet i ve got almost 200 strikecraft...isnt that too much ? im just asking :)

Reply Good karma Bad karma0 votes
Lavo Author
Lavo

Are you using the Squadron Size Reduction addon? It helps a lot with strikecraft numbers.

Reply Good karma+1 vote
RoyalRaptor
RoyalRaptor

This is my first time of hearing of this, there were to many strike craft so I manually went in and just made it so the AI and me couldn't make strike craft. i was annoying as hell. Where can i find this addon? Edit: never mind found it

Reply Good karma Bad karma+1 vote
Guest
Guest

can you use this mod if you have the game on steam

Reply Good karma Bad karma0 votes
Lavo Author
Lavo

Yes

Reply Good karma+1 vote
Guest
Guest

This comment is currently awaiting admin approval, join now to view.

crazy-gigan
crazy-gigan

when i try to extract the mod i get a beep at 99% then when i put it in the folder it crashes before it loads

Reply Good karma Bad karma+1 vote
DeathSummer16
DeathSummer16

I just downloaded the mod and it is amazing, but I have one problem and that is that there is no sound. There was sound and then I updated it with the smaller squadron add on and now there is no sound? is there a way to fix this or do I have to redownload and not have the addon?

Reply Good karma Bad karma+1 vote
Sgt.CDS
Sgt.CDS

WHAT!? I had 54 Munificent-class freighter/cruisers get jumped on by an Executor-class SSD, and a very large amount capital weight Star Destroyers. I focused all 54 onto the SSD 'Hope', and prepared to lose that fleet while I rounded up my other 100 or so Munificents and my two Subjugator-class Super Capitals- only to return to the battle scene and watch in shear amazement as my frigates took out the behemoth laid before them in only a few minutes, if even that, while 'only' sustaining losses of 32 ships. I know the Muni is a powerful little warship, hence why I had over 150 of the little guys, but to have only 54 go toe-to-toe with an Executor-class Super Star Destroyer and it's sizable escort and not only survive, but kill the damn with only 32 losses and no reinforcements? I'm definitely not complaining, mind you, just bewildered, and hopefully bringing this to your attention (Lavo) that the Munis might be putting out more firepower than intended? I do have all of the weapon upgrades and the various armor/health/shield upgrades for my ships; the game has been going on for about two days now. If they're performing as expected.. well I guess I just found out my strat for the CIS then :3

Reply Good karma Bad karma+1 vote
mmeier86 Creator
mmeier86

This is probably working as intended. The Munis have a lot of single target firepower, but they can't attack multiple targets. So, going up against a single large target is actually their thing. Now you said there were a number of SDs too, were they also completely wiped out? And: What about the Imperial attacker, on what technology level were they? If you had full combat research, shielding and armor and firepower would also be doubled, and when your enemy was still rather low...

Reply Good karma+1 vote
Sgt.CDS
Sgt.CDS

I noticed this and payed more attention to my ships and the enemy as the match progressed (I typed out my initial comment right after the event). Indeed, I noticed that unless the enemy ships came within spitting distance of the Munis, then they could only target one at a time. However, with how I tend to micro-manage my fleets, I have them focus fire on the largest warships and work my way down. With the shear raw firepower, the targets tends to go down very quickly, and the Munis only take minimal damage, as I tend to group them in the numbers of 20 and above. Now, the SD escort? I don't exactly remember what happened right after, as the match went on for another few hours (with another Executor falling prey to my fleets) but if I remember correctly I was able wipe out the escort too, but with the help of a 30 ship fleet backup. The enemy at the time kept focusing on building lots of capital class SDs, and lost nearly every engagement. However, the normal difficulty level AI did adapt very quickly after losing the first SSD, and started sending fleets with a LOT of escort carriers, and this started to to prove problematic. I did lose a lot of my Munis this way- but alas it was too late. The two aforementioned Subjugator class warships eventually helped seal the fate of the now late Pentastar Alignment. Looking at the post war/match results, I did notice the enemy had very low military research done, and I mean very low. I wonder if it just focused on getting the SSD and and ignored just about the rest of the tree. It was, as mentioned, just a normal level AI as I'm still coming to grips with the game and the mod, and I apologize if I wasted your time or anything. :P Thank you for this mod and I appreciate your attention and response.

Reply Good karma Bad karma+1 vote
Lavo Author
Lavo

This is a very good thing to bring up in truth. If it weren't for your crushing research advantage, I might very well say the Munis are overpowered. That being said, given that the Munis are single target oriented and given that you had a crushing research advantage, it isn't extremely surprising that you won a victory of this scale. The Munis might need a cost/supply increase, but otherwise they are fairly solid.

Reply Good karma+1 vote
UltimateFIFAGamer10
UltimateFIFAGamer10

Dear Mod Author,
me and my friend are trying to play an online game of sins and we have the same mod version and all that stuff and the mod checksum is different plz help.

Reply Good karma Bad karma+1 vote
jannik2099
jannik2099

make sure you apply the folders in the right order

Reply Good karma Bad karma+1 vote
Lavo Author
Lavo

One of you either has a corrupt mod download or a corrupted Sins install. Both of you should verify your Sins' cache via Steam and then reapply Large Address Aware to the game's exe. After that both of you should redownload both 4.10.0 and 4.10.1 from the NexusMods mirror: Nexusmods.com

Reply Good karma+1 vote
BRF100
BRF100

I just downloaded this mod 4.10.0 and the 4.10.1 patch and installed it just like in the discription it starts with the soge screen but when i want to play a multiplayer game wuth my friends sometimes it crashes when its loading or it starts normaly but after 15 min of gameplay it crashes do you know how i can fix this?? because this mod is really nice and i really want to play it.

Reply Good karma Bad karma+1 vote
Lavo Author
Lavo

Hello, if you are reading this message, it means that you are asking a question that has already been answered via ingame research/ability/unit descriptions or through one of the following documents included with the download and can also be viewed on the SoGE ModDB forum:
Installation Instructions - SoGE 4.10.0
SoGE How to Build Supercaps
SoGE FAQ
SoGE Known Bugs
Please refer to those, thank you!

Further, if you are getting a crash to desktop without warning, please make sure you have read over the installation instructions in their entirety, in particular the section that talks about Large Address Aware.

Reply Good karma+1 vote
Guest
Guest

Hi! We have encoutered a problem in a Multiplayer Coop that when we join each others party, there is a message: This map requires the following DLC to play: String not found. And when we start the game, there is immediate defeat. IS there any problem on our side or just is something wrong installed? Thanks

Reply Good karma Bad karma+1 vote
Lavo Author
Lavo

That's weird, SoGE shouldn't require any DLC... What map were you trying to play on?

Reply Good karma+1 vote
Marrs25
Marrs25

Hi i really enjoy the mod but it repeatedly crashes after 40 minutes of play

Reply Good karma Bad karma+1 vote
Grand_Admiral_Hacks
Grand_Admiral_Hacks

I keep crashing before starting the game. I keep getting the notification:

"There is a 90% chance that you did not properly enable Large Address Aware"

but I did! Please help because I am really confused! This has never happened before.

Reply Good karma Bad karma+1 vote
rabbitron
rabbitron

How do i change the settings to make the ships move slower?

Reply Good karma Bad karma+1 vote
wheelmandan
wheelmandan

ok is the patch now or no im really lost?

Reply Good karma Bad karma+1 vote
wheelmandan
wheelmandan

hey they updated there folder to the 1.84 are you going to updated your mod?

Reply Good karma Bad karma+1 vote
cartermanmcd
cartermanmcd

I've been wondering about this too really I would like to play this again or if you could make a working version for 1.80 but we would rather have a 1.8.4 version

Reply Good karma Bad karma+1 vote
fireofthevoids
fireofthevoids

Some reason now literally every AI turns the color red and some reason i'm that weird lime colored green. No matter what I do, it keeps making me green and everyone else red. How fix?

Reply Good karma Bad karma+1 vote
fireofthevoids
fireofthevoids

Apparently there was a Sins update on June 14th and I believe that's the reason why it's being screwy. Is there any way I can fix this?

Reply Good karma Bad karma+1 vote
Guest
Guest

In your library, right click your game and head into properties. From there select the tab Betas and from there you can switch on over to the previous version v 1.82 for Mod use only. Hope this helps.

Reply Good karma Bad karma0 votes
fireofthevoids
fireofthevoids

Thanks! It worked perfectly!

Reply Good karma Bad karma+1 vote
Post a comment
Sign in or join with:

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.

Follow Report Profile
Icon
Sins of a Solar Empire: Rebellion
Contact
Send Message
Release date
Mod watch
Follow
File
Browse
Files
Report
Report
Share
Related Games
Related Groups