SoGE is a Star Wars Total Conversion for SoaSE: Rebellion with it's roots in the Homeworld 2 mod Star Wars: Warlords which features the two primarily sides of the Galactic Civil War, the Clone Wars, and the Yuuzhan Vong War. The current public version works for Sins of a Solar Empire: Rebellion 1.90 and, with or without, all DLC. Rated #6 players choice in MOTY 2014. An editors choice in MOTY 2015.

Report OUTDATED - SoGE GOG patch for SOASE Rebellion 1.84
Filename
SoGE_GOG_Patch.zip
Category
Patch
Uploader
Lavo
Added
Size
3.27mb (3,433,977 bytes)
Downloads
7,296 (1 today)
MD5 Hash
141ca10b0d857053f4cd02405582f2d4
Embed Button
Embed Widget
Description

Sins of a Galactic Empire GOG patch for Sins of a Solar Empire: Rebellion 1.84; this patch is for those whom have 4.10.0 or 4.10.1 and are on GOG (aka. SoaSE v1.84). It also includes a number of minor tweaks from the latest beta revision.

Preview
OUTDATED - SoGE GOG patch for SOASE Rebellion 1.84
Comments
Guest
Guest

Hey i enjoy you mod alot but this latest patch serious messed something up. I followed your instructions to the letter bug i cant even load the game anymore. the Mod is stuck on the loading/SoGE picture and i looked at my Task Manager to see if it was not responding which is was. And when this happens i have to restart my pc all over. So i dont know what other info to give you but the Mod was working before i added this latest patch. And i cant get the Addons to work either. Im really confused on how its set up.

Reply Good karma Bad karma+1 vote
Lavo Author
Lavo

Do you have Sins on Steam or GOG? If the former, this patch is not for you; installing it will cause issues. It's noted very specifically in the description that this patch is for GOG users.

Reply Good karma+1 vote
Uhler
Uhler

hm i had these issues too if you change the version of sins in the steam Options and try the diffrent ones (also use enlarge adress after each time you changed it so i was able to fixed every problem)
Win 10 64 bit 4k resolution so when this works at mine it should work at yours :DDD cuz 1.83 is not the standard version in steam you've to change it manually.

Reply Good karma Bad karma+1 vote
ashcroft2000
ashcroft2000

Why isn't there a patch for the Steam Version? I can no longer access Rebellion v1.83 (of which my SoaGE is for) and so cannot play it, so I either have to wait or download for v1.82. Any idea on when a Steam patch is coming? Many people use steam and not GOG

Reply Good karma Bad karma+1 vote
wheelmandan
wheelmandan

is there going to be an update for Mods-Rebellion v1.85?

Reply Good karma Bad karma+1 vote
Mandalore331
Mandalore331

Wow nice timing!

Reply Good karma Bad karma+1 vote
BlackDova2012
BlackDova2012

It's on GOG now? I feel old :(

Reply Good karma Bad karma+2 votes
tobogan99
tobogan99

what changes with 1.82?????

Reply Good karma Bad karma+1 vote
aaagaming
aaagaming

mistyped and I cant get rid of comment for some reason

Reply Good karma Bad karma+1 vote
KillerThief
KillerThief

i dont understand how do i install this!!!!!

Reply Good karma Bad karma+1 vote
KillerThief
KillerThief

which do i download ;-;

Reply Good karma Bad karma+1 vote
Lavo Author
Lavo

4.10.0 and 4.10.1 for sure. Plus if you bought SoaSE on GOG, get this patch. This patch is NOT meant for people who have SoaSE on Steam. If you have Sins on Steam DO NOT download this patch!

Reply Good karma+2 votes
Guest
Guest

do you need any other patches before you download to work or can you just install patch 1.83 without the patch 4.10 etc...

Reply Good karma Bad karma0 votes
Lavo Author
Lavo

You need 4.10.0 and should have 4.10.1 as well. Further, this patch is NOT meant for people who have SoaSE on Steam. If you have Sins on Steam DO NOT download this patch!

Reply Good karma+1 vote
Guest
Guest

Star base with full defence does not withstand the attack of even small fleet. Make a database upgrade as the players (jump gates) or simply increase defense points of the planets. But what if the fleet away, the planet is lost through 4 minutes.

Reply Good karma Bad karma0 votes
mmeier86 Creator
mmeier86

Build more starbases. In contrast to vanilla Sins, you can build up to 4 starbases per gravity well. That holds even larger fleets, even when those fleets bring along a (low level) titan. Don't think of starbases as they are in vanilla. A single Golan III, canonically, is not intended to hold off a full scale assault all by its lonesome.

Reply Good karma+1 vote
Mrmode
Mrmode

How come theres no blaster sounds when the ships are firing?

Reply Good karma Bad karma+1 vote
ventdlord
ventdlord

After playing for 10 mins the game crushes.

Reply Good karma Bad karma+1 vote
wheelmandan
wheelmandan

hi can someone tell me are we on patch 10.01 or just 10.0 or 82 or 83 can i get a clear word. on what bloody hell patch sin on now.

Reply Good karma Bad karma+1 vote
Briggsy19
Briggsy19

We are on v1.82 for the game but this patch is meant for GOG players only, which the game is on 4.10.01 due to the other patches after the proper game. But there is now an Opt in v1.83 on Steam, which this patch is meant for, as GOG players have ease access to v1.83 compared to Steam players, which also aren't all too familiar with the Opt in Beta.

Reply Good karma Bad karma+1 vote
ashcroft2000
ashcroft2000

No there isn't a v1.83 version on Steam. I just checked, its only 1.80, 1.82 and 1.84. I have the SOAGE for v1.83 and this is extremely frustrating as my internet is sht

Reply Good karma Bad karma+1 vote
Briggsy19
Briggsy19

Can you send a screenshot?

Reply Good karma Bad karma+1 vote
ashcroft2000
ashcroft2000

How do you post a screenshot on Mod DB. I can't get it to post on this comment

Reply Good karma Bad karma+1 vote
Briggsy19
Briggsy19

+ashcroft2000 I have Steam, and there is a new update to fully update SOASE:R to v1.83 (Hence a patch download requirement that is automatically done by Steam as the default setting) and the Opt in beta's are for other versions then the current version of the game. Hence being v1.82 and v1.84. If you want more proof - Steamcommunity.com - This link states the v1.84 change (for Opt in Beta and obviously the automatic change from v1.82 to v1.83)

Reply Good karma Bad karma+1 vote
ashcroft2000
ashcroft2000

The newest update is to v1.85 not 1.83. The current version is the new one. It doesn't matter anyway now, I've downloaded it for 1.82 and will wait for an update to 1.85 and until I get the new DLC.

Reply Good karma Bad karma+1 vote
simo17
simo17

will this work on steam no its updated?

Reply Good karma Bad karma+1 vote
Guest
Guest

This comment is currently awaiting admin approval, join now to view.

Post a comment
Sign in or join with:

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.

Follow Report Profile
Icon
Sins of a Solar Empire: Rebellion
Contact
Send Message
Release date
Mod watch
Follow
File
Browse
Files
Report
Report
Share
Related Games
Related Groups