Global modification for BFME2 1.06 with Gondor, Mordor, Arnor, Angmar, Mithlond and Rhun. In the final version you can see updated graphic, optimization of performance, a lot of new units and heroes, big stone walls, more realistic ships, artillery and more.

General articles of the mod (click on image to look):


Now you have access to build big might walls and play real epic game! In the article you can see many screenshots of different walls with descriptions and a couple of videos.

TLHotTA 1.0 have really updated graphic with normal-mapping technology. This technology is old enough, but it never fully used in any other mod for BFME series. Nice precision with perfect performance - look on the screens.

And, finally, now I'm working on the patch 1.1 and after I'll be working on the campaign (latest WIP).
  • View media
  • View media
  • View media
  • View media
  • View media
  • View media
Post article RSS Articles

TLHotTA 1.2 Announcement

News


The Lord of the Rings:
The Battle for Middle-Earth II

The Last Hope of the Third Age 1.2



Global modification TLHotTA 1.2 for BFME2 will be released in October 2016. Updated version will include new faction - Iron Hills, improvements and some new things for other factions.

Follow the updates here on ModDB and on the development site - BFME Modding!


See also:

TLHotTA: dwarves

TLHotTA: dwarves

News 3 comments

We have come back and not alone. See more in the news.

TLHotTA 1.1 Released

TLHotTA 1.1 Released

News 6 comments

Modified 1.0 version is already available for download.

Second coming of big walls

Second coming of big walls

News 4 comments

Full detailed and final information about castles in The Last Hope of the Third Age 1.1.

Sky Hammer (Iron Hills)

Sky Hammer (Iron Hills)

News 4 comments

Description of Iron Hills fortress and new screenshots and video.

Add file RSS Files
The Last Hope of the Third Age Demo 1.11

The Last Hope of the Third Age Demo 1.11

Demo 2 comments

This version is Demo of the future 1.2 release. It includes three playable factions: Gondor, Mordor and Arnor. The main change in the 1.11 is improved...

The Last Hope of the Third Age 1.1

The Last Hope of the Third Age 1.1

Full Version 45 comments

TLHotTA 1.1 - final version of the mod, which fully changed the game. The Last Hope of the Third Age is waiting you!

The Last Hope of the Third Age 1.0

The Last Hope of the Third Age 1.0

Full Version 61 comments

Global modification for BfME2 1.06 with four fully original factions and two old updated factions. New graphic and gameplay.

The Last Hope of the Third Age beta 0.31

The Last Hope of the Third Age beta 0.31

Full Version 42 comments

Global modification with six unique factions, four of which created from scratch.

The Last Hope of the Third Age beta 0.3

The Last Hope of the Third Age beta 0.3

Full Version 6 comments

Global modification with six unique factions, four of which created from scratch.

The Last Hope of the Third Age 0.21 beta

The Last Hope of the Third Age 0.21 beta

Patch 1 comment

The patch is placed on the version 0.2b. Installation is similar on mod's install. Small change list: -Sky-on all the maps now received of EA:) Basically...

Comments  (0 - 10 of 737)
andreninpad
andreninpad

Mod can't be launched at 1.06 or even 1.09 patch. Can only be launched by disabling the mod but the music and skins or background is active.

The installer is not English.

Reply Good karma Bad karma+1 vote
Halbarad1996 Creator
Halbarad1996

The mod is for 1.06, not for 1.09 or any other version.
Last demo isn't localized for English, it's right. I wrote this in description.
Previous versions are on English here.

What error do you get when launching mod?

Reply Good karma+1 vote
andreninpad
andreninpad

Is it because I downloaded 1.11, you said isn't localized for English? And my version of BfME2 is in English. Maybe that's the cause of its error. This is the error when launching the mod

[http://i8.photobucket.com/albums/a32/andrex2005/For Purposes/TLHotTA-Launch-Error_zpsxsg7fak6.png]

Reply Good karma Bad karma+1 vote
andreninpad
andreninpad

The TLHotTA launcher can launch unmodded normal game BfME2, if it's disabled. But when enabled, it can't start TLHotTA.

I've already forgot the error message. I wasn't able to screen shot it.

It's a demo right? It means it is still in development process? Hoping for the next update, there's an English installer and compatible with 1.09 patch.

Reply Good karma Bad karma+1 vote
Halbarad1996 Creator
Halbarad1996

Well, you had troubles with launching the mod on your game. I can help you with it.
But it doesn't mean that mod is broken at all)

Reply Good karma+1 vote
andreninpad
andreninpad

I'll try re-installing it by patching BfME2 at 1.06 first. I got that error when installing it during BfME2 is at 1.09 patch.

I've got to ask which is best version of TLHotTA, 1.1 or 1.11?

Reply Good karma Bad karma+1 vote
Halbarad1996 Creator
Halbarad1996

1.1 is big release, which includes many changes and additions (compared to 1.0).
1.11 is just reworked 1.1 with limited factions (3vs6). It has a much better performance, some graphic updates. Also fixed bugs.

So, next version will have the same opportunities as 1.11, but there will be all old factions +dwarves.

Reply Good karma+1 vote
andreninpad
andreninpad

This is the screen shot of the error.

I8.photobucket.com

Reply Good karma Bad karma+1 vote
Halbarad1996 Creator
Halbarad1996

Mm, can't see it. Picture doesn't load.

Reply Good karma+1 vote
andreninpad
andreninpad

This one, copy paste the link inside the bracket in to the address bar of the internet browser.

[http://i8.photobucket.com/albums/a32/andrex2005/For Purposes/TLHotTA-Launch-Error_zpsxsg7fak6.png]

Reply Good karma Bad karma+1 vote
Halbarad1996 Creator
Halbarad1996

Is it 1.06 version of the game? Without any other patches or mods?
Remember this error, the reason is conflict of TLHotTA with any other unofficial stuff.
Disable all fan-modifications except TLHotTA and run it on clear 1.06 original game.

Reply Good karma+1 vote
andreninpad
andreninpad

It's already a 1.06 BfME2 patch and only HD Edition installed in BfME2. I've tried removing HD Edition but error still occurs. The RotWK game has mods installed.

Reply Good karma Bad karma+1 vote
Halbarad1996 Creator
Halbarad1996

Read PM, answered you there.

Reply Good karma+1 vote
andreninpad
andreninpad

Hi! I've tried 1.1 is for English, but still same error with 1.11 at launching the game.

Reply Good karma Bad karma+1 vote
Post a comment
Sign in or join with:

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.

Follow Report Profile
Icon
Battle for Middle-earth II
Developer
Contact
Send Message
Homepage
Bfme-modding.ru
Release date
Mod watch
Follow
Share
Community Rating

Average

6.6

90 votes submitted.

You Say

-

Ratings closed.

Highest Rated (5 agree) 7/10

lol

Aug 26 2012 by kol0183

Style
Twitter

Latest tweets from @bfmemodding

Анонс Total War Saga: Thrones of Britannia #total_war #rts #thrones_of_britannia Bfme-modding.ru

Nov 14 2017

Age of Conquest mod - Эребор Bfme-modding.ru

Sep 17 2017

Автоматический патчер до версии 1.07 (с лаунчером) для BFME 1 #bfme_1 #bfme_1_1.06 #launcher Bfme-modding.ru

Aug 18 2017

Тизер-трейлер стратегии Iron Harvest #iron_harvest #rts #game Bfme-modding.ru

Aug 17 2017

Тизер-трейлер стратегии Iron Harvest #iron_harvest #game #rts Bfme-modding.ru

Aug 17 2017

Age of Conquest mod - Ангмар Bfme-modding.ru

Aug 13 2017

Middle-Earth: Shadow of War - Шелоб #shadow_of_war #lord_of_the_rings #games Bfme-modding.ru

Aug 9 2017

BFME: Classic Edition - новые видеоролики #classic_edition #bfme1 #mods Bfme-modding.ru

Aug 9 2017

BM - 7 лет! Bfme-modding.ru

Aug 8 2017

THE POWER OF THE ONE RING 0.4.9 Bfme-modding.ru

Jul 25 2017

Embed Buttons
Link to The Last Hope of the Third Age by selecting a button and using the embed code provided more...
The Last Hope of the Third Age
Statistics
Last Update
Watchers
202 members
Files
8
Articles
19
Reviews
38