God rays, volumetric light, lens flares & dirt, visor reflections / water drops, depth of field, night & thermal vision scopes, dynamic wet surfaces with reflections, rainbows and many other effects. PATCH AVAILABLE NOW

Report Dynamic Shaders 2.0 CTP
Filename
Dynamic_Shaders_2.0CTP_by_Meltac.zip
Category
Full Version
Uploader
Meltac
Added
Size
12.85mb (13,472,679 bytes)
Downloads
9,502 (2 today)
MD5 Hash
eb7ab1cf64934356159127eb9f6e3402
Embed Button
Embed Widget
Description

Community Technology Preview (CTP) of the long awaited Dynamic Shaders 2.0 mod. See details for more information...

Preview
Dynamic Shaders 2.0 CTP
Comments  (0 - 50 of 75)
slipkid69
slipkid69

Could you please say whether or not these Dynamic Shaders are compatible with other Mods?

Reply Good karma Bad karma-1 votes
Meltac Author
Meltac

Yes, they are. But depending on what other mods you're running it might require some merging (mainly a few script and config files). I'm sorry I didn't have a chance yet to write down any extensive release notes or manual, I will do that asap. For the moment you could check the notes of the older versions of the mod (e.g. DS 1.2).

Reply Good karma+3 votes
nashathedog
nashathedog

Thanks a lot.

Reply Good karma Bad karma+2 votes
Meltac Author
Meltac

I've created an article explaining some more details in the news sections. It's currently awaiting authorization.

Reply Good karma+3 votes
slipkid69
slipkid69

Thanks very much appreciated.

Reply Good karma Bad karma+1 vote
Fr3sh_Hit
Fr3sh_Hit

Any chance for 1.0004 patch? 1.0004 is popular :(

Reply Good karma Bad karma+2 votes
Meltac Author
Meltac

I had an older version of the mod running without flaws on patch 1.0004, so there is a good chance that the new version will work on that patch as well, however I haven't tested it yet. If any, the required changes would probably only affect some scripts but not the shaders or configs, so it shouldn't be too hard to make it run on 1.0004.

Why not just test it and let me know? I'd be eager to provide a patch if required.

Reply Good karma+3 votes
Fr3sh_Hit
Fr3sh_Hit

Ok, i'm test on 1.0004

Reply Good karma Bad karma+2 votes
Fr3sh_Hit
Fr3sh_Hit

It's work on 1.0004, thanks

Reply Good karma Bad karma+2 votes
Meltac Author
Meltac

thanks for testing. I've updated the description :)

Reply Good karma+3 votes
Hegel
Hegel

Ah...I knew there was a reason to get out of bed today!

Reply Good karma Bad karma+1 vote
Anna_Maniac
Anna_Maniac

Just curious, but why 1.0005 and not the more commonly used 1.0006? Not a big deal for me as I keep multiple copies on my drive, but just wondering.

Reply Good karma Bad karma+1 vote
Meltac Author
Meltac

1.0005 is still the most spread and most stable patch. With the original version 1.0006 the devs introduced more problems than the patch solved, unfortunately. Of course, that version has gained a broad audience because the source files have been published (or leaked), so it's much easier to apply engine hacks and extensions. But the latter make inter-mod-compatibility much harder, if even possible, that's why I decided to keep it with the "solid" older 1.0005 version.

But after all the differences are rather small between the two, so it should be fairly easy to make the mod running on 1.0006 as well.

Reply Good karma+2 votes
Fr3sh_Hit
Fr3sh_Hit

How to turn lens flares?

Reply Good karma Bad karma+1 vote
Meltac Author
Meltac

Unfortunately my news article containing detailed information about the mod has not yet been authorized by the admins, so I repeat it here:

The lens flares need to be configured per light source, they are not generically on all light sources as in some other mods or games. So far I have configured them only for the Agroprom Underground level, and there only on a few specific lights. The task of defining lights to apply flares on all levels to is still open.

Reply Good karma+2 votes
strelokgunslinger
strelokgunslinger

I will continue to figure out what is going on but I get this familiar issue I.imgur.com

Reply Good karma Bad karma+1 vote
strelokgunslinger
strelokgunslinger

Even reinstall to 1.04 to test, no luck.. will try new drivers next..

specs are gtx 970, i7 4770, w7 x64

Reply Good karma Bad karma+1 vote
strelokgunslinger
strelokgunslinger

pastebin of xray.log Pastebin.com

Reply Good karma Bad karma+1 vote
strelokgunslinger
strelokgunslinger

ok.. so to get it working I had to change the renderer in the user.ltx it wasn't launching with dx8

Reply Good karma Bad karma+1 vote
Meltac Author
Meltac

Glad you got it working.

Reply Good karma+1 vote
dave_5430
dave_5430

I didn't get it to work. Help?

Reply Good karma Bad karma+1 vote
Fr3sh_Hit
Fr3sh_Hit

What cause this bugs? I.imgur.com I.imgur.com

Reply Good karma Bad karma+1 vote
Fr3sh_Hit
Fr3sh_Hit

And this bug: I.imgur.com

Reply Good karma Bad karma+1 vote
Meltac Author
Meltac

The first two look like a graphical glitch from the (not yet finalized and perfected) wet surfaces effect. Try to disable it or lower its intensity in ShaderSettings.txt.

The third picture is the old, well-known shadow bug from (vanilla) SoC, nothing that DS 2.0 would have introduced but apparently some of my changes tend to pronounce this bug for some reason that I couldn't figure out yet. You could try playing with (at least, increase) shadow resolution in the file common.h or ShaderSettings.txt, but that probably won't eliminate the issue completely. I'll check that when I'll get a chance to.

Reply Good karma+1 vote
Fr3sh_Hit
Fr3sh_Hit

Thanks!

Reply Good karma Bad karma+1 vote
Fr3sh_Hit
Fr3sh_Hit

And have last question :D How to config shaders for dynamic hud from: Yadi.sk

You mod is epic, you are BIG modder :D

Reply Good karma Bad karma+1 vote
Meltac Author
Meltac

Thanks.

The dynamic hud mod places a texture overlay over the regular in-game hud and doesn't include any shader changes, so it could easily be used additively. Depending on which texture overlay you are using, you might want to disable the black border of my visor shader, though. This can be done in ShaderSettingsVisor.txt, simply adjust the "blackness" while leaving the other settings as they are. One thing that is not possible of course is to show my visor effects (such as reflections and water drops) only on those parts of the hud that haven't been damaged.

Reply Good karma+1 vote
Fr3sh_Hit
Fr3sh_Hit

Dynamic hud from link is not working, doesn't have reflections and water drops. Why?

Reply Good karma Bad karma+1 vote
Fr3sh_Hit
Fr3sh_Hit

Sorry, for the exo and sciencefit outfit is working, but for specops_outfit and military_outfit is not working

Reply Good karma Bad karma+1 vote
Meltac Author
Meltac

Then it's probably just a case of configuration. You need to add the names of the suits in question to visor_control.script (need the suit's internal name, not the one displayed in game, you might need to google it). I have added there only a few suits with visors (such as exo and ecolog), but more can be added easily.

Reply Good karma+1 vote
Szabby999
Szabby999

Hi!

I install STALKER SHOC, I patch it to v10006, than I install Dynamic Shaders 2.0, but when launching the game I only get black screen... ???

Reply Good karma Bad karma+1 vote
Meltac Author
Meltac

Sent you a PM...

Reply Good karma+1 vote
dmo9001
dmo9001

I get the same thing, black screen and the log file is empty. Steam v10006 version.

Reply Good karma Bad karma+1 vote
lowenz
lowenz

It's the shader compiling process.....it takes some time :D

Reply Good karma Bad karma+1 vote
Meltac Author
Meltac

and much less time if you have a SSD :)

Reply Good karma+1 vote
Guest
Guest

This comment is currently awaiting admin approval, join now to view.

Aximiron
Aximiron

many flights, especially _hr, and for a long time to load, wait for the patch.
Sorry for my English, I from Russia

Reply Good karma Bad karma+1 vote
Meltac Author
Meltac

I don't know what you mean by "many flights", but I haven't had any issues with _hr stuff. And load times probably won't get much faster, even with a patch (but sure I'll check it).

Reply Good karma+1 vote
Fr3sh_Hit
Fr3sh_Hit

I have bug, it's white edged trees XD Pic: Imgur.com

Reply Good karma Bad karma+1 vote
Meltac Author
Meltac

Interesting. Never seen this. Most probably a result of the merge that you obviously have done. Have you tested the mod stand-alone?

Reply Good karma+1 vote
Fr3sh_Hit
Fr3sh_Hit

Yes, and don't have this o.O Maybe gloss_factor?

Reply Good karma Bad karma+1 vote
Meltac Author
Meltac

Unlikely. Must be something else. Try running the mod stand-alone with all default settings and no external components such as ENB or any modded binaries (besides those from the mod itself).

Reply Good karma+1 vote
Aximiron
Aximiron

Why so long to boot?

Reply Good karma Bad karma+1 vote
Meltac Author
Meltac

Because SoC (unklike CoP) compiles all the shaders on every game launch, start of a new game, or loading a savegame - and since this is a shader mod which does much more than most of the other mods shader-wise, there is much to be compiled in these cases.

Either getting a faster (or at least much better optimized) system, especially HDD, or disabling some features of the mod, are the only two things that can be done about this.

Reply Good karma+1 vote
Zacam
Zacam

I happened to discover (while perusing through how to integrate into Complete) that xglass2.s has a typo in it (also exists in 1.2)
Line 17: texture is typed as textur
No idea what impact that may/may not have, but reporting it for you all the same.

Reply Good karma Bad karma+1 vote
Meltac Author
Meltac

Thanks for reporting this. I will check.

Reply Good karma+1 vote
dave_5430
dave_5430

Pixel shader 1.1 error.

Launched in R2.
Disable SSAO.
Installed kb2670838 (because you said DX11), while this is generally frowned upon by the stalker community.

Nothing works.

Why?

GTX 260, latest drivers.

Can play Pixel Shader 1.1 games.

Reply Good karma Bad karma+1 vote
Meltac Author
Meltac

Have you 1. read the release notes, and 2. tried using the user.ltx file in the separate download? Also, have you tried with all original settings (without changing any settings like SSAO)?

Basically the "Pixel shader 1.1" error can have many causes and doesn't need to be a problem with your GPU or drivers. Often it occurs when there's a syntax error in one of the shader files (or in the ShaderSettings files), so you might want to try the initial downloaded files prior to apply any changes.

Reply Good karma+1 vote
Junra
Junra

Any chance of seeing this awesomeness ported to Clear Sky? :)

Reply Good karma Bad karma+1 vote
Meltac Author
Meltac

Not from my side at least, unfortunately I don't have time for such. But maybe some friendly fellow modder might help you out here...

Reply Good karma+1 vote
Post a comment
Sign in or join with:

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.

Follow Report Profile
Icon
S.T.A.L.K.E.R. Shadow of Chernobyl
Creator
Meltac
Contact
Send Message
Release date
Mod watch
Follow
File
Browse
Files
Report
Report
Share
Related Games
S.T.A.L.K.E.R. Shadow of Chernobyl
S.T.A.L.K.E.R. Shadow of Chernobyl First Person Shooter