FEATURES:

1) Civil Protection Officer and Overwatch Soldier's AI heavily improved.
2) NPC's aggressiveness and intelligence are now affected depending on difficulty. On Easy, enemies are amateurish and on Medium & Hard, your enemies are more challenging.
3) Difficulty settings no more affect how much damage players will receive and deliver. Ammo boxes quantity is still affected however.
4) Your weapons are slightly more accurate and efficient.
5) Allied Combine Forces: Combine NPCs who fight alongside the Resistance.
6) Antlion and Resistance co-existence: now you can storm Nova Prospekt with your rebel friends without having them slaughtered by your own Antlions. This applies to the Allied Combine forces too!
7) Almost every Resistance fighter can now be killed by the player on Anticitizen One and Follow Freeman chapters!
8) Resistance fighters no longer remind you to reload all the time.

Requires Half-Life 2 and Source SDK Base 2007.

HOW TO INSTALL THE MOD:

1) Make sure you own Half-Life 2 and have the game installed.
2) Install Source SDK Base 2007.
3) Place "Badass_Combine_HL2" folder in "sourcemods" folder. Generally, for Windows users, it's located in
- 32-bit Windows: "c:\program files\steam\steamapps\sourcemods"
- 64-bit Windows: "c:\program files (x86)\steam\steamapps\sourcemods"
4) Execute the batch file for your desired Windows bit version. You MUST have Half-Life 2 and Source SDK Base 2007 installed in order to work.
- 32-bit Windows: 32bit_HL2_Maps_To_Source_SDK_Base_2007
- 64-bit Windows: 64bit_HL2_Maps_To_Source_SDK_Base_2007
The batch file will copy all HL2 maps to Source SDK Base 2007, allowing you to play all HL2 maps within the mod.
5) Restart Steam. The mod should be available in your Steam's library.

  • View media
  • View media
  • View media
  • View media
  • View media
  • View media
RSS Articles

For the next release, not only you'll be able to play the entire HL2 saga (Half-Life 2, Episodes One and Two), but also be capable of easily integrate my mod into other mods as well.

Below, a list of compatible, yet recommended mods you can integrate Badass Combine into them:

HL2: Aftermath
HL2: Deep Down
HL2: Calamity
Eye Of The Storm
Depot
Forest Train
Joutomaa
MINERVA: Metastasis (NOT the steam version)
Mission Improbable
Overflow
Powerstation 17
Project 25
Random 17
Sebastian
Station 51
The Citizen Returns
The Forgotten Journey
The Masked Prisoner
Year Long Alarm
CombineBaseVille
HunterVille
RaiseTheBarVille
RooftopVille
SniperVille
StriderVille

The video below demonstrates footage of my mod integrated in other mods.


The new version will no more require Source SDK Base 2007. Instead, it will require Source SDK Base 2013 Singleplayer to be played with.

While the version isn't out yet, save yourself some time by doing the following procedures bellow:

1) Open your Steam's Library, then change the list to 'TOOLS'.
2) Search for Source SDK Base 2013 Singleplayer.
3) Upon finding the tool, right-click it and select the 'Properties' option.
4) Click on the "Betas" tab, then switch to "upcoming - " on the list of available betas.
5) Close the tool's Properties windows and install Source SDK Base 2013 Singleplayer.

If you really want to, you can download the compatible mods on the links above.

Badass Combine v0.1 Released!

Badass Combine v0.1 Released!

News 2 comments

No more waiting! The first release version is available. Now go kick some Combine butt.

Badass Combine v0.1 Announced

Badass Combine v0.1 Announced

News 4 comments

Badass Combine will be released on June 12. Stay hyped!

Badass Combine News #3

Badass Combine News #3

News 7 comments

Antlion and Resistance/Allied Combine coexistence, allied CPs + ability to use AR2 and shotgun, less robotic AI alert reaction and expanded difficulty...

Badass Combine News #2

Badass Combine News #2

News 3 comments

Police brutality has been given a whole new meaning.

RSS Files
Badass Combine v0.1

Badass Combine v0.1

Full Version 4 comments

Requirements: Half-Life 2 and Source SDK Base 2007.

Comments  (0 - 10 of 73)
guywithahevsuit
guywithahevsuit

is this compatible with hl2 update?

Reply Good karma Bad karma+1 vote
Guest
Guest

This comment is currently awaiting admin approval, join now to view.

MODSUX
MODSUX

Really need this to be compatible with Update

Reply Good karma Bad karma+1 vote
empleat
empleat

This mod doesn't work anymore ??? What update ? Shouldn't this work on source engine 2007, if it is meant for it ? Also couldn't downloading older version from steamdb fix this problem ?

Reply Good karma Bad karma+1 vote
Guest
Guest

This comment is currently awaiting admin approval, join now to view.

Guest
Guest

I have some uplifting news (even though its from 2 years ago). the mod dev said it wasn't said just put on hold

Reply Good karma Bad karma+1 vote
Guest
Guest

This comment is currently awaiting admin approval, join now to view.

Stevie-Akers
Stevie-Akers

this better be the case

Reply Good karma Bad karma+1 vote
weaponsmith
weaponsmith

What?

Reply Good karma Bad karma0 votes
Stevie-Akers
Stevie-Akers

So much potential just gone in an instant.

Reply Good karma Bad karma+1 vote
Post a comment
Sign in or join with:

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.