Revamp Expansion Mod (RVE) The Ultimate Supreme Commander 2 Experience (New Scale, New Units, New Ability's, New Game)

Forum Thread
by member
  Posts  
Research Tree (Mods : Revamp Expansion Mod (RVE) : Forum : Mod Creation Help : Research Tree) Locked
Thread Options
Mar 30 2013, 12:11pm Anchor

Well, now I have this in the right place, and a lot more space to write stuff. So I suppose I'll be a little bit more detailed...

So far, I have (more or less) added and textured fairly simple units already. They all work fine and do what they need to do. But now, to make some of them playable, I need to mod the research tree. Despite the multitude of guides on the GPG forums, I'm still wondering how you do it. The guides are perfectly clear on how the research tree files work, and how to code for the research tree, but not so much so on what to do after you are done with all that.

I'm gearing my mod to be a sort of addon to revamp, so I don't want to have any conflicting files. (That means I don't want make a "multimod" .scd file like revampt did.) That means, I assume, that I should just have a lua directory in my own .scd. So I put all the necessary files in that lua directory, in the right places, and tried to add one researchable technology, but that didn't change anything. So next I tried going into the lua.scd in my /gamedata folder and modifying the research tree there. I added my one tech, but then the game wouldn't start. So THEN I added my mod as a part of the revamp mod (I put it in the same .scd) and modded the already modified lua.scd in revamp's mod files. Then I added revamp to the game, but the game still woudn't launch. Hmph.

As said before, all my code should be perfect. (I modified Research.lua, DefaultBuildRestrictions.lua, and research_layout.lua, if that's any help.) However, my computer seems to hate me, or I'm doing something terribly wrong (I'd put my money on the latter) and I'm just not noticing it. Any ideas?

Mar 30 2013, 1:01pm Anchor

Some files in SC2 are un-hookable because there loaded as soon as you start the game instead of when your start a match, The research files are in this list of un-hookable files so the only way to mod these files are to replace them instead in the lua and dlc scds, You can do this by using winrar up to version 4.01 any newer version wont work correctly with scd files.

Edited by: OverRated

Mar 30 2013, 6:07pm Anchor

Well, I got the research tree working. Getting the older version of winrar did the trick. However, my plight is not yet over. I have the research working, but I cannot get the unit (experimental air) to build now. So far, I have...

A) Made sure the cats in the research is 'AIRGANTRYBUILDER',
B) Changed the .bp files of the exp. air gantry to include '[my unit]' in 'categories' and '[my unit] MOBILE' in 'BuildableCategory',
C) Added my unit to the build restrictions as 'categories.[my unit]', and added BuidlRestrictionsRemoval = { [my unit] }, in the research.lua file. 
D) Made the categories for my air unit include "AIRGANTRYBUILDER' and '[my unit]'.

EDIT: I just tried the whole research thing again, but this time with a structure that I added, and it works just fine. So the question is, as stupid as it sounds, how exactly do I make a unit buildable by a gantry? I would think that the "AIRGANTRYBUILDER' category would be enough, but apparently not...

I'm pretty sure that that more or less covers it. Is there anything that I'm forgetting? Well, more the question, what am I forgetting?

Edited by: ALBINOsnowball

Mar 30 2013, 10:12pm Anchor

You need to do a bp merge and add the units ID to the ganties buildablecats they don't work the same as a factory does.

Mar 30 2013, 11:12pm Anchor

I had already done that manually, and still no luck. I edited it in bp.scd, and if my unit is UUX0410, I'm assuming it should look like this:

BuildableCategory = {
            'C230STARKING MOBILE',
            'AIRFORTRESS MOBILE',
            'AC1000 MOBILE',
            'UUX0410 MOBILE',
        },

Of course, 'UUX0410' is also present in the categories list of both the gantry and the unit.

Mar 30 2013, 11:28pm Anchor

No its ether unit id or cats so try giving it a name like the others and adding that name to the units cats as well.

Mar 30 2013, 11:41pm Anchor

Okay. I am entirely stumped. Here's what Ive done (this might be long)(also, my unit is the Imperium, id UUX0410):

In my unit's cats:
    'AIRGANTRYBUILDER'
    'IMPERIUM'
In the air gantry's cats:
    'IMPERIUM'
In the air gantry's buildable categories:
    'IMPERIUM MOBILE'
In Research.lua (in both lua scds):
    UAU_IMPERIUM = {
        NAME = 'Imperium',
        TIME = 0,
        COST = 20,
        ENERGY = 0,
        MASS = 0,
        INFO = 'Unlock the \'Imperium\' Experimental Gunship',
        CATS = 'AIRGANTRYBUILDER',
        BuildRestrictonRemoval = {
            'IMPERIUM',
        },
        PREREQUISITES = 'UAU_GUNSHIP',
        tip_affects = 'Built By: Air Gantry',
        tip_type = 'Unit Unlock',
    },
In DefaultBuildRestrictions.lua (in both lua scds):
    categories.uux0410, -- Imperium

What am I forgetting??????? Or where did I go wrong??

Edited by: ALBINOsnowball

Reply to Thread
click to sign in and post

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.