Revamp Expansion Mod (RVE) The Ultimate Supreme Commander 2 Experience (New Scale, New Units, New Ability's, New Game)

Forum Thread
by member
  Posts  
Gantries (Mods : Revamp Expansion Mod (RVE) : Forum : Mod Creation Help : Gantries) Locked
Thread Options
Mar 31 2013, 10:22pm Anchor

I figured it would be best to move this conversation to a different thread, for both the purpose of organization and to make it easier for anyone else interested in the subject.

For some reason (my total lack of knowledge about what I am doing :) ) I cannot get my units to be built by gantries. Despite all the previous, very-easy-to-follow help. Is there any way that it could be dumbed down just a tad more?

Here is what I am doing:

In the gantry's cats :
    'MYUNITNAME'
In the gantry's buildable cats:
    'MYUNITNAME MOBILE'
In the unit's cats (land unit):
    'MYUNITNAME'
    'LANDGANTRYBUILDER'

I was pretty sure that that would cover it, and make the gantry able to build the unit. Obviously, there is something I'm doing wrong. Or am I doing it right and repeatedly missing an error in the code? That just as likely...

Again, sorry for all this. After I understand this, I'm hoping for no more questions in a while (but, of course, no promises...).

Apr 1 2013, 12:18pm Anchor

Post them up so i can look over them to see if you have missed any think your cats should be fine.

Apr 1 2013, 1:39pm Anchor

Okay, here they are. For this, I am using Total Mayhem's Marksman Experimental Sniper Tank.

The blueprint for the tank: Pastebin.com

The blueprint for the gantry: Pastebin.com

Thanks for your help. I know it must get irritating to put up with all my questions after a while. Also, entirely off-topic; I was looking through the revamp files, and I noticed the original atlantis! I, personally, would love to see it in RVE 1.1b2, even as pointless as it is. In any case, I've enabled it in my own mod.

Also, I know that there is unnecessary code in this. I just figure, if the code doesn't do anything, why take the trouble to remove it?

Apr 1 2013, 5:41pm Anchor

All you forgot was a comma on the end of your units name in the gantry's buildable cats it should be like below. Yer the code wont affect any think but normally i clean my unit bps up also clean gpgs bps as well -_- .

lua code:
            'MARKSMAN MOBILE',

Edited by: OverRated

Apr 1 2013, 5:56pm Anchor

Ugh! I hate it when I do that! :flame:

Well, I have learned an important lesson. Never forget your commas. Of course, I thought that the error in the code would mean that you couldn't build the gantry...

Actually, I still don't have it working. I added the comma, but....still no luck. Meh.

EDIT: Yep. I've been trying, but still no luck with the gantries, even with the comma fixed. Any ideas on what else it could be? (I wonder how I got it to work before....?)

Edited by: ALBINOsnowball

Apr 2 2013, 3:12am Anchor

You shouldn't be replacing it any ways you need to do a merge for the gantry like so, also you need the mod support mod for this to work as it uses a custom input method.

lua code:
UnitBlueprint {
    Merge = true,
    BlueprintId = "uub0011",
    AddCategories = {
        MARKSMAN = true,
    },
    AddBuildableCategory = {
        ['MARKSMAN MOBILE'] = true,
    },
}
Apr 2 2013, 11:47am Anchor

Actually, it was much simpler. Of course, I have no doubt your method will work, but what I was doing was much more stupid. I was editing the gantry's blueprint in the .bp scd, with the DLC enabled. Silly me....

Reply to Thread
click to sign in and post

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.