An expansion/overhaul mod of epic proportions, with entirely rebalanced gameplay, expanded factions, new gametypes, graphical overhauls, and five new factions; stealth-based Confederate Revolutionaries, tower defense-inspired Atomic Kingdom of China, economy-focused Mediterranean Syndicate, DotA-esque Order of the Talon and spammy Electrical Protectorate.

Forum Thread
by member
  Posts  
need help launching from steam (Mods : Red Alert 3 Paradox : Forum : Technical Issues/Bug Reporting : need help launching from steam) Locked
Thread Options
Jul 6 2012, 1:13pm Anchor

so my friend just downloaded red alert 3 from steam and he cannot play the paradox mod because when ever he launches the mod, it just goes back to the game browser. we have tried doing the adding the non steam game thing and adding -ui to the command line but the mod still does not launch. we have also tried to put the -ui in the original shortcut in the steam library and it still does not launch. when we tried launching the vanilla game using the -ui shortcuts it still goes back to the game browser thing. we can still play the vanilla game fine by using the original shortcut that does not have the -ui added,

Jan 21 2013, 12:57am Anchor

I am having a similar problem i launch the game and it shows the launch screen then after about 30 seconds just closes out and im left looking at desura again.
any suggestions on how to fix this i also have the game on steam.

Edited by: yamuumage

GearsGoAwryMan
GearsGoAwryMan bizzare mastermind
Mar 8 2013, 11:01am Anchor

That's a bummer. I'll ask around, but i don't think we have ever solved this problem yet. Try posting in the general page (go to summary, scroll down, and post a line there). chances are you will get some feedback.

A quick search of the FAQ's show that some releases did work on steam, but on the whole, steam and mods is a bit of a weird matter.

Mar 8 2013, 11:08am Anchor

Try to copy the RA3 folder (updated to 1.12) to a new directory and launch it, then try the mod. Sometimes the Steam programm or other DL manager may interfere because it views mods as foreign files and blocks them. At least this usually worked with mods for GensZH.

Mar 11 2013, 8:08pm Anchor

thanks for the reply

Reply to Thread
click to sign in and post

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.