The Zone of Alienation mod is an adaptation of the renowned AMK mod. It is built on top of a specialized variant of AMK that uses a magazine system. From this premise, it has expanded to aim to include the following:

Forum Thread
by member
  Posts  
CTD Extravaganza. (Mods : Zone of Alienation mod : Forum : CTDs (Game Crashes) : CTD Extravaganza. ) Post Reply
Thread Options 1 2 3 4
Feb 8 2013, 9:58pm Anchor

Fun fact: Crashes are not always bad, I often use them as a helpful part of the development process. Mr. CTD can oftentimes be your friend.

In this thread we post our current hiccup involving the X-Ray engine, I will try to solve it, in the way that only the blind can lead the blind.

Feb 9 2013, 10:29pm Anchor

I had written a post about XR_3DA crashing when loading a hardsave.

My solution no longer works since it now does it on an autosave I have; so I'm looking into it to see if I can solve it, if I can I will edit this post once again.

Edited by: IamStrelok

Feb 9 2013, 11:28pm Anchor

I've had very few problems with ZoA, but here's a couple I can remember off the top of my head.The most recent crashing problem I've had is in the Army Warehouses. Basically, if I quicksave in a certain area, the save gets fucked and whenever I load it the game crashes. I'm almost certain this is only because of the 100+ vibrating mutant bodies immediately surrounding the place where I quicksaved, so to fix this problem I just won't save there. I really hope mutant bodies despawn.
The second crash was quite a while ago, but it's happened multiple times with two different weapons. It first happened way back in Cordon when I tried to load a PPSH mag. The second I stopped loading it (either by canceling or by finishing/running out of ammo to load), the game would crash. I stopped using the PPSH altogether, but then it happened again in the bar after coming back from Yantar, only this time with the Bizon's magazines. The second I finished loading, crash. It also happened with STANAG mags once, but corrected itself immediately afterwards.
Sadly, these were a while ago and I don't have a crash log on-hand. The next time I encounter this sort of crash I'll try to remember to post crash log here instead of just looking at it and trying to deduce on my own what's wrong.

Feb 10 2013, 3:28pm Anchor

Just going to add here that I have occasionally experienced crashes when finding a controller in the wild, though this seems less common in more recent versions.

Is mildly annoying because the only solution involves killing it before it can cause the error (I think maybe it's an attack animation, often happens when it's surrounded by a pack of blind dogs).

Feb 10 2013, 5:07pm Anchor
Norinvaux wrote:I'm almost certain this is only because of the 100+ vibrating mutant bodies immediately surrounding the place where I quicksaved, so to fix this problem I just won't save there. I really hope mutant bodies despawn.

The second crash was quite a while ago, but it's happened multiple times with two different weapons. It first happened way back in Cordon when I tried to load a PPSH mag. The second I stopped loading it (either by canceling or by finishing/running out of ammo to load), the game would crash.


I think the first one is related to object collisions. i.e. too many physics objects colliding, causing the game to crash. Mutant bodies do indeed despawn, so saving in a part of the map where the bodies are offline alife objects is what I would advise.

I think the second crash might be related to bad tree arrays in the magazine.ltx file in the ammo folder. I might not have corrected mag loading arrays for all of the weapons, especially ones with newer ammunition types like 7.62x39 and 7.62x51.

I also know that this same bug exists for one of the Saiga's mags, and it's been fixed so far.



jrgl_cuchallain wrote:Is mildly annoying because the only solution
involves killing it before it can cause the error (I think maybe it's an
attack animation, often happens when it's surrounded by a pack of blind
dogs).


This is correct, this is a vanilla game error in SoC with the
controller;s animations, it frequently shows up as dBodyStateValide(b)
in the crash log.

I usually avoid getting this crash by killing
any controllers on sight as soon as I know they are in the area, but
this tool can help as well, it kills them through a command.

ZRP controller kill function for AMK/ZoA
Pastebin.com

Edited by: FatalFunnel

Feb 21 2013, 3:12pm Anchor

I have a big problem:
FATAL ERROR [error]Expression    : xml_result[error]Function      : CXML_IdToIndex::InitInternal[error]File          : e:\stalker\patch_1_0004\xr_3da\xrgame\xml_str_id_loader.h[error]Line          : 162[error]Description   : error while parsing XML file[error]Arguments     : info_amk_recipts.xml 
stack trace:
Please help me :)

Edited by: pvtneo66

Feb 21 2013, 10:34pm Anchor
pvtneo66 wrote:I have a big problem:
FATAL ERROR [error]Expression    : xml_result[error]Function      : CXML_IdToIndex::InitInternal[error]File          : e:\stalker\patch_1_0004\xr_3da\xrgame\xml_str_id_loader.h[error]Line          : 162[error]Description   : error while parsing XML file[error]Arguments     : info_amk_recipts.xml 
stack trace:
Please help me :)


I don't know the cause of this either, don't know why it wouldn't parse that file, or why it would be an argument. Strange.

Edited by: FatalFunnel

Feb 22 2013, 5:50am Anchor

FatalFunnel ! What do I do? :dead:

Feb 22 2013, 1:28pm Anchor
pvtneo66 wrote:FatalFunnel ! What do I do? :dead:

Well first off, it seems to be a bug with parsing that .xml file The first thing you can do is open the file it lists and see if it has anything in there.

It's almost impossible to do troubleshooting over the internet, but is this error on loading a save, or starting a game?

I see that you're using the correct patch version for the game, since it lists it as 1.0004, and it's not a dialog error. Since I can't replicate this crash I can't really find a way around it other than make suggestions on what it might be, or what might fix it.

Okay, so first troubleshoot it like this.

make a copy of info_amk_recipts.xml
delete the original
load up game, test to see if it crashes
if it crashes, rename the original so that it uses that.
If it crashes again, it could either be something wrong with the script, or an installation error, the second of which might require you to re-download the mod and reinstall all the patches in order again, but first you could probably just try re-installing the patches, and don't forget to comment out the zoa_flash_infos.ltx from the items.ltx file.

Feb 23 2013, 2:26pm Anchor

I'm also getting CTD's at cordon in the rookie camp there's a military squad of 4 men that keep on attacking the camp so I'll try to defend the camp by sitting on the little berm that separates the camp from the checkpoint, anyway I take out a few guys then the BMP starts shooting at me and pinning me down with such terrible lag that the game crashes.

Mar 5 2013, 9:39am Anchor

Just for the record I repost this into the forum.
It´s a crash which happend to my german version.

[error]Expression : fatal error
[error]Function : CStringTable::Load
[error]File : E:\stalker \patch_1_0004\ xr_3da\xrGame\string_table.cpp
[error]Line : 53
[error]Description :
[error]Arguments : string table xml file not found
string_table_includes.xml, for language eng

stack trace:
------------------------------------------------
Btw this is an error which doesnt let the game start at all, i found out its due to different language version, in my case i have the german version.

Solution:

If you have other language versions, you need to go to gamedata\config\localization.ltx and change the language to your version in my case to ger.

Then go to Gamedata\config\text and copy the "eng" folder paste it in the same directory and rename the new one to your language in my case "ger". So you will have 2 folders in the text folder, one is "eng" and one in your language.

Mar 5 2013, 4:39pm Anchor
na1344462961 wrote:Just for the record I repost this into the forum.
It´s a crash which happend to my german version.

[error]Expression : fatal error
[error]Function : CStringTable::Load
[error]File : E:\stalker \patch_1_0004\ xr_3da\xrGame\string_table.cpp
[error]Line : 53
[error]Description :
[error]Arguments : string table xml file not found
string_table_includes.xml, for language eng

stack trace:
------------------------------------------------
Btw this is an error which doesnt let the game start at all, i found out its due to different language version, in my case i have the german version.

Solution:

If you have other language versions, you need to go to gamedata\config\localization.ltx and change the language to your version in my case to ger.

Then go to Gamedata\config\text and copy the "eng" folder paste it in the same directory and rename the new one to your language in my case "ger". So you will have 2 folders in the text folder, one is "eng" and one in your language.


Thank you.

Mar 5 2013, 5:12pm Anchor

Hey i have a minor problem with CTDs.
Expression    : fatal errorFunction      : CScriptEngine::lua_errorFile          : E:\stalker\sources\trunk\xr_3da\xrGame\script_engine.cppLine          : 73Description   : Arguments     : LUA error: ... of chernobyl\gamedata\scripts\dialog_manager.script:393: attempt to compare number with nil
I have been playing other mods on this Steam copy of the game and haven't had any problems, so i think i have not followed instructions properly. 
I am having problems with the downgrading from 1.0005 (the other mods needed that patch). I tried to follow the instructions from here Moddb.com 
but have not been able to find any items in the specific STALKER-SHOC registry folder.
Everytime i load a saved game it CTDs and gives me the error message specified above.
Thanks

Mar 5 2013, 7:31pm Anchor
skyline3237 wrote:Hey i have a minor problem with CTDs.
Expression    : fatal errorFunction      : CScriptEngine::lua_errorFile          : E:\stalker\sources\trunk\xr_3da\xrGame\script_engine.cppLine          : 73Description   : Arguments     : LUA error: ... of chernobyl\gamedata\scripts\dialog_manager.script:393: attempt to compare number with nil
I have been playing other mods on this Steam copy of the game and haven't had any problems, so i think i have not followed instructions properly. 
I am having problems with the downgrading from 1.0005 (the other mods needed that patch). I tried to follow the instructions from here Moddb.com 
but have not been able to find any items in the specific STALKER-SHOC registry folder.
Everytime i load a saved game it CTDs and gives me the error message specified above.
Thanks


Did you delete gamedata.dbc after downgrading?

Mar 5 2013, 8:57pm Anchor

nope, and that was the problem. Thanks FatalFunnel!

Mar 10 2013, 1:48am Anchor

I have installed the mod correctly to my knowledge; however i get a ctd when starting a new game its not immediate but has occurred the 3 times Ihave tried at first with sidorovich when accepting mission to help wolf and the end of the dialogue and then with wolf when saying that you will help help him crashing when i click on "I'll try."

Exception Reason:  XR_3DA.exe caused ACCESS_VIOLATION in module "C:\Program Files (x86)\Steam\steamapps\common\STALKER Shadow of         Chernobyl\bin\xrGame.dll" at 0023:066624C3

Registers: EAX=00000000  EBX=55D97F40  ECX=0018D6A8  EDX=0018D6E0 ESI=55D97F54  EDI=00000000  FLG=00210212 EBP=0018D700  ESP=0018D69C  EIP=066624C3 CS=0023  DS=002B  SS=002B  ES=002B  FS=0053  GS=002B
 
Stack Trace: .....\bin\xrGame.dll
 

if needed i can post the log

Edited by: Holykalo

Mar 10 2013, 11:20pm Anchor
Holykalo wrote:I have installed the mod correctly to my knowledge; however i get a ctd when starting a new game its not immediate but has occurred the 3 times Ihave tried at first with sidorovich when accepting mission to help wolf and the end of the dialogue and then with wolf when saying that you will help help him crashing when i click on "I'll try."

Exception Reason:  XR_3DA.exe caused ACCESS_VIOLATION in module "C:\Program Files (x86)\Steam\steamapps\common\STALKER Shadow of         Chernobyl\bin\xrGame.dll" at 0023:066624C3

Registers: EAX=00000000  EBX=55D97F40  ECX=0018D6A8  EDX=0018D6E0 ESI=55D97F54  EDI=00000000  FLG=00210212 EBP=0018D700  ESP=0018D69C  EIP=066624C3 CS=0023  DS=002B  SS=002B  ES=002B  FS=0053  GS=002B
 
Stack Trace: .....\bin\xrGame.dll
 

if needed i can post the log


Please post log, crash cause could also be ascertained by Ctrl+V-ing in notepad.

I had to deal with something worse this morning, a few lines in a lone config file were causing a crash that was leaving me with no log, so I had to test the game without a mod folder, then trace my steps backwards until I figured out the cause.

Mar 11 2013, 3:36am Anchor

also it crashes on the 6-7 dialogue choice no matter who i speak too  i cant post a drop box link for the log and and if i don't its a wall of text when pasted into this site.

Edited by: Holykalo

Mar 11 2013, 4:24pm Anchor
Holykalo wrote:also it crashes on the 6-7 dialogue choice no matter who i speak too  i cant post a drop box link for the log and and if i don't its a wall of text when pasted into this site.

Ah, dialog choice, this is definitely sounding like game patch version incompatibility. Did you make sure to follow this guide?

Downgrading Your SoC from 1.0005+ to 1.0004

Also, even if you've done that, you need to delete gamedata.dbc, since that isn't used in 1.0004.

Edited by: FatalFunnel

Mar 12 2013, 1:34am Anchor

thank you it worked i didn't delete the game data files upon downgrade :(

Mar 12 2013, 3:44am Anchor

Hi All!

I have a problem starting the game after copying the gamedata folder into the stalker soc directory.

I installed the non-steam version, updated to 1.0004, then tried to run the game and it worked. However after "installing" the 1.05 of this mod, it becomes unstartable: after the splash screen the so-feared (by me :)) "XR_3DA.exe stopped working" message arrives. There are no logs, and I also tried using some command line arguments like "-nointro".
Even if I copy all patches (1.06a, 1.06b, 1.07 proto) it remains the same.

If I remove the gamedata folder, it will work again.

I also found, that if I remove (or rename) the textures folder, the game starts and I can reach the main menu (which looks ugly in this case, of course).

Does someone have any idea?

Thanks in advance!

Cheers!

Mar 12 2013, 2:26pm Anchor

Try editing one of the true | false values in fsgame.ltx I think. By what you've said the mod shouldn't be incompatible with your patch / game version, it could also be crashing due to a localization issue, if that's the case you could change the language to eng in the localization.ltx, or simply copy the gamedata/text/eng files over to what folder your game typically uses.

Mar 12 2013, 6:10pm Anchor
FatalFunnel wrote:Try editing one of the true | false values in fsgame.ltx I think. By what you've said the mod shouldn't be incompatible with your patch / game version, it could also be crashing due to a localization issue, if that's the case you could change the language to eng in the localization.ltx, or simply copy the gamedata/text/eng files over to what folder your game typically uses.


Hi!

Unfortunately I've already tried these, do you have any other tips by the chance?

Thanks for the answer anyway!
Cheers!

Mar 12 2013, 8:12pm Anchor
emze wrote:
FatalFunnel wrote:Try editing one of the true | false values in fsgame.ltx I think. By what you've said the mod shouldn't be incompatible with your patch / game version, it could also be crashing due to a localization issue, if that's the case you could change the language to eng in the localization.ltx, or simply copy the gamedata/text/eng files over to what folder your game typically uses.


Hi!

Unfortunately I've already tried these, do you have any other tips by the chance?

Thanks for the answer anyway!
Cheers!


No, I got nothing, damn. :(

It's hard to tell what's wrong when there isn't a crash log.

Mar 13 2013, 2:59am Anchor
FatalFunnel wrote:
emze wrote:
FatalFunnel wrote:Try editing one of the true | false values in fsgame.ltx I think. By what you've said the mod shouldn't be incompatible with your patch / game version, it could also be crashing due to a localization issue, if that's the case you could change the language to eng in the localization.ltx, or simply copy the gamedata/text/eng files over to what folder your game typically uses.


Hi!

Unfortunately I've already tried these, do you have any other tips by the chance?

Thanks for the answer anyway!
Cheers!


No, I got nothing, damn. :(

It's hard to tell what's wrong when there isn't a crash log.



Interesting, I also fiddled with the steam version, and it seems to be working. :-)
At starting a new game, I got an out of memory error (2 GB RAM), but the -noprefetch seems to be solving it.

Cheers!

Reply to Thread
click to sign in and post

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.