First Strike is a Star Wars total conversion modification for Battlefield 2142. The goal of First Strike is to totally immerse the players into the amazing universe of Star Wars by presenting the most accurate representations of famous Star Wars locales, weapons, and characters, and combining them with exciting, fast paced gameplay and features new to the Battlefield scene. Within this mod you'll find yourself as a soldier of the Galactic Empire or as a freedom fighter for the Rebel Alliance. You'll fight across lovingly detailed recreations of various Star Wars locations with a wide array of weapons and vehicles.

Report content RSS feed First Strike Now BF2142 v.1.51 Compatible

We are happy to announce that First Strike is now fully compatible with Battlefield 2142 version 1.51. Today we are releasing an update which will allow your launcher to work no matter which version (on-line, original or deluxe) of BF2142 you have. Just run First Strike as you normally would and an auto-update will take care of everything...

Posted by on

Greetings Troopers!


We are happy to announce that First Strike is now fully compatible with Battlefield 2142 version 1.51. Today we are releasing an update which will allow your launcher to work no matter which version (on-line, original or deluxe) of BF2142 you have. Just run First Strike as you normally would and an auto-update will take care of everything. Also don't worry if you've performed the temporary manual fix we suggested to get you up and running and make First Strike compatible with BF2142 1.51, that will not effect this update in the slightest.

So now please enjoy the freedom of disc free play, and we'll see you out there troopers.

Comments
Cpt.Dann
Cpt.Dann

Wiil you also make servers for 1.51?

Reply Good karma Bad karma+1 vote
TALON_UK Author
TALON_UK

No need to make servers, the only change required is that the servers update to BF2142 1.51, the First Strike code stays the same. More of an issue is availability of Linux (which a lot of servers use) unranked server files for 1.51, but the links for these files are starting to surface now, so anyone running a First Strike/BF2142 server using Linux should now be able to update their server.

Runekn, what is it that doesn't download for you? The First Strike launcher update?

Reply Good karma+1 vote
Runekn
Runekn

updated but still want cd :(

EDIT: seems like it cant download, im getting an error 400

Reply Good karma Bad karma+1 vote
Marvin_hun
Marvin_hun

it works for me. I updated bf2142 to 1.51 and start the mod

Reply Good karma Bad karma+1 vote
Post a comment
Sign in or join with:

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.

Icon
Battlefield 2142
Contact
Send Message
Homepage
Fsmod.com
Release date
Mod watch
Start tracking
News
Browse
News
Share
Related Games
Battlefield 2142
Battlefield 2142 First Person Shooter
Related Groups
First Strike Development Team
First Strike Development Team Developer & Publisher with 9 members
Star Wars Fan Group
Star Wars Fan Group Hobbies & Interests with 991 members