Crossfire continues the epic adventures of Edison Trent. Get ready for a brand new experience in a breathtaking and extraordinary environment. This mod is the unofficial sequel to Freelancer with the most stunning graphics and worlds you have ever seen. Jump into an atomspheric universe full of surprises, challenges incredible adventures. Experience the awesome gameplay, highest quality and unique features of Crossfire. With several hundred thousand downloads, four Mod Award Nominations and it's very large fan community Crossfire has developed to one of the most favorite Singleplayer and Multiplayer mods for Freelancer.

Report Crossfire Mod 1.7 Client Version
Filename
CFsetup17.exe
Category
Full Version
Uploader
SWAT_OP-R8R
Date
Size
195.86mb (205,377,700 bytes)
Downloads
35,502 (2 today)
MD5 Hash
ce35611f4600848f8180478d2b25e549
Embed Button
Embed Widget
Description

This is the download of the Crossfire mod version 1.7 For years this release of Crossfire has been one of the most successful Freelancer mods.

Preview
Crossfire Mod 1.7 Client Version
Comments  (0 - 50 of 91)
tdpritchard
tdpritchard

i downloaded it, installed it, then tried activating it but it brings up an error message...

Reply Good karma Bad karma+3 votes
magnet14
magnet14

and what is the message?

Reply Good karma Bad karma+1 vote
goodone
goodone

new crossfire players:

patch 1.7a is IMPORTANT, so plz install it, if u r installing crossfire from start, as a step 8a in the installation instructions on the crossfire troubleshooting guide.

Reply Good karma Bad karma+1 vote
Guest
Guest

This comment is currently awaiting admin approval, join now to view.

SWAT_OP-R8R Author
SWAT_OP-R8R

then you didnt follow the installation instructions correctly

use a clean installation of FL and use FLMM 1.31

Reply Good karma+3 votes
xlogic
xlogic

Where do I find the instructions???

Reply Good karma Bad karma+1 vote
goodone
goodone

u can find the instructions on tutorials page.

Reply Good karma Bad karma+2 votes
SteveCopeFHG
SteveCopeFHG

Its working!!! :-)

Reply Good karma Bad karma+2 votes
SteveCopeFHG
SteveCopeFHG

i downloaded, it was a different ammount each time and it came with an error messege when i try clicking the icon so its not to do with fl and the other mods so im downloading using db's downloader.
also upgrade ur lancersreactor mod profile okay!

Reply Good karma Bad karma+2 votes
shamim
shamim

How are people? i am a big fan of this game .i love to travel those systems very much .please help with these questions .can i play crossfire 1.7 and discovery mods in single player mode?do they require me to install FLMM and which version ?there are 30+ mods. which ones let player buy battle ships ,transport train and if so can i travel directly from one system to another using battle ship without going through jump holes or gates .which mods give me more new ships to buy including battle ships and more new systems to travel (in single player mode) recomend please.when i download any mod using dap it shows download is resumeable but my internet connection sometimes gets disconected so when i try to resume incomplete download form dap it says after trying to connect servers that the download file is not there so i have to start a new download again?it happened when i tried to download crossfire 1.7 twice.why i cannot resume?i am new to using mod .so any advice about using mods particularly for single player mode will be welcome .ow last word i would love to see freelancer 2 . Thanks in advance. Shamim from Bangladesh.

Reply Good karma Bad karma+2 votes
assault911
assault911

yes you can play single player in the discovery mod id recommend v4.84 as docking and undocking battleships has no problems and has lots!!! of ships to fly plus 60 something new systems to visit, you need fl mod manager v1.4 beta 4 to run it. i don't know about this mod as iv just found a download manager so i can download it disconnect from the internet and finish it another time thanks to a friend. look on google you might find it there.:)

Reply Good karma Bad karma-1 votes
masternerdguy
masternerdguy

also make sure that you dont turn on the EBNS series of effects.

Reply Good karma Bad karma+1 vote
shamim
shamim

How are people? i am a big fan of this game .i love to travel those systems very much .please help with these questions .can i play crossfire 1.7 and discovery mods in single player mode?do they require me to install FLMM and which version ?there are 30+ mods. which ones let player buy battle ships ,transport train and if so can i travel directly from one system to another using battle ship without going through jump holes or gates .which mods give me more new ships to buy including battle ships and more new systems to travel (in single player mode) recomend please.when i download any mod using dap it shows download is resumeable but my internet connection sometimes gets disconected so when i try to resume incomplete download form dap it says after trying to connect servers that the download file is not there so i have to start a new download again?it happened when i tried to download crossfire 1.7 twice.why i cannot resume?i am new to using mod .so any advice about using mods particularly for single player mode will be welcome .ow last word i would love to see freelancer 2 . Thanks in advance. Shamim from Bangladesh.

Reply Good karma Bad karma+2 votes
SWAT_OP-R8R Author
SWAT_OP-R8R

either you didnt have a clean installation of FL installed or you use a wrong flmm version
FLMM 1.31 is required since FLMM 1.4 is bugged

Reply Good karma+3 votes
SWAT_OP-R8R Author
SWAT_OP-R8R

yes you can play in singleplayer

Reply Good karma+3 votes
{LP}Knightshade*{X}
{LP}Knightshade*{X}

hiho OP good job with this mod all of u who enjoy this mod plz join the swat community at swat-portal.com

Reply Good karma Bad karma+3 votes
AdamF
AdamF

You have to use a fresh installation of Freelancer and the Freelancer Mod Manager 1.31

Reply Good karma Bad karma+2 votes
maicdave
maicdave

i just downloaded the mod, i installed it all corectly and it worked.......the first time, and thats it, everytime i try and play it a second time it never works, it says could not install update only single player available so i try singleplayer but a message pops up saying multiplayer dnt work, im so confused

Reply Good karma Bad karma0 votes
SWAT_OP-R8R Author
SWAT_OP-R8R

check the official Crossfire forum at www.swat-portal.com
there you will find an explaination

Reply Good karma+3 votes
goodone
goodone

simply the best mod for freelancer.

Reply Good karma Bad karma+3 votes
assault911
assault911

HELP!!!!!!!!!!!! i keep getting this error when i finish activating this mod after installation. the application failed to initialize properly (0xc0000005), Click on OK to teminate the application... i got this error when i cut and paste crossfire mod 1.70 client edition from the crossfire file in the mods file Error: problem activating 'Crossfire Mod 1.70 Client Edition' Look in the log for more details. Do you wish to restore backups?(strongly recommended) i have re-installed freelancer and crossfire this has not worked i have free lancer mod manager v1.4 beta 4 and v1.3 on disk which one shoud i use, is v1.4 incompatible?! is there way to install crossfire and be able to change the startup settings it comes up with the name crossfire in mod manager but has no startup options and when fully loaded the (0xc0000005) pops up and when i cut the real mod in the crossfire file and paste it in the mods folder, once i fully activate the mod the other error pops up listed above, have i done somthing wrong? did i install it in the wrong directory?,if u have any spare time can you please help me or please tell me someone who does. it took 7hours to download and i really really want to play it!!!!! i am usually on at 9pm to 2 am NZ time if you need more info type in the comment box and ill be right on it.

Reply Good karma Bad karma+2 votes
assault911
assault911

whew!!! got it going it,s amazing!! i have never seen so many new features in a mod!!!

Reply Good karma Bad karma+1 vote
Tharros
Tharros

How did you fix that error? I am getting the same one with FLMM v1.31.

Reply Good karma Bad karma+1 vote
BubonicDragoon
BubonicDragoon

How'd you stop that "Error: problem activating 'Crossfire Mod 1.70 Client Edition' Look in the log for more details. Do you wish to restore backups?(strongly recommended)" thing from showing up?

Reply Good karma Bad karma+1 vote
assault911
assault911

question does this mod have it's own campaign story line?

Reply Good karma Bad karma+1 vote
SWAT_OP-R8R Author
SWAT_OP-R8R

it has a quest based story line

Reply Good karma+2 votes
assault911
assault911

how do i play it?

Reply Good karma Bad karma+1 vote
SWAT_OP-R8R Author
SWAT_OP-R8R

read the storyline chapters of the readme and you will find out where to start

Reply Good karma+2 votes
assault911
assault911

thanks

Reply Good karma Bad karma+2 votes
assault911
assault911

do i play the original campaign first?

Reply Good karma Bad karma+1 vote
goodone
goodone

if u have activated the mod in regular campaign mode, then yes. on the other hand, if u have activated it using opensp, then u don't have regular fl campaign anyway, so u can proceed searching for cf based content.

Reply Good karma Bad karma+2 votes
assault911
assault911

i was reading though the old comments. it sed something about two to three new system's/sector. are they system's with system's in it? if so how do i get there. thank you putting up with me.

Reply Good karma Bad karma+1 vote
assault911
assault911

i was reading though the old comments. it sed something about two to three new system's/sector. are they system's with system's in it? if so how do i get there. thank you for putting up with me.

Reply Good karma Bad karma+1 vote
goodone
goodone

there is an entire new sector in cf, named altair. and there r many systems, both in altair and sirius. about how to get to them: plz check op's reply to ckyrules at cf mod db mainpage.

if u r not into exploring, it would b best to join cf community in swat forums to get u started.

Reply Good karma Bad karma+2 votes
assault911
assault911

thanks

Reply Good karma Bad karma+3 votes
Stan3k
Stan3k

I can't get out of New York. It keeps giving me a blue screen. Please help. stop error 0x0000007f and 0x0000007c

Reply Good karma Bad karma+1 vote
SWAT_OP-R8R Author
SWAT_OP-R8R

deactivate the 3d sound

Reply Good karma+1 vote
RefusedStone
RefusedStone

Any chance you guys could make this work with A. The speed mod from FLMM and B. The Adv. Beams Weapons mod from FLMM? I know it's possible because I've used those mods with other total conversions for FL...

Reply Good karma Bad karma+1 vote
SWAT_OP-R8R Author
SWAT_OP-R8R

its intentionally incompatible with those mods
we dont like cheaters

Reply Good karma+1 vote
RefusedStone
RefusedStone

I meant for SP, anyways. I don't like having to sit there for 20 minutes to get across a system. If thats called cheating, well... Right, no insults, I don't want to be kicked from this site.

Reply Good karma Bad karma+1 vote
NW_DJW
NW_DJW

Working on New Server that can be accesed by all who have installed this Patch.

Server info and website URL will be provided soon.

If you want acces mail me @ NW_DJW@Hotmail.com

Reply Good karma Bad karma+1 vote
SWAT_OP-R8R Author
SWAT_OP-R8R

and why do you think you would have a permission to run this mod on your server?

Reply Good karma+1 vote
goodone
goodone

wtf? :D
op will not like this, lol!

why not just come to crossfire and invite ur friends too, there's room for everybody?

Reply Good karma Bad karma+1 vote
dieukuk
dieukuk

what is the patch for, Windows Vista? it says a different Os version next to it?

Reply Good karma Bad karma+1 vote
SWAT_OP-R8R Author
SWAT_OP-R8R

different windows versions before windows vista are meant
vista is pure crap and its hard to get normal FL running on it... even harder to code working FL mods and tools for it

Reply Good karma+1 vote
ninjaboy
ninjaboy

ye vista is pure crapp coz its not letting me run crossfire =( ive installed both fresh versions of fl nd flmm 1.31 nd it does load to the crossfire mod laucher but if i click singleplayer vista just shuts the program down nd says is normal ****** error mssgs how do i get crossfire to work... i know i had it working one time i jus dunno y its not workin now? =S

Reply Good karma Bad karma+1 vote
ninjaboy
ninjaboy

hehe its working, i guess i was a bit impatiant to play crossfire

Reply Good karma Bad karma+1 vote
ninjaboy
ninjaboy

how do i get the connection to work to connect to the crossfire server? do i need that global network workaround patch?

Reply Good karma Bad karma+1 vote
SWAT_OP-R8R Author
SWAT_OP-R8R

normally CF does automatically connect to the server
but when you run vista there might be problems with the firewall or with antivir tools such as norton which simply block every connection

Reply Good karma+1 vote
StormyBras
StormyBras

Just wanted to say: "thank you for this mod", it works great and it looks great (specialy juni, lol). no problems installing it, except my antivir got ****** so i turned it off.
I enjoy playing freelancer again!! . Now i just need Internet so i can play on the server :P
THANKS once again

Reply Good karma Bad karma+3 votes
Post a comment
Sign in or join with:

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.

Follow Report Profile
Icon
Freelancer
Game
Freelancer
Developer
SWAT Development
Contact
Send Message
Release date
Mod watch
Follow
File
Browse
Files
Report
Report
Share
Related Mods
Related Games
Freelancer
Freelancer Futuristic Sim
Related Groups
SWAT Development
SWAT Development Developer & Publisher