Crossfire continues the epic adventures of Edison Trent. Get ready for a brand new experience in a breathtaking and extraordinary environment. This mod is the unofficial sequel to Freelancer with the most stunning graphics and worlds you have ever seen. Jump into an atomspheric universe full of surprises, challenges incredible adventures. Experience the awesome gameplay, highest quality and unique features of Crossfire. With several hundred thousand downloads, four Mod Award Nominations and it's very large fan community Crossfire has developed to one of the most favorite Singleplayer and Multiplayer mods for Freelancer.

Report content Crossfire Mod 1.7a patch
Filename
CF17aPatch.exe
Category
Patch
Uploader
SWAT_OP-R8R
Date
Size
4.46mb (4,676,085 bytes)
Downloads
151,501 (2 today)
MD5 Hash
938f370f7a988dda833f2eec2d337a65
Embed Button
Embed Widget
Description

This Patch for Crossfire 1.7 does fix a codepage issue with different OS version. The Crossfire 1.7a Patch is an optional update for players which have problems with the automatic update of the Crossfire 1.7 mod.

Preview
Crossfire Mod 1.7a patch
Comments  (0 - 50 of 71)
FabiVKH
FabiVKH

Thx. But i have a new PC and crossfire don't start.
-> msenet.ocx <-
component "msenet.ocx" or one of it dependencies not correctly rigistred: a file is missing or invalid. can you help me?

Reply Good karma Bad karma+1 vote
assault911
assault911

this might work but its irratating.unstall freelancer and cross fire then mod manager v1.3then look for any directorys to these files delete them so your pc is clear of freelancer and any files of that kind .id recommend you defrag your pc at this time, then install freelancer then mod manager v1.3 and then cross fire,that's how i got it going on mine. one mistake i did is i made a backup of mod manager using the cut and paste technique from my programs file and puting it on disk,and when using it as a backup it'll work but it wont install properly witch means cross fire wont install properly as well, so it's best to use the installation setup file for mod manager.

Reply Good karma Bad karma+2 votes
Guest
Guest

This comment is currently awaiting admin approval, join now to view.

SWAT_OP-R8R Author
SWAT_OP-R8R

type this into a cmd line:
"regsvr32 c:/Program Files/Microsoft Games/Freelancer/Exe/MSInet.ocx" (adjust to ur Freelancer path)

usually this component is installed with windows but we experienced that this is sometimes not the case O_o

Reply Good karma+1 vote
BubonicDragoon
BubonicDragoon

Whats a cmd line?

Reply Good karma Bad karma+1 vote
Guest
Guest

This comment is currently awaiting admin approval, join now to view.

goodone
goodone

new crossfire players:

this patch is IMPORTANT, so plz install it, if u r installing crossfire from start, as a step 8a in the installation instructions on the crossfire troubleshooting guide.

Reply Good karma Bad karma+1 vote
Guest
Guest

This comment is currently awaiting admin approval, join now to view.

Guest
Guest

This comment is currently awaiting admin approval, join now to view.

RefusedStone
RefusedStone

Error: problem activating 'Crossfire Mod 1.70 Client Edition'
Error: SHCopyFile failed ('C:\Program Files\Microsoft Games\Freelancer\EXE\spcontent.dll.flmmbak' to 'C:\Program Files\Microsoft Games\Freelancer\DLLS\BIN\content.dll')

Do not want Error.
Do want Crossfire.
Help please. ):

Reply Good karma Bad karma0 votes
RefusedStone
RefusedStone

Er. Was going to post this in the other download, the actual mod. Oh well...

Reply Good karma Bad karma0 votes
SWAT_OP-R8R Author
SWAT_OP-R8R

use flmm 1.31 (no other version)
use a clean installation of FL (delete the directory and install again)

Reply Good karma0 votes
RefusedStone
RefusedStone

Huh. I'll try that then. I was using a clean install of FL (Was having some other problems with it from another mod, the Wing Commander one was crashing to desktop every time I killed an enemy fighter, wtf. BUT, I was using FLMM v1.4 because another mod said it was needed. Hopefully it'll work when I get the time.

Reply Good karma Bad karma+1 vote
RefusedStone
RefusedStone

Wiped FL from my PC along with FLMM and all files having anything to do with them, have reinstalled both, am downloading Crossfire, again, now. If it doesn't work I blame you... Or Microsoft, because they're easier to blame for PC troubles. =D

Reply Good karma Bad karma+1 vote
RefusedStone
RefusedStone

Weeee. Installed, activated, now I must test. One question: What happened to Perfoptions.ini? I must edit difficulty because I blow unless I have a joystick. And... I only do SP so it's not like cheating... So... What did you do to the file? D8

Reply Good karma Bad karma+1 vote
RefusedStone
RefusedStone

Wait a minute... Ignore last comment, forgot you had to start and save a game before perfoptions was even created. Dx I'm such a moron...
Why must I patch? I want to play single player, and the launch button is active... but I click. And crossfire mod launcher closes and nothing happens.

Reply Good karma Bad karma+1 vote
RefusedStone
RefusedStone

And now my last comment.

New ships - win
New outfits - win
Highway To The Dangerzone - win
New HUD, menu, and cursors - win
Having to uninstall everything and reinstall just to change mod options - fail
Not being able to use the speed mod in SP - fail (Any chance you could tell me how to fix that so I can go fast? One thing I hate about the game and most mods is the slow-*** speeds, even with cruise engines)

Then win still outways the fail. Great job, guys. (& gals, if applicable o_o)

Reply Good karma Bad karma+2 votes
goodone
goodone

well, now u should write a short review and post it here, so everybody can read it. :D or just wait for 1.8, get blown out of the sky and review as an angel. :D

regarding 'clicking launch and crossfire launcher closes and nothing happens', please alt-tab to minimized accept eula window (it gets minimized after launcher starts the game, microsoft's fault).

regarding reinstall: will b fixed with 1.8 (i'm working on it).

regarding modding: u must b advanced modder, many things r possible, but there r some that r not.

Reply Good karma Bad karma+1 vote
RefusedStone
RefusedStone

I need the speed mod at least ;o; I hate going so slow. Thats one of the problems with almost every space combat sim out there; You go so unrealisticaly slow that it's amazing you can even dog fight.

Reply Good karma Bad karma+1 vote
InterAirplay
InterAirplay

I click on "launch Singleplayer"... After 3 fesh installs I finally get it launched... then the button does nothing.

I've tried Alt-Tab - no "minimised EULA window\" - just nothing happens. The launcher closes, nothing whatsoever.

:(:(:( PLease help me, kind sir.

ooh, also, in my task manager the launcher appears to still be running, but I can't see it anywhere. And no matter how hard I try, I simply can't make it visible. All I get is a little bar with "CF launcher" on it...

Reply Good karma Bad karma+1 vote
SWAT_OP-R8R Author
SWAT_OP-R8R

have you removed old savegames?

Reply Good karma+1 vote
sour_sugar
sour_sugar

i have deleted the old saved games. but still i cannot open single player mode.

I click on "launch Singleplayer"... After 3 fesh installs I finally get it launched... then the button does nothing.

I've tried Alt-Tab - no "minimised EULA window\" - just nothing happens. The launcher closes, nothing whatsoever.

ooh, also, in my task manager the launcher appears to still be running, but I can't see it anywhere. And no matter how hard I try, I simply can't make it visible. All I get is a little bar with "CF launcher" on it...

Reply Good karma Bad karma+1 vote
goodone
goodone

well, most of the modding is not acceptable, due to the licence. maybe op will reconsider making sp portion of the mod independent from anti-cheating protection in 1.8, but u will have to stick around and see.

it's not impossible, but given cf is mainly mp mod, it may not happen.

on the other hand, i suggest u to try mp. u don't know what u r missing, m8. :D

Reply Good karma Bad karma+1 vote
dogeddie
dogeddie

Is it ok if I installed patch 1.7a as step 9a of the installation guide rather than step 8a? I didn't do the launcher updates till after I had the patch, though.

Reply Good karma Bad karma+1 vote
goodone
goodone

since u need patch 1.7a to b able to patch the client from the server's new address, it won't matter if it is 8a or 9a, but should b done if u don't get updates at all (may happen without it).

anyway, patch 1.7a is only a simple crossover between updates, cause it gets updated too with launcher updates.

Reply Good karma Bad karma+1 vote
SWAT_OP-R8R Author
SWAT_OP-R8R

some people need the patch others dont
it simply depends on where those ppl are living and which language they speak
when you receive update the launcher should update itself to the newest version aswell

Reply Good karma0 votes
nymphia
nymphia

you know i have never had any problems with FLMM i can turn a mod off and on in a few seconds
if i want to try a new mod i just turn off the one on and turn the new one on

Reply Good karma Bad karma+1 vote
nymphia
nymphia

[kicks myself] why do i say things like that

Unable to find /mods subcategory

whats going on

Reply Good karma Bad karma+1 vote
nymphia
nymphia

oh well problem fixed
see you all in crossfire

Reply Good karma Bad karma+1 vote
nymphia
nymphia

Unable to find \mods subdirectory!
it seems that this only appears at the end of crossfire instal
when it opens FLMM

Reply Good karma Bad karma+1 vote
nymphia
nymphia

0 files restored and 0 directories deleted
Error: problem deactivating 'Crossfire Mod 1.70 Client Edition'
Warning: Unable to un-rename file; 'C:\Program Files\Microsoft

Reply Good karma Bad karma+1 vote
nymphia
nymphia

i don't under stand its only your mod that does this

Reply Good karma Bad karma+1 vote
nymphia
nymphia

i uninstalled freelancer and mod manager and than reinstalled
them am now running freelancer

Reply Good karma Bad karma+1 vote
silentsurfer
silentsurfer

Kan i activate this after i have played crossfire and deactivate the mod and reaactivate it and will it still work

Reply Good karma Bad karma+1 vote
Guest
Guest

This comment is currently awaiting admin approval, join now to view.

InterAirplay
InterAirplay

I install this mod, and it doesn't activate properly.
I re-activate. Nothing.
I re-install the mod. Nothing.
I re-install freelancer and FLMM. Still nothing.
I re-install FL and FLMM and Crossfire WITHOUT the 1.7a patch and it ACTUALLY ACTIVATES PROPERLY!
I did a little dance, then clicked on the "Launch Single Player" button in the Crossfire Launcher. Once again... Nothing.

I looked at all the solutions provided for people who have also had this problem with the launcher, and none of them work for me...

Can anyone help me? sorry for hassling. =]

Reply Good karma Bad karma+1 vote
Guest
Guest

This comment is currently awaiting admin approval, join now to view.

muhrip
muhrip

Hi,
I Just Downloaded the client version and the Patch an when I run "flmm" when loading says:
--------------------
'Crossfire Mod 1.70 Client Edition' successfully loaded
Warning: mods should not contain files that end in .flmmbak (to fix, remove all the *.flmmbak files from this mod's directory)
Reading mod script...
Parsing mod script...
Found mod: \Freelancer Mod Manager\mods\Crossfire1.70
--------------------
So I removed the.flmmbak part of the file.
Now it is saying:
--------------------
Error: problem activating 'Crossfire Mod 1.70 Client Edition'
Error: SHCopyFile failed ('\Freelancer\EXE\spcontent.dll.flmmbak' to '\Freelancer\DLLS\BIN\content.dll')
--------------------

What should I do next??


Were installed today, Both.
2007_07_06_CFsetup17.exe
2007_12_11_CF17aPatch.exe

Reply Good karma Bad karma+1 vote
sour_sugar
sour_sugar

Hey! i hav got a problem in freelancer crossfire1.7. when i open it(single player)nothing happens. it shows an hourglass and it disappears. what can i do................

Reply Good karma Bad karma+1 vote
Guest
Guest

This comment is currently awaiting admin approval, join now to view.

SWAT_OP-R8R Author
SWAT_OP-R8R

1.7 is currently not supported

Reply Good karma+1 vote
sour_sugar
sour_sugar

so what should i do..................

Reply Good karma Bad karma+1 vote
Guest
Guest

This comment is currently awaiting admin approval, join now to view.

SWAT_OP-R8R Author
SWAT_OP-R8R

try the new version

Reply Good karma+1 vote
sour_sugar
sour_sugar

which is the new version........................
can you give me its website.

Reply Good karma Bad karma+1 vote
sour_sugar
sour_sugar

hey i got the FREELANCER CROSSFIRE 1.7a CLINT VERSION. it;s working now. but the problem is i cant get any mission. i cant meet june. what may be the problem.

Reply Good karma Bad karma+1 vote
Guest
Guest

This comment is currently awaiting admin approval, join now to view.

Guest
Guest

This comment is currently awaiting admin approval, join now to view.

Guest
Guest

This comment is currently awaiting admin approval, join now to view.

Guest
Guest

This comment is currently awaiting admin approval, join now to view.

Post a comment
Sign in or join with:

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.

Icon
Freelancer
Game
Freelancer
Developer
SWAT Development
Contact
Send Message
Release date
Mod watch
Start tracking
Download
Browse
Downloads
Share
Related Mods
Related Games
Freelancer
Freelancer Futuristic Sim
Related Groups
SWAT Development
SWAT Development Developer & Publisher