A modification for Rise of the Witch-king that enhances gameplay, improves and adds onto existing factions, and adds new ones.

Add file Report Age of the Ring Patch 1.1 (2.02 v7 Compatibility)

This patch has been archived by the uploader because it is out of date and no longer supported. We recommend you browse the file list for the latest patch.

Filename
AgeOfTheRing_Setup1.1Fix.exe
Category
Patch
Uploader
RiderOfRohan
Added
Size
512.51mb (537,408,242 bytes)
Downloads
3,646 (2 today)
MD5 Hash
12ba0fe7a092231752df3df951c1fe5a
Embed Button
Embed Widget
Description

Contains fixes to ensure compatibility with the new 2.02 v7 patch as well as all AotR 1.1 changes. NOTE: This is NOT the Lothlórien release.

Preview
Age of the Ring Patch 1.1 (2.02 v7 Compatibility)
Comments
Vandil
Vandil

hm...but lorien would have been great :D :P

Thx anyways, this way game makes even more fun!

Reply Good karma Bad karma+3 votes
Someone90
Someone90

I can only find patch 2.02 v6

EDIT: nvm, I clicked the link and found it.

Reply Good karma Bad karma+1 vote
RiderOfRohan Author
RiderOfRohan

Man you really live up to your username.

Reply Good karma+3 votes
Someone90
Someone90

Indeed. I decided to change it though.

Reply Good karma Bad karma+1 vote
MathijsRevora Creator
MathijsRevora

That's a shame.

Reply Good karma+3 votes
Someone90
Someone90

Either way, nothing works.

Reply Good karma Bad karma+1 vote
treefoz
treefoz

That's a lot of good changes. Love your work. :)

Reply Good karma Bad karma+1 vote
kingsjewel
kingsjewel

I have to uninstall the earlier 2.02 version?
Edit: And can I delete the previous AotR Patch 1.1.?

Reply Good karma Bad karma+1 vote
MathijsRevora Creator
MathijsRevora

You don't have to do either of those things.

Reply Good karma+1 vote
kingsjewel
kingsjewel

But the previous AotR patch and this are same, so I don't need both installer (or yes?)
I have 2.02 v6.0 's installer, I can't delete it? Is it necessary if I should reinstall the game?

Reply Good karma Bad karma+1 vote
MathijsRevora Creator
MathijsRevora

They're not the same. You're overthinking it. Just install 2.02 v7 and the AotR version that we uploaded today. It fixes some crashes that occur with 2.02 v7.

I don't think v6's installer is necessary to reinstall the game and patch to v7. You didn't need v5, v4, v3, v2, or v1 to install v6 as far as I'm aware.

Reply Good karma+2 votes
kingsjewel
kingsjewel

thank you!

Reply Good karma Bad karma+1 vote
alenoguerol
alenoguerol

i installed the 2.02 V7 patch but the installers says its not installed.
i dont get it...

Reply Good karma Bad karma+2 votes
Guest
Guest

This comment is currently awaiting admin approval, join now to view.

Guest
Guest

Can I have a reply please as later posts have been replied to

Reply Good karma Bad karma0 votes
MathijsRevora Creator
MathijsRevora

Can't you set widescreen options in the 2.02 launcher? This isn't related to AotR - it's something you did with 2.02, hence no reply.

Reply Good karma+1 vote
Guest
Guest

This comment is currently awaiting admin approval, join now to view.

Guest
Guest

When i downloaded the first versions of the game it didn't work and i had a big error on my screen. After i downloaded the 2.07 patch for ROTWK my original game looked way better but the mod still won't work. Now when i try to open the mod instead of the big error message it just starts and then fails to work. PLs help me, i really want to play with the misty mountains

Reply Good karma Bad karma0 votes
MathijsRevora Creator
MathijsRevora

Please follow the installation instructions:
Moddb.com

Reply Good karma+1 vote
🍃{Legolas}
🍃{Legolas}

can i play this mod on 2.0.1 witch king?

Reply Good karma Bad karma+1 vote
MathijsRevora Creator
MathijsRevora

No.

Reply Good karma+1 vote
🍃{Legolas}
🍃{Legolas}

can i ask what fuctions are playable?

Reply Good karma Bad karma+1 vote
Guest
Guest

This comment is currently awaiting admin approval, join now to view.

Guest
Guest

This comment is currently awaiting admin approval, join now to view.

MrSleepz
MrSleepz

I just installed Aotr but no shortcut came up to play the mod after the installer finished. I don't have any other mods installed. Not sure why it isn't working, I've installed every patch as well. Any solutions? This mod looks great and I hope I can play it.

Reply Good karma Bad karma+1 vote
Guest
Guest

How do i install the latest patch for the newer version of this mod?

Reply Good karma Bad karma0 votes
MathijsRevora Creator
MathijsRevora

Download the file you are commenting on and install it.

Reply Good karma+1 vote
ras1116
ras1116

Hi I need help, I have already installed 2.02 v7 and the age of the ring installer won't let me install the mod because I'm lacking 2.02 patch even i have the latest patch installed? also there is no link to the previous patches, I wonder what should I do pls help =(

Reply Good karma Bad karma+1 vote
MathijsRevora Creator
MathijsRevora

Make sure you have the full 2.02 v7 patch, not the smaller one.

Reply Good karma+1 vote
Guest
Guest

This comment is currently awaiting admin approval, join now to view.

titanbass1
titanbass1

Found a bug in War for the Ring where whenever you do a Real Time Match at Fangorn, the game gives a black screen that you cannot escape, essentially crashing.

Reply Good karma Bad karma+1 vote
MathijsRevora Creator
MathijsRevora

War of the Ring isn't supported in the current version.

Reply Good karma+1 vote
Guest
Guest

Ok so i have a question. I just bought bfme2 on original disc cause i have missed the game all these years.
And now i see u guys do these amazing mods!
I dont own rotwk add-on.just the original game

can i download the age of the ring HD mod without having rotwk add-on?

TY for any help!

Reply Good karma Bad karma0 votes
MathijsRevora Creator
MathijsRevora

AotR requires RotWK. However, you can download it safely from below:

Forums.revora.net

Reply Good karma+1 vote
NoldorinElf
NoldorinElf

which factions are going to be added?

Reply Good karma Bad karma+1 vote
MathijsRevora Creator
MathijsRevora

This information is readily available in several places.

Reply Good karma+1 vote
NoldorinElf
NoldorinElf

no guardians of the tree recruitable for gondor? nor citadel guardians?

Reply Good karma Bad karma+1 vote
MathijsRevora Creator
MathijsRevora

Fountain Guards are available from the Fortress after buying an upgrade. Citadel Guards are summoned with Denethor.

Reply Good karma+1 vote
NoldorinElf
NoldorinElf

i got a bug.. on the map of ice bay of forochel for unknown reason my CP got disappeared and i cannot recruit soldiers. any solutions?

Reply Good karma Bad karma+1 vote
Sentezz60
Sentezz60

Error

step says

''It seems you do not have Rotwk patch 2.02 installed. Please install or enable it and try again''

but i can play rotwk mod 2.02 v7

Reply Good karma Bad karma+1 vote
MathijsRevora Creator
MathijsRevora

Make sure you have the full version of v7. This installer doesn't detect the small version.

Reply Good karma+1 vote
NoldorinElf
NoldorinElf

another bug i ve found that for unknown reason the cp reduces

Reply Good karma Bad karma+1 vote
MathijsRevora Creator
MathijsRevora

This will be fixed in the next version.

Reply Good karma+1 vote
NoldorinElf
NoldorinElf

thanks for reply :) keep up the excellent work

Reply Good karma Bad karma+1 vote
NoldorinElf
NoldorinElf

i got a question i think berethor is non canonical character.. will he be removed?

Reply Good karma Bad karma+1 vote
Eichi.ichibun22
Eichi.ichibun22

/nsis error not 2.02 v7 not install ?
please install fix

Reply Good karma Bad karma+1 vote
Post a comment
Sign in or join with:

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.