In a time where the Empire's grip on the galaxy is still tenuous, take command of early Rebel luminaries or the Emperor's closest advisors in an epic struggle to define a galaxy still smoldering from the Clone Wars. Assemble your faction's war machine from dozens of asynchronous lines, then augment it with hundreds of potential upgrades. Transform aspiring heroes into legends to provide intangible leadership to your military and government. Leverage entire planets and civilizations to their greatest potential through base building. Then, when everything is in place, plot your conquest vector. This is a four-decade strategic simulation of warfare across 120,000 light-years.

Report content PR v1.2 64-bit RAM Patch Fix
Mar 27th, 2012
0.03mb (29,236 bytes)
10,508 (1 today)
Embed Button
Download now

This patch is only for users experiencing compatibility or crash issues with Phoenix Rising v1.2 after installing the LucasArts 64-bit OS, 2+ GB RAM patch found here:

  1. Browse to your Forces of Corruption installation folder. To find it, search for swfoc.exe.
  2. Open the folder Mods\Phoenix_Rising_v1.2\Data.
  3. Extract the XML folder that is inside the zip file into the Data directory.
  4. You should now be able to run PR v1.2 with the 64-bit OS patch installed for FoC.
Preview Image
PR v1.2 64-bit RAM Patch Fix
Post comment Comments
yun_yuuzhan Apr 19 2012 says:

Using this just makes my game crash on launch. It's really quite sad since this mod looks sweet.

+2 votes     reply to comment
evilbobthebob Creator
evilbobthebob Apr 19 2012 replied:

Does it crash without it? Are you sure you put it in the right folder when you installed it?

+1 vote   reply to comment
5par7icus May 7 2012 says:

I have the same problem, i get further without the patch, maybe more detailed instruction notes would help, for example are the 2 files supposed to be in the new xml folder in the data folder or not?

+2 votes     reply to comment
TomorrowsStrategist Jan 4 2013 says:

Ive followed the install directions exactly for 1.2 and threw the patch XML folder into PR 1.2 Data folder but I keep getting a "Perception Parsing" error. Please help I loved older versions of this mod and I want this one. I have installed many other mods and they all work fine even though I run Windows 7. Im confused pls help

+3 votes     reply to comment
Guest Apr 7 2013 replied:

I have the same issue! Any help at all would be appreciated!

+1 vote     reply to comment
Guest Oct 13 2013 says:

same parsing error thing for me,im not sure why it does this but i just alt tab out the game and click ok on it and then click on the mod and bring it back up and get a black screen for a few seconds then the main menu comes up and i can i guess well just have to live with it till they fix it.

+1 vote     reply to comment
elit3honorguard Dec 6 2013 replied:

but the AI doesnt work

+1 vote     reply to comment
Guest Jan 29 2014 says:

This comment is currently awaiting admin approval, join now to view.

Gefreiter-Conley Feb 10 2014 says:

Alright, I have a 64 BIT Computer and attempted an install to my steamapps > common > Empire at War > corruption > Mods and I launched it with the mods path, and upon the startup which worked I got an exception error after the logo of this mod went away I did the main install the executable came with (which does not install correctly so I had to change the file locations manually.) and it did not work, is this what this patch is supposed to fix? I wanted to be sure before install.

+1 vote     reply to comment
Ren_Dhark1984 Jul 16 2014 says:

I cant play Phoenix Rising mod on Windows 7,...only when i play the game on Win Xp all is fine.

+1 vote     reply to comment
megatron10 Oct 28 2014 says:

wheres darth vader in this game

0 votes     reply to comment
DeusImperator Sep 16 2015 says:

This mod makes a weird sound echo when I try to use it on Win 6 64 bit with the GOG version.

+1 vote     reply to comment
Ragnrok Nov 23 2015 says:

if you install the patch as instructed. you will get parsing errors, but all you have to do is maximize the game window again. however, i can confirm that the ai does not work for me either. everything else works fine, no other problems. game does run a bit slow, but dont worry it isnt freezing just give it a minute or 2. still need to figure out if there is a fix for the ai bug.

+1 vote     reply to comment
Post a comment

You are not logged in, your comment will be anonymous unless you join the community. Or sign in with your social account:

Star Wars: Empire at War: Forces of Corruption
Send Message
Release date
Released 2012
Mod watch
Start tracking
MD5 Hash
Related Games
Related Groups
Phoenix Rising Team
Phoenix Rising Team Developer & Publisher with 2 members