The L.U.R.K. team wants to provide the best possible experience from Stalker: Shadow of Chernobyl, we don't plan to skew the scope of this game, because I, like many others, fell in love with the game because of the story, the realistic gameplay, and the atmosphere. I plan to preserve and improve on that concept to the best of my abilities, and our team has vowed to do so as well. Which is why we took it upon ourselves to provide that experience. We want to fulfill a niche that's otherwise unfulfilled in the modding community. We want to bring as many features to Stalker without damaging or changing the original theme of the game. While improving upon that concept with features that were dropped off the development cycle from GSC, such as stealth AI, and a strong foundation for balance, as well as dynamic A-Life, and an unprecedented visual presentation that no other Stalker Overhaul can touch.

Forum Thread
by member
  Posts  
How To Disable LURK Graphic Features? (Mods : L.U.R.K. : Forum : Questions : How To Disable LURK Graphic Features? ) Locked
Thread Options
Sep 28 2011, 9:12am Anchor

Hi,

when searching for the mods for Stalker SoC I found references to LURK and gave it a try. It is truly amazing and atmospheric but one thing I really hate about it - the blur and other visual treatment features. I just can't "see" anything properly. Everything is so fuzzy and dark. I wouldn't mind the dark but this fuzziness is awful. I tried several other mods because of that and they are all "sharp" and I have no problems. Considering in LURK I have no HUD to rely on too (which I like) it makes my experience rather frustrating. I tried both Optimized and Extreme and they seem the same in this respect (I have no trouble running it on full settings).

My question is as the title, how can I disable the visual treatment features of LURK?

Here is what I got with LURK and comparison to vanilla and Complete2009. Can I get it to be more like vanilla at least?

LURK (dark and very fuzzy)
User Posted Image

Vanilla
User Posted Image

Complete2009
User Posted Image

Thanks for the answer and especially for otherwise amazing mod!

Oct 2 2011, 5:38pm Anchor

I have the same issue, the lighting just makes the game look really soft and hard to look at. The only solution I've found is to turn off dynamic lighting completely.

Oct 5 2011, 12:59am Anchor

Wow, that I might try. It never occured to me as the mod claims it will run properly only with dynamic lightning on. Thx!

I can confirm it works however the quality goes down significantly as the shadows gets toned down to minimum with dynamic lightning off and the realism and immersion drops sharply because of that. Still better than with that "fog" on though.

Dec 21 2011, 7:52am Anchor

Thanks.
I installed the mod, started a new game, talked to a very fuzzy and shiny Sidrovich, went outside, took 5 steps and hit Alt-F4 because I felt like I was going to have a brain aneurysm. I can safely say I now know what it's like to wear someone else's contact lenses.
The mod itself seems promising, but the graphics just make me want to puke. No seriously, I felt queasy.

I'll try turning off dynamic lighting, and if it looks terrible I'll have to go and alter/delete any file that looks like they alter graphics and hope the game doesn't crash, and if it still won't work I'm just gonna ditch this mod altogether.
How can people play like this? o_o I'd literally have a mental breakdown a 10th of the way through the main story.

Jun 3 2012, 7:11am Anchor

Hello, I am bumping this thread because the amount of shaders/bloom/blur being applied to LURK is insane. I can only imagine that LURK is actually intended to be a Stalker-without-contact-lenses simulator.

What files do I edit to make the blur and bloom less intense?

Oct 12 2012, 7:56am Anchor

Why are the changes I have made to the user.ltx being overwritten when the game runs? I would like to alter some of the settings. And why does the console not work? I would like to alter some of the settings. A little Dev help would be appreciated.

Thanks

Edited by: ResidentE

Nov 12 2012, 11:33pm Anchor

I was really hoping there'd be some kind of answer at the end of this thread. 

I really love this mod - but I hate the graphics. I've learnt to deal with games which (horribly) tie motion blur and depth of field (and other stupid blur filters) to the rest of post processing (HDR, bloom, etc), but I've never seen a game as bad as this mod. The whole thing is just far too blurry and bloom-y. It makes my eyes water just looking at it when I play. It's a real shame, because this seems to be the only decent, recent mod for STALKER, gameplay-wise. But the graphics...they're so bad that I just can't play it.

Oddly enough, I was originally playing without dynamic lights. I'd only just reinstalled SoC and put the mod on, so I didn't realise dynamic lights was off. It looked quite ok, but it was too dark. When I saw that there was apparently no sun at midday, I figured something must be wrong. So, I saw that dynamic lights was off, turned it on, went back in game and went straight back to the menu to fix this horribleness.

The two main issues I have are that the bloom/blur is just bloody ridiculous - it neither looks good nor looks realistic; and the clouds/sky keep flickering (between light and dark), which I'm assuming is because of the terrible ultra-super-killmenow-HDR/bloom. The worst thing is that changing the user.ltx doesn't fix this, because the game changes it back to the crap settings when I launch it (even when I make the bloody thing read-only!). I don't remember Stalker SoC doing this, so I'm wondering if it isn't just the maker of the mod trolling everyone by making a good mod, getting a whole bunch of people to download it and then force them to play in a way that makes their eyes fall out and their brains combust.

Please, is there any kind of fix for this? Even just some way to stop the damn game from wiping my changes to the user.ltx?

Edit: I've found a way. Edit the file 'lurk_settings.script', found in the 'scripts' folder and you can edit most of the settings. Turning off bloom entirely, mostly removed the blur problems I was having, though now I'm without bloom. There's still a slight, weird fog and my sky still flickers (though, less noticeably). If I could be bothered, I could fiddle with the settings and get bloom working, without it ruining my eyes, but I just really can't. I've remembered why I stopped playing SoC - it sucks without mods, but mods make its graphics suck (and always give me all kinds of glitches, despite having upgraded from a 7800GT to a 9800GTX and now to a 560GTX and latest drivers - always get stupid issues like flickering sky, with mods). Plus mods always require too much tweaking to make them work.
If anyone ends up editing the lurk_settings file to reduce/remove the blur/fog/eye-death (and, ideally, give it some realism), I'd be really grateful if you could post it here. 
Also, if anyone knows how to fix the flickering sky issue, I'd appreciate any help with it.

Edited by: Mattressi

Apr 5 2013, 5:14pm Anchor

Hey guys, all this crying over the blur for ages has a fix which requires, like, 2 seconds of digging through stuff.
-Go to gamedata/scripts/
-Edit lurk_settings.script with a text editor like notepad.
-Do a search for "r2_ls_bloom_fast on"
-Replace the "on" at the end with "off" in every instance.
-Bam, no more near-sighted Marked One. 

Of course, this just turns blur off. Feel free to tamper with "r2_ls_bloom_threshold" if you want to adjust it to suit your needs. A higher value is what you should aim for (related to the default settings).

Reply to Thread
click to sign in and post

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.