Half-Life 2: Short Stories is a team working on a group of modifications that take place in the same realm. A lot of the focus is on the story and gameplay, new innovative set pieces and puzzles. After the release of the first episode of Human Error, the team is planning to release more episodes and expand the characters and the world.

Forum Thread
by member
  Posts  
Bug Reporting (Mods : Human Error : Forum : Human Error : Bug Reporting) Post Reply
Thread Options
Feb 11 2010, 7:17am Anchor

Known causes of bugs & problems:

1. Demo recording:

If you are recording a demo while playing ( Developer.valvesoftware.com ) you will get problems with both vehicles, the APC and the manhacks. With manhacks, players also seem to be unable to select the manhacks in the weapon selection hud. In some cases recording demos while using the manhack also caused a crash. The only thing I can say to this right now is: don't record demos.

2. Using custom configuration files or weapon scripts:

If you are using ready made scripts files to replace any of the weapon_*.txt scripts files, you might have problems with weapon selection. If you are using ready made skill.cfg files to increase max ammo carry values, decrease or increase health, you will have problems with the new NPCs, if their health values are not added to the skill file.


Crashing:

Some people have reported crashing while playing the Vortessence chapter. If you have a crash in any chapter, please go to your episode two hl2.exe folder. That is something like: C:\Steam\steamapps\[username]\half-life 2 episode two\ depending on your Steam installation. There should be a mini dump file (.mdmp file extension) from the time of the crash. Please send it to me to au-heppa at hlssmod dot net.

Feb 11 2010, 1:07pm Anchor

There's an interesting problem towards the end of the game. It's where you're with Eloise, Noah and Larson. After storming the building and getting ready to start the final big battle in order to get the generators started, there's a conversation piece as you're following Larson to their armory. As soon as the conversation stops, Noah stops following the group. I didn't realize it right away because I kept getting stuck wandering,trying to figure out where to go next. it then hit me that Noah was needed to trigger an event. So i had to "push" Noah into the proper direction and into the armory room. Once there did the trigger event activate and was able to open the doors properly to the next area. Also, Noah wasn't frozen or couldn't move, he just wasn't moving through the proper path with the rest of the group. I'm not familiar with how these things work, but remembering commentary from Episode One about nodes and how Alyx moves, could this be something related?

I apologize for any spoilers if others are reading but this was something I thought needed to be brought up.

Feb 12 2010, 8:21pm Anchor

There is another bug similar to this. When the car come towards you and the team the part before they argue who f***ed up on security. If you do shoot and kill the car sometimes the dead car hits Larson but does not kill him. Larson gets stuck and therefore you cannot continue on. The path finding for your AI "buddies" in general could be a bit better. Sometime you have to backtrack to get them out of and around corners. Although..it is still good and I guess I can't complain too much considering you are using the system for 3 key members that need to follow you instead of just Alex or several expendable :de: rebels.

Apr 1 2010, 6:09pm Anchor

This is a great game (besides the excessive language) but There is a bug in the ritual level while you are battling the xenian dropships while waiting for the "air defense" to recharge... but when It recharges, it shoots at me and my teammates! Arghhh....

Apr 2 2010, 1:28am Anchor

That's pretty weird. They can shoot metrocops and players if the global state of "combine computers being hacked" is set on, but there shouldn't be any global state ents in that map.

Jun 17 2010, 4:45pm Anchor

There's also a bug for me when I get all the generators recharged at the end of Ritual. My team runs down to the giant gate, but the third guy doesn't open the gate. We just sit there with no way to go on. How can I manually advance to the next level after ritual using the console?

Edited by: Jottle

Feb 14 2011, 6:19am Anchor

Hi. I don't understand what is that - Why I see only code (or something like code), i don't know?P.S. I download Half-Life 2: Short Stories from Desura

Ah. I don't have this problem more. I just delete version from Desura and download normal version from your site

Edited by: LongNange{RUS}

Feb 14 2011, 10:55am Anchor

Those are localization tokens. Basically they would be replaced by entries from the localization file which would be something like he_coop_&#xla;nguage%.txt, but it would fall back to the english one if your language wouldn't have its own file. Not sure why it wouldn't find the localization file, though. The best reason I can think of the game folder being the same wrong name, i.e., not he_coop.

But yeah, that's the Coop version of the game. If you want the SP version try out site or the download section here.

Feb 15 2011, 12:59am Anchor

Au-heppa,I said I download Half-Life 2: Short Stories by Desura. And folder with game called Human_Error, but there was only coop. There wasn't Human Error Episode One.

Edited by: LongNange{RUS}

Feb 15 2011, 8:13am Anchor

Yeah, I am aware of that problem, but being the forgetful person I am I didn't e-mail the Desure people about it yet. Sorry for the inconvinience.

Mar 29 2011, 11:31am Anchor

I'm having a problem where on startup that the game crashes with 'MountFileSystem (421) Failed.....' Please help!!

Mar 30 2011, 1:20am Anchor

Did you try downloading the update patch?

Dec 4 2011, 9:36pm Anchor

At the intro with the portal storm, My entire system crashed,
I got past it by loading the next map useing console, but id like to know how to get past it so i can enjoy the intro.
Also,After geting past the map with the elevator, it loads it as blank or something, i can only see Black, from the console, i think it dident load thne map for some reason, what the hell?

Edited by: Nick123q23

Jan 25 2012, 5:41pm Anchor

When i start it, will loading, it closes by it self and no warn show up. Can you give me a help here? :\

Jan 27 2012, 12:24am Anchor

Most bugs are caused by missing Half-Life 2: Episode Two. I think there was also some problems with the vehicle physics, that could cause crashes, but I never figured out what how to fix it.

If it's just the intro map / background map crashing you could try to skip it by enabling the console and writng map he01_01 into the console.

Jan 29 2012, 10:14am Anchor

how? i even get to the menu before the game close it self

Jan 30 2012, 5:24am Anchor

Go to the Steam Games library, select Human Error, Right mouse click, select Properties, click Set Launch Properties, write -console. The menu background map wont be loaded. You can either try starting the intro map with "map he01_intro" (although if the menu background crashed, it will probably crash as well) or the next map from that with "map he01_01". The intro map has the background story of the player character setup, and it's really short. The story might be a bit confusing if you don't play the intro, but you wont miss any of the fighting.

Jan 30 2012, 4:05pm Anchor

You're not understanding. When i go to steam and click "start" on the mod, it only shows that thing saying "Human error" with the black background, i am NOT able to be in the menu. Will it LOADS THE MENU it crash, i can NOT even type anything in the console. Got it?

Jan 31 2012, 12:45am Anchor

Ah, okay, I assumed it was the menu background map crashing the game. I am not really sure what could be causing the game to crash if you had console enabled.

Feb 19 2012, 5:54pm Anchor

Well, i can open and play human error coop, but human error episode 1 i can't :\. So, there is nothing you can't do to help me, right?

Feb 20 2012, 4:26am Anchor

Did you install them through Desure or normally?

Mar 12 2012, 3:07pm Anchor

normally

I bought a new computor, much better then the other one, and in this one human error still doesn't work, but only the singleplayer one. The multiplayer works.

Wait nevermind, it works now =P

Reply to Thread
click to sign in and post

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.