Game Manager for Desura. If you are a developer or know of a developer who wants to make their games available on Desura let me know. I have been a Linux user since the days of Slackware and a Windows user since DOS and Windows 3.1. I have been a part of the gaming community for 30+ years, yes I know I am showing my age again.

Comment History  (0 - 30 of 265)
Protektor
Protektor Feb 1 2013, 10:47am says:

This has been fixed in the open source version of the client. I would recommend you go and download the source code and compile it yourself.

+1 vote     article: Linux Client Crashes
Protektor
Protektor Nov 13 2012, 11:26am replied:

It is working correctly now.

+2 votes     game: Vampires: Guide Them to Safety!
Protektor
Protektor Oct 28 2012, 4:04pm replied:

I have now included FS2 Open completely setup in addition to the original Freespace 2 port.

+2 votes     game: Freespace 2
Protektor
Protektor Oct 24 2012, 5:04am replied:

Most likely there is some library that isn't being loaded correctly if you run it from the terminal window it will let you know what library you are missing. If you let us know we can add it to the list of require libraries.

+1 vote     game: Wake Up Call [Surrealist]
Protektor
Protektor Oct 23 2012, 2:17am replied:

Fanfazar went out of business before they could finish the game. Dead Mage Studio then picked up the game and finished the development of the game. I don't know how far along Fanfazar was in development but I got the impression it wasn't close to being completed.

+1 vote     game: Garshasp: The Monster Slayer
Protektor
Protektor Oct 23 2012, 1:26am replied:

Are you running Windows or Linux?

+1 vote     game: Freespace 2
Protektor
Protektor Oct 17 2012, 3:05am replied:

This is an error with your distribution not having all the need dependencies installed. We test on Ubuntu and Red Hat as our two main platforms.

+1 vote     member: Protektor
Protektor
Protektor Oct 16 2012, 7:04am says:

I thought i would mention that game within a game has been done before with the Dot Hack series of anime and video games. There is a new one out as well although I don't think it has been translated to English for the game called Sword Art Online. The anime has been subtitled to English. If you like those type of things you should check both of them out.

+5 votes     game: Shadow of the Game
Protektor
Protektor Oct 15 2012, 11:57pm replied:

It's the native port that Ryan "Icculus" Gordan did. If your looking to improve the original game you might want to look at FS2_OPEN.

+2 votes     game: Freespace 2
Protektor
Protektor Oct 15 2012, 11:03pm replied:

This is the original source code of the game ported to Linux. The no sound was an issue with not being able to get the sound in videos working correctly. You might want to try downloading and using FS2_Open which uses the Freespace 1 & 2 data files but has a much more updated engine for the game.

+1 vote     game: Freespace: The Great War
Protektor
Protektor Oct 15 2012, 6:53am replied:

I am showing V16 as the current release here.

+2 votes     game: Xenonauts
Protektor
Protektor Oct 15 2012, 12:01am replied:

This has been corrected. The client will now look to see if you have it installed and if not it will download it and use it. You will need to install the game again to get the client to check for it and download it if needed.

+1 vote     game: Wake Up Call [Surrealist]
Protektor
Protektor Sep 25 2012, 11:19pm replied:

Yes it is now available.

+1 vote     game: Freespace: The Great War
Protektor
Protektor Sep 25 2012, 11:14pm replied:

What is the exact problem you have? It works fine for me under Ubuntu 12.04.

+1 vote     game: Descent 1 & 2
Protektor
Protektor Sep 25 2012, 11:13pm replied:

I can say it runs on Ubuntu 12.04 without an issues.

+1 vote     game: Descent 1 & 2
Protektor
Protektor Sep 25 2012, 11:03pm replied:

Your version of glibc isn't new enough. You need at least version 3.4.15.

0 votes     game: Descent 1 & 2
Protektor
Protektor Sep 25 2012, 11:01pm replied:

DOSBox

+2 votes     game: Earthworm Jim 1 & 2
Protektor
Protektor Sep 25 2012, 11:01pm replied:

It is bundled with DOSBox since it is the original DOS game.

+2 votes     game: Earthworm Jim 1 & 2
Protektor
Protektor Sep 25 2012, 11:00pm replied:

Yes it uses DOSBox since it is the original DOS version.

+2 votes     game: Earthworm Jim 1 & 2
Protektor
Protektor Sep 17 2012, 8:20pm replied:

I can confirm that it runs on Ubuntu 12.04 if you have the i386 libraries installed. I don't know about the beta.

+2 votes     game: Freespace 2
Protektor
Protektor Sep 17 2012, 8:05pm replied:

Yes you can use the data files to install Freespace Open.

+4 votes     game: Freespace 2
Protektor
Protektor Aug 20 2012, 3:29am says:

Since Desura is collecting the money and actually doing the sale it is Desura who has to pay the taxes. There is no choice in the matter if we want to sell in those regions.

The reason for the .99 is that we started out that way and want to keep everything uniform on the system.

+2 votes     article: Pricing & Taxes
Protektor
Protektor Jul 12 2012, 1:33am replied:

The demo uses the old Linux way of doing sound. If you system isn't setup to support the old way then just as "padsp" to the script that launches the game. The full version uses Pulse Audio and has been updated recently to add that support.

+2 votes     game: POSTAL 2
Protektor
Protektor Jul 12 2012, 1:29am says:

If you have a lightning icon next to the game name in the game list in the client then you are still running the demo and need to uninstall the demo and install the full version. You can do that from the client or you can force the install by starting the install from the website. You can do that by going to this URL:
Secure.desura.com

+3 votes     game: POSTAL 2
Protektor
Protektor Jul 12 2012, 1:25am replied:

The "padsp" should only be needed for the DEMO. The full version has been updated and recompiled to work with Pulse Audio without any issues. The "padsp" is for the old way that Linux used to do sound to re-route it to Pulse Audio. Let me say it again the Full version of the game uses Pulse Audio now.

+3 votes     game: POSTAL 2
Protektor
Protektor Jul 1 2012, 11:50pm replied:

It will still run fine on 64-bit systems if you install the i386 compatibility libraries. I tested the game on a 64-Bit machine with the libraries installed.

+5 votes     game: Dino Run SE
Protektor
Protektor May 22 2012, 7:38am replied:

You need glib 2.15 installed.

+1 vote     game: The Journey Down: Chapter One
Protektor
Protektor May 22 2012, 7:36am replied:

You need to check and see what version of glibc is installed on your system. You need 2.15.

+1 vote     game: The Journey Down: Chapter One
Protektor
Protektor May 20 2012, 11:22am replied:

You should run it from the terminal window and see what error messages are generated when you try and launch the game. If you are still having problems then email support.

+1 vote     game: Savage XR
Protektor
Protektor May 20 2012, 11:14am replied:

This has been corrected now. If you download the game now and don't have SDL installed then it will download the libraries and use them.

+2 votes     game: Savage XR
Level
Avatar
Avatar
Offline Since
Feb 13, 2014
Country
United States United States
Gender
Male
Member Watch
Track this member
Comment Statistics
Posts per day
0.2
Members
3
Games
164
Articles
96
Media
3
Engines
1
Groups
40