Post feature RSS Instructions to properly install The Ultimate Universe v2.2 for Star Trek Legacy

Instructions to properly install The Ultimate Universe v2.2 for Star Trek Legacy.

Posted by on

Instructions to properly install The Ultimate Universe v2.2 for Star Trek Legacy.

Step 1: First you need a Clean Stock copy of Star Trek Legacy.

One of the easiest ways to get a known good clean copy of Legacy is to get this follow these instructions:

1. First we either delete or rename the existing copy of Star Trek Legacy. To do so, either Rename (if you want to keep that copy) or Delete (if you don’t want to keep it) your existing "\Star Trek Legacy\" folder". The default location of this folder can be one of two places typically depending if you are running a 32bit or 64bit Operating System.

32bit - C:\Program Files\Bethesda Softworks\Star Trek Legacy\

64bit - C:\Program Files (x86) \Bethesda Softworks\Star Trek Legacy\

It may be different if you happen to not install Star Trek Legacy to the Default folder initially.


  1. Next Insert the Star Trek Legacy Dvd and start the installer. When it asks, choose the "Repair" option. That will automatically reinstall Star Trek Legacy to the folder it was installed to originally. If “Repair” is not an option, then your computer doesn’t know it had it previously installed (that’s assuming you did have it previously installed), then you can just install it from scratch. You now have a clean fresh Stock copy of Legacy to work with to install UU 2.2 into.

    3. At this point you can optionally install/reinstall the Legacy 1.1 and Legacy 1.2 patches. If you install either patch nacelles will not break off ships when the engines are damaged, but some various things do work better such as the "5" key and the Energy Acollation control. I personally prefer to have the breaking engines/nacelles effect in the 1.0 exe. Optionally if you “copy” the Legacy 1.0 legacy.exe to “legacy1.exe” before installing 1.1 and 1.2, the UUTools has a button to swap between it to launching legacy1.exe (v1.0) and legacy.exe (v1.2) giving you the best of both worlds. Remember you must copy/rename it before installing 1.1 or 1.2 or legacy1.exe will not be there.

If you are installing UU2.2 into this install and want Legacy 1.2, you do not have to install the Legacy 1.1 patch. While 1.2 does not include all of the 1.1 patch files, UU overwrites all the files that are included in 1.1 anyways.


Step2: Now we are ready to install The Ultimate Universe mod itself.

Take special care that each of the 3 installers are installed to your \Star Trek Legacy\ folder.

One of the UU 2.0 parts does not properly recognize if you have a 64bit os and tries to install to \Program Files\ instead of \Program Files (x86)\ while the other half of 2.0 does properly goto the x86 folder. The UU2.2 Update (Build 2) tries to install to \Bethsda Softworks\ instead of \Bethesda Softworks\ (Missing second “e” in Bethesda)

  1. Download and install UU 2.0 Part 1.
  2. Download and install UU 2.0 Part 2.
  3. Download and install UU 2.2 Update.
  4. Optionally you can install our XI Pack for UU 2.2 as well. If you choose to install it, install it LAST.

Ultimate Universe 2.0 Part 1 of 2

Moddb.com

Ultimate Universe 2.0 Part 2 of 2

Moddb.com

Ultimate Universe 2.2 Update (Build 2)

Moddb.com

CJG XI Pack for UU2.x (Build 2)

Moddb.com

Comments
Opinionator
Opinionator

This would of saved me from the depth noobified hell last week. I forgot how to install this off the top of me head. Nice install guide cheers and tar very much. :)

Reply Good karma Bad karma+1 vote
Muldrf Author
Muldrf

Your welcome, that's what it's here for. It can be a bit awkward to install. At some point the installers might be made a bit more uniform.

Reply Good karma+1 vote
phillip1604
phillip1604

I can't play the Cardassians, the Dominion or the Mirror Starfleet. Additionally, every time I want to start a scenario with on of these races involved, the game crashes.

Reply Good karma Bad karma+1 vote
brujahcrusader
brujahcrusader

Installed this earlier today and works well so far, nicely designed. However the POV of the piloted ship has shifted from directly behind to slightly starboard. How can I correct this?

Reply Good karma Bad karma+1 vote
Muldrf Author
Muldrf

It is in various documentation in the Readmes. Use the UUTools, it has the option to change between the UU "Offset" view and the original "Centered" view. Also all Readmes are easiest to access in the UUTools.

Reply Good karma+1 vote
Guest
Guest

i am haveing trouble with getting the universe 2.2 part working i load the game up and it says 2.0 can anyone help me please

Reply Good karma Bad karma0 votes
Muldrf Author
Muldrf

I'm expecting you didn't follow the specific notes to:

"Take special care that each of the 3 installers are installed to your \Star Trek Legacy\ folder.

One of the UU 2.0 parts does not properly recognize if you have a 64bit os and tries to install to \Program Files\ instead of \Program Files (x86)\ while the other half of 2.0 does properly goto the x86 folder. The UU2.2 Update (Build 2) tries to install to \Bethsda Softworks\ instead of \Bethesda Softworks\ (Missing second ā€œeā€ in Bethesda)"

Reply Good karma+1 vote
CloneCaptainRex(332)
CloneCaptainRex(332)

Can someone tell me where to find and buy star trek: Legacy?

Reply Good karma Bad karma+1 vote
Guest
Guest

This comment is currently awaiting admin approval, join now to view.

Guest
Guest

Works great. However, it closes down when I access certain Campaign levels like "Generals" for example

Reply Good karma Bad karma0 votes
Muldrf Author
Muldrf

You may not have started with a fresh clean un modded Star Trek Legacy install before installing UU. Or something didn't install correctly for you. UU is only compatible with itself, the only modification specifically built to work with it is the UU version of the XI Pack.

It is because the odf files create a database, if one odf file has a reference in it that doesn't exist in UU then it can't use that ship, object, map object etc. It could also be a corrupt file, 3d model, map file, a "duplicate" named map file that is being loaded instead of the UU2.2 map file. Maps in UU are modified.

UU 2.0 and by extension 2.2 are NOT Compatible with UU 1.x. If you install UU 2.0/2.2 overtop of a UU 1.x install you will have a corrupt install and will likely find may things that won't work.

Reply Good karma+1 vote
Guest
Guest

i can't open the downloaded 2.0 files. pc asks me what program i want to open the files with (notepad, web xplorer etc) but nothing works. pc runs Legacy fine but after doing the download i'm stuck. thanks for any advice

Reply Good karma Bad karma0 votes
Muldrf Author
Muldrf

Your download is was not saved with the correct file extension that it originally had they are .exe files. .exe files don't ask "what to open them with" they are natively executable.

Reply Good karma+1 vote
Guest
Guest

can the mod be installed on the xbox one?

Reply Good karma Bad karma0 votes
Muldrf Author
Muldrf

No. It is PC Only.

Reply Good karma+1 vote
dompmahoney
dompmahoney

PLEASE CAN ANYONE HELP!!!!!!!
I Have tried installing this game now for a month and still no luck, i have followed the instructions exactly but i still dont have any controller input , im not sure where ivee gone wrong
so i had a clean legacy, installed UU20part1
then UU20Part 2
then UU22Update
and finally the XIPack1ur2B
now before as in a year ago when i played it worked perfectly the controller support was excellent but for some reason it just isnt working
can anyone help!!!!!!!

Reply Good karma Bad karma+1 vote
Muldrf Author
Muldrf

The first thing to do is start with a fresh clean install. If your Controller is not working without UU, it will not work with UU. There is no reason that a controller would not be expected to work, though the game was written for XP, so it has never expected to be run on later operating systems. If it isn't working in UU, but you find it works in clean non-modded Legacy I would expect it did not install properly. UU does not change legacy.exe, so the only reason for it to behave differently with the patch is that one of the installers didn't get installed properly or in the proper order. You can also test between installations, go from the stock unmodded, if that works, install UU 2.0 part 1 and 2 and test again, then install 2.2 and test again and finally install the XI Pack (be sure it is the UU compatible release).

Reply Good karma+1 vote
Post a comment
Sign in or join with:

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.