Description

Ported food, drug and drinks animations from anomaly addon and integrated into Smurth’s Dynamic HUD 1.1. This includes: full consumable items animations, monster hunting, weapon shooting camera effects, masks HUD.

Preview
Smurth LilGABE HUD animations hybrid (ver.2 -moves enabled) 1.5r7
Comments
Feel_Fried
Feel_Fried

--[[
Script_2(item_animations):
\\File : item_animations.script
\\Author : thales100

Script_3(enhanced_animations):
\\File : enhanced_animations.script
\\Author : thales100

Author: LilGABE
Вся необходимая информация указана в скрипте item_animations.script.
]]--

-------------------------------------------------------------------------------
--[[
Original authors: Tris, Nuor, thales100
Script_1(dfz_hide_wpn):
\\File : dfz_hide_wpn.script
\\Author : Tris (Modified by Nuor)

Script_2(item_animations):
\\File : item_animations.script
\\Author : thales100

Script_3(enhanced_animations):
\\File : enhanced_animations.script
\\Author : thales100

Author: LilGABE
]]--

Reply Good karma Bad karma+3 votes
jeredy_hothead Author
jeredy_hothead

Eh perhaps slipped when was editing out unused stuff, sorry for that. I'm very grateful for their works and efforts and by no means this move intended.

Reply Good karma+1 vote
jeredy_hothead Author
jeredy_hothead

So I rechecked again - there were no credits in the first place in Smurth's HUD scripts I downloaded from link provided in description.

Reply Good karma+1 vote
Feel_Fried
Feel_Fried

oh... really, he deleted them =( meh, then sorry for blaming you, I used originals when started porting to Amomawy, anyway, it will be nice if u add them back.

Reply Good karma Bad karma+1 vote
jeredy_hothead Author
jeredy_hothead

This version slightly differs from what you are currently using, maybe an old version of scripts? Anyway, added header to both files
--[[
Original authors: Tris, Nuor, thales100
Script_1(dfz_hide_wpn):
\\File : dfz_hide_wpn.script
\\Author : Tris (Modified by Nuor)

Script_2(item_animations):
\\File : item_animations.script
\\Author : thales100

Script_3(enhanced_animations):
\\File : enhanced_animations.script
\\Author : thales100

Author: LilGABE
]]--
Hope issue resolved now and everyone happy.

Reply Good karma+3 votes
jeredy_hothead Author
jeredy_hothead

Uploaded update - low health state no longer disabling animations.

Reply Good karma+1 vote
xintothefallx
xintothefallx

What about the other can food, the lost to the zone addon have more food items, beer, tushonka, will work with it? :(

Reply Good karma Bad karma+1 vote
jeredy_hothead Author
jeredy_hothead

There is a list of currently unused items in script such as: nuts, sardina, olivki, cheese, galet and so on including beer. Animations should be same, only texture and model different. Adaptation is possible i guess but I'm working on another very interesting thing now.

Reply Good karma+1 vote
jeredy_hothead Author
jeredy_hothead

Major update STCOP patch.

Reply Good karma+1 vote
jeredy_hothead Author
jeredy_hothead

Second addon version is lighter and free of previously existed flaws but requires full reinstall.

Reply Good karma+1 vote
TOSNAMI9PRO
TOSNAMI9PRO

It is work also in CoC 1.4 Please Answer Me

Reply Good karma Bad karma+1 vote
jeredy_hothead Author
jeredy_hothead

No.

Reply Good karma+2 votes
TOSNAMI9PRO
TOSNAMI9PRO

Work Also In 1.5 R6 ? And Thanks For Reply :)

Reply Good karma Bad karma+1 vote
jeredy_hothead Author
jeredy_hothead

Should work but I haven't tried.

Reply Good karma+1 vote
TOSNAMI9PRO
TOSNAMI9PRO

what version you have i have coc 1.5 r7 64 bit 2019 what is yours,
I installed the coc r7 64 bit but when i lunch it it crashed with no error messages i have directX with vs and openAl it keep crashed i have win 10 how to fix it

Thanks 😊

Reply Good karma Bad karma+1 vote
jeredy_hothead Author
jeredy_hothead

Game client:
Drive.google.com
With patch:
Yadi.sk
Try not to use launcher, but Stalker-Coc.exe instead. I have no problems on win 10.
Check appdata/logs/openxray_x64.log it usually writes crash details in the end of file.

Reply Good karma+1 vote
TOSNAMI9PRO
TOSNAMI9PRO

Thank you very much 😊

Reply Good karma Bad karma+1 vote
Cyanmint
Cyanmint

Um... Hello? Is this compatibility for Outfit Addon 1.4.7?

Reply Good karma Bad karma+1 vote
jeredy_hothead Author
jeredy_hothead

This is for CoC 1.5r7 which already has built-in Outfit Addon. If you are using other CoC version I cannot guarantee stable work.

Reply Good karma+1 vote
Zealot_K
Zealot_K

Hello, my game crashes every time i try to skin a mutant :

[09:31:13.157] FATAL ERROR
[09:31:13.157]
[09:31:13.157] [error] Expression : !m_error_code
[09:31:13.157] [error] Function : raii_guard::~raii_guard
[09:31:13.157] [error] File : D:\CoC_UP\src\xrScriptEngine\script_engine.cpp
[09:31:13.157] [error] Line : 622
[09:31:13.157] [error] Description : ...nobyl 1.5 r7\gamedata\scripts\enhanced_animations.script:345: attempt to get length of a nil value

Reply Good karma Bad karma+1 vote
jeredy_hothead Author
jeredy_hothead

Thanks for feedback. Indeed there were certain variations of monsters subtypes unspecified in clsid table. Uploaded fixed script, should be fine now.

Reply Good karma+1 vote
Zealot_K
Zealot_K

Actually, i still have the exact same crash. Tested with no other addon, x64 and x86 launcher... which is strange, because it worked perfectly well with older versions of your mod.

Reply Good karma Bad karma+1 vote
jeredy_hothead Author
jeredy_hothead

Which mutant exactly is that? Or just any mutant?

Reply Good karma+1 vote
Zealot_K
Zealot_K

Actually, just any mutant it seems... tested with dog, flesh, boar. I'm using the CoC 1.5R7 repack posted in the addon section. Do you think it could be the problem ? Also, you suggested not to use the launcher... the launcher could be the problem ?

Reply Good karma Bad karma+1 vote
jeredy_hothead Author
jeredy_hothead

Just tried - every dog, psydog, rat, tushkano, flesh, boar, snork, bloodsucker, everything worked, only electric burer crashed, but I don't think they are present in-game. Are you using JSGME by any chance? It can break game files. Laucher is not a problem, because I use it to start dev mode with spawner and test everything. What about repack, you were saying it worked before, idk give a try Drive.google.com and Disk.yandex.ru which I'm using.

Reply Good karma+1 vote
Zealot_K
Zealot_K

Well.. i tried both the repack and your version and it still does not work... too bad. Actually, i'm not very fond of the animation when skinning mutants, i prefer the other animations. Is there any way to deactivate the animations for mutants, while keeping the other animations ?

Reply Good karma Bad karma+1 vote
jeredy_hothead Author
jeredy_hothead

Added to game options, interface section. If doesn't work on first time - try to enable/disable again.

Reply Good karma+1 vote
Ultraje
Ultraje

I installed the mod, but my game crashes, no error message, i got the smurth dynamic hud installed already, the original, maybe is that the problem? In that case, what can i do, can i uninstalled?
THANKS!

Reply Good karma Bad karma+1 vote
jeredy_hothead Author
jeredy_hothead

Smurth's dynamic HUD is included here so, yes, old installation will interfere and has to be removed before you install this one. If it is too difficult to find and delete it file by file, each added folder then delete whole gamedata folder (but keep axr_options and atmosfear_options so you don't have to reconfigure game again).

Reply Good karma+2 votes
Ultraje
Ultraje

Okay, thank you very much for the quick response, i forgot to mention that i got OWR installed too, i assume that is making conflict too

Reply Good karma Bad karma+1 vote
Ultraje
Ultraje

Okey nvrm i was trying to use this mod on 1.4.22 xDD

Reply Good karma Bad karma+2 votes
Guest
Guest

compatible with 1.5r6?

Reply Good karma Bad karma0 votes
jeredy_hothead Author
jeredy_hothead

Never tried with anything except 1.5r7, but r6 comes very close feature wise, so it is worth to try at least, might work without additional editing.

Reply Good karma+1 vote
Lastshit
Lastshit

can this be ported to 1.4.22?

Reply Good karma Bad karma+1 vote
Guest
Guest

-----loading c:\users\yooooooohh\downloads\coc_1.5_r6_full\gamedata\configs\system.ltx

FATAL ERROR

[error]Expression : I
[error]Function : CInifile::Load
[error]File : Xr_ini.cpp
[error]Line : 267
[error]Description : Can't find include file:
[error]Arguments : plugins\achievements.ltx

stack trace:

001B:00AD50BE xrCore.dll, CInifile::Load()
001B:00AD4B32 xrCore.dll, CInifile::CInifile()
001B:00467FF5 xrEngine.exe, CApplication::load_draw_internal()
001B:0046561A xrEngine.exe, InitSettings()
001B:00466043 xrEngine.exe, InitSound2()
001B:00466366 xrEngine.exe, InitSound2()
001B:00471F4B xrEngine.exe, CApplication::load_draw_internal()
001B:771BCF39 KERNEL32.DLL, BaseThreadInitThunk()
001B:772926A5 ntdll.dll, RtlExpandEnvironmentStrings_U()
001B:77292679 ntdll.dll, RtlExpandEnvironmentStrings_U()



I tried to use it in 1.5r6 but it crashes how to fix?

Reply Good karma Bad karma0 votes
jeredy_hothead Author
jeredy_hothead

Remove line
# include "plugins\achievements.ltx"
from your gamedata\configs\system.ltx file.
If it errors again with same "Can't find include file" message - you'll have to remove another specified # include line from system.ltx.

Reply Good karma+1 vote
Guest
Guest

FATAL ERROR

[error]Expression : <no expression>
[error]Function : CInifile::r_section
[error]File : Xr_ini.cpp
[error]Line : 523
[error]Description : fatal error
[error]Arguments : Can't open section 'reduce_lod_texture_list'. Please attach [*.ini_log] file to your bug report

stack trace:

001B:009A269C xrCore.dll, xrDebug::fatal()
001B:772AF7E1 ntdll.dll, RtlGetCurrentServiceSessionId()
001B:772AA526 ntdll.dll, RtlAllocateHeap()
001B:772AF1DE ntdll.dll, RtlFreeHeap()
001B:5FD3ECFA MSVCR120.dll, free()
001B:009A31C4 xrCore.dll, is_stack_ptr()
001B:0098582F xrCore.dll, CMemoryWriter::w()
001B:00991E8B xrCore.dll, IWriter::w_string()

it still crashes

Reply Good karma Bad karma0 votes
jeredy_hothead Author
jeredy_hothead

Search through original unpacked untouched CoC1.5r6 config files with notepad++ or any other editor. Find reduce_lod_texture_list string, locate the file that contains section and copy whole this section to same config file in your actual CoC1.5r6 that you are modifying. This is the way to do adaptations to various versions.

Reply Good karma+1 vote
Guest
Guest

This comment is currently awaiting admin approval, join now to view.

Nikkolai_Superfly
Nikkolai_Superfly

I'm sure the animations in this are superior to the default animations of Smurth's HUD but considering I'm on 1.4.22 and using AO+OA I have a feeling it would be a pain for me to make this compatible with my setup.

Reply Good karma Bad karma+1 vote
amogusuperedition69
amogusuperedition69

which version does this one work on?, the 64 2019 version or the 32 2018 version?

Reply Good karma Bad karma+1 vote
Guest
Guest

This comment is currently awaiting admin approval, join now to view.

Post a comment
Sign in or join with:

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.