Warband Enhanced is my first attempt to improve the gameplay in Warband Native with the help of the best mods made by this community and also with the implementation of new features and gameplay tweaks made by me.

Add download Report content Warband Enhanced - v0.6
Filename
Warband-Enhanced-v0.6.rar
Category
Full Version
Uploader
idragon
Date
Size
171.57mb (179,902,884 bytes)
Downloads
22,073 (6 today)
MD5 Hash
290e39c238c570a23d6bfa99866976dc
Embed Button
Embed Widget
Description

Warband Enhanced v0.6 for Warband 1.143. Compiles Diplomacy+PBOD+Freelancer into one. Adds new features and tweaks. See mod summary for more information.

Preview
Warband Enhanced - v0.6
Comments
Irishman215
Irishman215

is this for warband 1.5.3 yet?

Reply Good karma Bad karma+2 votes
EireKHAOTIX
EireKHAOTIX

It works with Warband 1.5.3 though I downloaded it to 1.5.3 and IT worked fine.

Reply Good karma Bad karma+1 vote
scandaldog
scandaldog

how about 1.158?

Reply Good karma Bad karma+4 votes
idragon Author
idragon

nop, still 1.143

Reply Good karma+1 vote
Isapie
Isapie

I dont understand how to download...

Reply Good karma Bad karma0 votes
idragon Author
idragon

well ? the download button at the top? then read the instruction in the readme.txt

Reply Good karma+5 votes
Knez
Knez

I'm sorry,are you blind ????

Reply Good karma Bad karma+1 vote
Irishman215
Irishman215

please update it =(

Reply Good karma Bad karma0 votes
Irishman215
Irishman215

will it be updated to 1.5.3?

Reply Good karma Bad karma+1 vote
idragon Author
idragon

yes, but it will take time, so for now try the 1.143. Some of the major mods like Diplomacy and PBOD are not fully updated to 1.153, so i am waiting for their modders to do that first.

Reply Good karma+4 votes
FeatsOfStrength
FeatsOfStrength

You can still download 1.143 and play it, I have a 1.143 version installed as well as 1.153 on steam and have no issues atall.

Reply Good karma Bad karma+2 votes
Irishman215
Irishman215

how?

Reply Good karma Bad karma+1 vote
Irishman215
Irishman215

how?

Reply Good karma Bad karma+1 vote
idragon Author
idragon

Well:

1) You download and install the official 1.143 version Download.taleworlds.com
2) Download an Extract the folder Warband Enhanced to your Modules directory. Go to WSE folder in the Warband Enhanced directory, launch wse_loader.exe, select Warband Enhanced from the list and play.

Reply Good karma+2 votes
Guest
Guest

This comment is currently awaiting admin approval, join now to view.

Irishman215
Irishman215

sir i now love you

Reply Good karma Bad karma+2 votes
nanuka
nanuka

love this mod but could be made a bit clearer on how to download.

Reply Good karma Bad karma0 votes
TheMetalfreak360
TheMetalfreak360

How can it be "made a bit clearer" to download!? There is a big "DOWNLOAD NOW!" button in red on the top...

Reply Good karma Bad karma+3 votes
Ishvalania
Ishvalania

the game log is invisible, please help me fix it i love this mod

Reply Good karma Bad karma+2 votes
BrindGallos
BrindGallos

I'm having the same problem. Is it just because its not 1.154 yet or is there a way to fix this

Reply Good karma Bad karma+1 vote
Guest
Guest

This comment is currently awaiting admin approval, join now to view.

Guest
Guest

This comment is currently awaiting admin approval, join now to view.

svetliaka92
svetliaka92

I have a problem, i did everything sayd in the installation guide and it still says that i have an unsupported version, when i start from the game launcher when i choose the mod it starts OK, but when i start playing it starts to give the red error codes.Can someone help, i am with windows 7 ultimate x86 version

Reply Good karma Bad karma+1 vote
TheMetalfreak360
TheMetalfreak360

"unsupported", do you mean you have pirated the game? Because I doubt it will work that way.

Reply Good karma Bad karma+1 vote
Guest
Guest

This comment is currently awaiting admin approval, join now to view.

Guest
Guest

This comment is currently awaiting admin approval, join now to view.

Arkais3
Arkais3

It would seem that I am having a problem. Game works almost perfectly, the only problem I have is that the game log will not show up. I can load my saves just fine and everything. This has been the only problem, otherwise the game is perfect. Thank you for your time if you respond to this, if not then I suppose I can find another forum to help me.

Reply Good karma Bad karma+2 votes
Guest
Guest

This comment is currently awaiting admin approval, join now to view.

Guest
Guest

This comment is currently awaiting admin approval, join now to view.

Ratlook
Ratlook

ill be waiting til its 1.5.3, hope youll do it soon! :)

Reply Good karma Bad karma+1 vote
clinci
clinci

the lords dont move? whats wrong

Reply Good karma Bad karma+1 vote
Guest
Guest

This comment is currently awaiting admin approval, join now to view.

Nicolas_4825
Nicolas_4825

DOWNLOADING IN 450!

Reply Good karma Bad karma+1 vote
aryano
aryano

i downloadede it and it downloaded just fine but it has some problems in game like I cant get any noble troops even though im a vassel

Reply Good karma Bad karma+1 vote
DonBre
DonBre

YAY! :D

Reply Good karma Bad karma+1 vote
Woofy200
Woofy200

I swear, it asks me for my serial code for M&B Warband and I put it in. It says "Activation Denied". I've tried using all of the codes for all of the games I own. I've tried the first, second, (with all dlc tried too.) and the third. Nothing's working! I need help.

Reply Good karma Bad karma+1 vote
Guest
Guest

This comment is currently awaiting admin approval, join now to view.

arinbhatta1999
arinbhatta1999

Hey the mod is really awesome but am having problems in giving orders, like formations in IN BATTLE MODE. And there isn't any info coming about the damage dealt or received. Please help?

Reply Good karma Bad karma+1 vote
Guest
Guest

This comment is currently awaiting admin approval, join now to view.

Milan001
Milan001

Does it work with 1.158?

Reply Good karma Bad karma+1 vote
Jon_Baptiste_Edwards
Jon_Baptiste_Edwards

I have 1.143, (Using your download link), I don't have any other versions but it's like WSE is detecting a newer non-existent version. Everytime I try to run WSE it says that I'm running an unsupported version, and that it only supports 1.143, which is what I have. I'm new to WSE so does anyone know a fix?

Reply Good karma Bad karma+1 vote
Post a comment
Sign in or join with:

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.

Icon
Mount & Blade: Warband
Creator
idragon
Contact
Send Message
Release date
Mod watch
Start tracking
Download
Browse
Downloads
Share
Related Games
Mount & Blade: Warband
Mount & Blade: Warband Role Playing