CDF Ghostship Ghostship is a first person, third person survival horror and sci-fi shooter. We don’t have much choice with these sort of games today and we don’t have a free roaming one! Our vision is bring you a fun, scary, highly re-playable sci-fi game like the older games such as Doom, System shock, Dead Space, ACM, Natural Selection etc. There are some good ones out there but we want to do a few things new such as a free roaming game and a real first person mode with a helmet view for extra realism and atmosphere. There are over 20 different enemies and over 20 different weapons with some cool gadgets. Please play the alpha we have released to see what we mean when we say "it’s not just a game, It’s an experience!" FULL NATIVE RIFT VERSION !! Rift demo available - see our web site

Forum Thread
by member
  Posts  
Alpha V0.33 Bug Report (Games : CDF Ghostship : Forum : Alpha v0.33 Feedback Thread : Alpha V0.33 Bug Report) Locked
Thread Options 1 2 3
Jun 9 2013, 10:33pm Anchor

Please post your bug reports on this thread. The ones we know about we can fix, the ones we don't we can`t! So let us know on every bug you find. A brief description of where you are, what you was doing before the bug occurred and what the bug does or doesn't do. Please let us know of you have come across this bug more than once (this excludes AI bugs)

Thanks :)

Lord_Porksword
Lord_Porksword Unreal Old Friends
Jun 12 2013, 11:34pm Anchor

Howdy Shaun!
I'll post more indepth feedback over the next few days, after playing more, but here's a couple of issues I've found so far.
-=-=-=-
I'm picking up ammo clips but they aren't replenshing my ammo count on any of the weapons.
The hitbox for the 'bigger biters' seems to be around their feet. I find that I cannot kill them when shooting the top half of the body.
The Zombies in the containment area managed to kill me through the glass.
After unlocking Hangar two nothing happened in there. In the earlier alpha I a wave or two of enemies emereged from the far corridor. I could hear the sound that normally indicates a wave but this time that didn't happen. The same happened with the storage room and it almost appeared that the spawnings had stopped in some other areas as well. Medical deck appeared OK though.
Due to the spawning issue it allowed me to run around everywhere, on all decks, but I couldn't find anything that gave me options to find ways off the ship. I didn't let out the zombies in containment so there's a good chance I wasn't looking hard enough for clues to get off the ship. :x
There's an ammo clip in one of the medical bays that you can't get two. (a teaser pickup perhaps) ;)
Getting blocked by some of the trimmings, like some door frames, yellow and black striped sections and on the bridge near the enterence to the tactical area. To replicate this go near these things and stop then start walking.
Still getting stuck on quite a few things in the main corridor. It get's somewhat fustrating when retreating backwards from a wave of enemies. If I can identify the exact things I'll let ya know.
In hanger 2 I reckon you should remove collision on the fuel/power cables that are laying on the floor.
Upon re-entering the medical deck the minigun had re-appeared so I picked it up and ended up with two of them as I scrolled through the weapons.
When doing the food gathering mission on the surface I found I couldn't exit the map and had to Ctrl-Alt-Del and kill the game.
I have a couple of other things written down and will post them later.
Please note I'm running via the 64bit executable. I plan to try the 32bit on my next run through to see if I don't get the spawning issue. Also if you'd like a copy of the save game to study let me know.
----
Apart from that it's been a lotta fun to play. Atmosphere is still awsome M8! :D
I did fid the main corridor very hard when you first go in to use the RAT to unlock the other parts of the ship. I couldn't survive the initial wave on all attempts I made. Ended up assuming that this was purposeful to teach me that I'm not some big gun totting hero and then just entered the main corridor, quickly using the RAT then retreating back to Deck 3 continuing on my mission. Upon entering the corridor next I had a better weapon and became that gun totting hero! :D
I really like the blinding sun on the planet surface! Looks superb M8!

Cheers for posting the new alpha for us to play! Good work! :D

I'll post more feedback this weekend!

Edited by: Lord_Porksword

Jun 13 2013, 7:16am Anchor

Thanks for the feedback. Most of the problems you described are all AI and programming based. Even the spawn problems, and zombies and aliens getting through doors. There are lots of random problems with AI which I am full aware of and will tackle when i can get a programmer sorted again. It took me ages just to get the alpha back to it original working state with no programmer to help me fix what he had done.

The lead programmer who started the AI never finished it and is not available for a while until he is paid lol. So there is nothing i can do on that part until we get the funds to continue with it. But AI is top on the list of priorities as this is what fuels most of the game-play

All the ammo has changed as well due to the programmer, and it should all be working fine but seem to have lost the ammo description upon pickup. You will be picking up ammo but there are lots of types, and you may not have the weapon you just picked up ammo for. Dont forget the MK 3 and Mk4 rifles use different ammo, then there is SMG ammo, pistol ammo and the mini-gun ammo looks totally different.

Hope you like some of the additions and improvements compared to the last alpha a month before. I managed to get a lot done but the last month i was left without a programmer.

One more thing, don't use the 64 bit exe, Unreal themselves actually tell developers not to use it, even though you have a 64 bit machine, stay with the 32 bit exe.

Thanks for the feedback :)

Jun 15 2013, 1:30pm Anchor

Is the "new" V0.33 Alpha different than the "old" V0.33 Alpha that was only available in the members section? Reason I ask is it took me about an hour to download it the first time and was wondering if the Alpha has changed since last I touched it?

Jun 15 2013, 3:40pm Anchor
Palanduss wrote:Is the "new" V0.33 Alpha different than the "old" V0.33 Alpha that was only available in the members section? Reason I ask is it took me about an hour to download it the first time and was wondering if the Alpha has changed since last I touched it?

Yes this is a new alpha than the last one, you still have exclusive access to the member area which will be added to other the coming months :)

The new alpha has much more and I suggest you check it out, I will be releasing another alpha in a couple of weeks which again will have some new additionsand bug fixes (Just sorted the Zombies Out Yesterday)

Jun 15 2013, 3:56pm Anchor

kk, I'll redownload and take a new look, Shaun. I also posted a thing on Angry Joe's show (he does reviews and such and is one of the few reliable reviewers on the internet) talking about talking a look into CDF Ghostship and maybe funding it as well. His show usually gets good traffic, usually because hes very enthusiatic and down-to-earth and constantly tries to support game developers that provide good entertainment and gets down hard on those that don't (unlike most review sites).

Jun 15 2013, 5:15pm Anchor

That sounds great, tell him to have a play with the new alpha, if he wants any exclusive screenshots, videos or artwork just tell him to give me a shout. :)

Jun 15 2013, 6:40pm Anchor

Ok! Finally finished downloading the "new" alpha. Just finished with the fire section, going to the RAT now.

Couple of things I've noticed instantly:
1) My framerates were worse than the previous alpha build. I was getting single-digit framerates on Deck 3 during the fire part. As I exceed the recommended specs, I'm surprised my framerates are so horrendous. I have 6gb DDR3 Ram, Quad Core + 2 threads per core, and a dedicated 1gb DDR5 graphics card (bought the computer in 2011).
2) The plasma SMG does not work well for me. After every shot the game freezes briefly (by freeze I mean everything stops and my framerate is 0) for about 0.333 seconds (rough estimate) and then unfreezes, then freezes again when I fire again... so if I'm firing it a lot, it freezes, unfreezes, freezes... etc. This makes aiming with it and using it in close combat to be incredibly problematic. Not only that but its horrendously inaccurate, except in close combat... which doesn't end well for me.
3) Usually AI bugs, with walls, and ceilings. AI does appear to be slightly "smarter"... they tend to run past me a lot less.
4) The new user interface for the main menu looks awesome. Keep up the great work.
5) The chewed off plasma pistol on Deck 3 is gone! Excellent.
6) Found a plasma pistol on Maintenance. Couldn't pick it up though.
7) Found several standard laser rifles, and could pick up each one. Should this be happening when these weapons have unlimited ammo and would serve no purpose other than to remove them from the environment.
8) I didn't take damage this time after colliding with crates! Awesome!
9) AI spawn locations seem to be a bit different. Dunno if this is intentional or not.
10) Little biter's teeth clip through the door leading to Hangar 1, when they chase you.
11) The ingame cutscene in the Hanger 1 doesn't play AFTER you move to about the end of the hangar towards the exit (not referring to the landing sequence, but the part where you see biters coming from the other doorway). Dunno if intentional or not.
12) Framerates FARRRRRR better after the fire is put out on Deck 3. Up around 40-50 (except when firing plasma SMG; freezes then)
13) Crate physics still could use some work. Still occasionally getting stuck on them (noticed when running after hitting decompression)
14) The "torch" for the lazer pistol is far brighter and much easier to see stuff in the environment now. Thanks! Appreciate it.
15) Ship Computer voiceovers can sometimes overlap eachother completely nullifying any usefulness for either messages as they blend together. Noticed when doing decompression and the decompression voice played while another voice said evacuate the ship and then it got garbled and couldn't make sense of either.

Will post any others I find for the rest of the experience!

Jun 15 2013, 10:31pm Anchor

Yeah i think i know about your framerate problems. Nobody else has mentioned it but i have noticed it on my other pc i installed it on.

I am sure that is something to with the particles the weapons uses when fired. The particles use PhysX and I know know that certain cards such as ATI cards do not handle the PhysX and the CPU does instead which causes problems. This is being looked into, I also suggest downloading the latest version of PhysX and graphic card drivers and see of that has any benefit. If it does then please post :)

I will sort out the plasma pistol in maintenance. Lazer weapons are in abundance around the ship, they are meant to be there - the crew that used them are dead, but when picking up a new lazer rifle for example your charge goes to max, useful for when your charge is low and you can spot a Lazer weapon and pick it up quick to carry on giving those suckers what for!

Spawns points are different, in full game they will be randomly generated and placed to make every game a fresh challenge :)

The cut scenes as in Hangar 1 have all now been removed. This is mainly now to keep everything focused on the players view for oculus rift and keeping the inevitability. There will also be a helmet first person view where you can see out of the visor which looks very realistic and will be ideal for Oculus Rift.

There is still the odd problem with voice over playing over each over, this will be sorted :)

Thanks for the feedback :)

Jun 17 2013, 2:10am Anchor

I think I found a critical bug that needs addressing in the alpha.

I was in the section for the RAT corridor and noticed that there was a bazillion biters coming from both directions, and rushed to the console and I think I hit the disengage button twice and then rushed back to the airlock so I wouldn't get mobbed. In V0.32 the corridor was barely manageable and could explore a little bit without getting mobbed to death. I see that is changed... which adds to the excitement. The problem is that now, I've travelled to the bridge and, I cannot leave the bridge AND I cannot disengage the lockdown. Unless you switched the computers, I cannot interact with the computer. I also didn't get attacked AT ALL on the bridge which I found to be odd (I got attacked several times in V0.32 while exploring the bridge before and after the remove captain lockdown). I cannot reload a past save, to "fix" my mistake, and reloading the game and relaunching it (tried both) still keeps me stuck on the bridge. [[NOTE: If you moved the computer, it may not be a bug; aka tell me which computer it is... is it the one with the Plasma Rifle MK3 leaning on it?]]

I found this issue annoying in V0.32 as well... apparently if you hit the button twice, it resets the order. This is the same for the orders to remove quarantine and such AFTER you remove captain's lockdown on bridge on the RAT. I believe if you hit it 3 times it sets it, resets then sets it again. If you could make it so that NO MATTER HOW MANY TIMES you press the button it doesn't reset and such?

I ask this because when theres enemies coming from both sides its hard to be calm and patient and take your time when there is things trying to kill you... very quickly at that. I'm not saying tone down that section, what I am saying is FIX THE BUTTON!

Now I think I will have to start from scratch to see all the new stuff... yah! >.>

Also two other bugs I found:
-> Aiming with the Lazer Pistol is impossible. When you aim with it it obscures more of your view that it does un-aimed. (try it you'll figure out what I mean quickly)
-> Aiming with the Plasma Pistol is different now. In V0.32, it zoomed onto the screen (like the Plasma SMG and Plasma Rifle MK3) but now it doesn't.

Other than that, some minor collision issues with dead bodies and Plasma SMG freezing. Shrinking my resolution from my native one helps to improve framerates by about 20 FPS. Or is it enlarging? (Went from 1366 x 760 ish to 1024 x 800 ish (i think))

Edited by: Palanduss

Jun 17 2013, 3:03pm Anchor

Yeah there has been a few changes in the new alpha (0.33). The main access corridor is now much harder if you linger, and on deck 1 there is a problem with the aliens spawning, but it gives you more time to have a look around and listen to the captains logs. Appreciate it while you can LOL. :)

I will look into the button resets and stuff on the main access corridor. There is 2 buttons for each special order, one resets it and the other engages it. This is so that if you allowed access to the store room and the stalkers got out, you can go back to the main access corridor and re-engage the lock so no more will get out.

The second time you visit the bridge you should be able to leave at anytime via the stairs. If not then this is a bug which will be fixed. I will look into this and check what the problem is.

The problems with the SMG have been mentioned, have you tried installing the latest PhysX and graphic card drivers. I would like to know if this helps, there are still a few collision issues and a few fixes which will be put into the new alpha version I should be releasing in a months time. I will keep you posted.

Thanks for the feedback :)

I also noticed that the screen pop up informing you to press e to use the captains console is not showing up, this has already been fixed in bit an alpha v0.33 it does not show up. However the console can still be activated, just the message doesn`t appear. So try going to the center of the captains console and then press e, that bit still works in v0.33

Jun 17 2013, 9:22pm Anchor

K, well found another critical bug for ya Shaun. I tried using the main console as you said, and it worked, and when I hit Disengage Lockdown the entire game crashed. I'll see if I can repeat the bug for you.

Jun 17 2013, 9:54pm Anchor

Please let me know if happens again, it might just be a random crash but if it happens again at the same point please let me know.

It would be a good idea if it does happen again, to look at the game log - which is a text doc located in your install directory in UDKgame /Logs it will be the newest dated "Launch" file. If you can past the last 10-20 lines of the log that would help nail down what the problem is.

Thanks :)

Jun 17 2013, 11:07pm Anchor

These are the last few lines in said log file:

[0148.90] Log: === Critical error: ===
Fatal error!Address = 0x2ad0cc8 (filename not found) [in C:\UDK\GhostShipAlphaV33\Binaries\Win32\UDK.exe]
Address = 0x2c21a20 (filename not found) [in C:\UDK\GhostShipAlphaV33\Binaries\Win32\UDK.exe]
Address = 0x2bcab71 (filename not found) [in C:\UDK\GhostShipAlphaV33\Binaries\Win32\UDK.exe]
Address = 0x2c14477 (filename not found) [in C:\UDK\GhostShipAlphaV33\Binaries\Win32\UDK.exe]
Address = 0x2ad0fbf (filename not found) [in C:\UDK\GhostShipAlphaV33\Binaries\Win32\UDK.exe]
Address = 0x1e4879b (filename not found) [in C:\UDK\GhostShipAlphaV33\Binaries\Win32\UDK.exe]
Address = 0x1e4a706 (filename not found) [in C:\UDK\GhostShipAlphaV33\Binaries\Win32\UDK.exe]

Jun 17 2013, 11:12pm Anchor

Have you got the last 10 lines before this please :) that would show what it was doing or attempt to do just before the critical error :)

Jun 17 2013, 11:19pm Anchor

Okay did not crash on me again BUT.... several new bugs:

-> Aiming with the Plasma Rifle also causes freezing
-> Aiming with the Plasma SMG apparently only causes freezing. Firing it at the hip, doesn't cause freezing but its horribly inaccurate so it doesn't help much.
-> Firing with the Plasma Rifle kills my framerate. Didn't have this issue in V0.32
-> Zombies no longer have a walking animation... they just... float.
-> I shot the zombies in the head about 50 times with the Plasma MK3 and will not die. I expended over 10 clips of ammo trying to kill two of them, aiming carefully for the head, to no avail. I did not have this much trouble killing zombies when I played the V0.32 Alpha. I ended up getting killed by the zombies)
-> I didn't notice this in V0.32, but in V0.33 the door with 2 plasma clips next to it now opens up... I thought communications was off limits for the Alpha? Or is this area not communications (this is Deck 1 on the bridge after turning off the lockdown heading towards the staircase.

Well... before those lines it just had line after line after line of Animation for Zombies not found (in a nutshell; would explain why the zombies float) Ex: [Log: PlayCustomAnim ZombsWalk1, CustomChildIndex: 1, Animation Not Found!!]

Something else that may help you narrow it down:

ScriptWarning: Accessed None 'customAnimNode'
RamaAI_Zombie gs-zak6.TheWorld:PersistentLevel.RamaAI_Zombie_3
Function Ghostshipalpha.RamaAI_Zombie:doAttack:00AA

Edited by: Palanduss

Jun 17 2013, 11:40pm Anchor

Yeah the zombies is already fixed, noticed that myslef staright after the alpha was released. They still have problems dying though, I am looking into that :)

I opened up a little of the comms bit on deck 1, so you can have a bit more wander, lots of new stuff in new alpha next month.

The framerates on the plasma weapons are because of using PhysX - realistic particles. These have problems with ati cards and some computers. Please can you donwload and install latest version of PhysX and see if that helps, please let me know. You did not have problems with those weapons in the last version as the particle effects for impact where only recently added. Thats is one problems at the moment that i would like to sort for the next alpha :)

Jun 18 2013, 1:42am Anchor

K, ill redownload my drivers, though they should be up to date. I'm using a Nvidia graphics card though. Shouldn't it have PhysX with it?

EDIT: Apparently a new one came out in May. Downloading it now :)

Edited by: Palanduss

Jun 18 2013, 2:29am Anchor

Great. let me know how it goes.

Also regarding your pistol view problem. That may due to resolution. I have just tried it myself on 1280x1024 and the weapons are misplaced.

Try using resolution -

1152x648

Let me know if the pistols are better on yours with that resolution :)

Jun 18 2013, 2:30am Anchor

======================================
I'm sure you are getting tired of hearing this but... More bugs:

-> I shot and killed the same biter about 7 times before it finally died (I checked, no others had spawned and kept my eye on its "corpse"). Apparently its not just Zombies that are having a field day with invulnerability.
-> I shot and killed the same 4 legged biter (not stalker/hunter... one that looks more like a rat or something) about 6 times. After the 6th time it finally stayed dead.
-> I've installed latest drivers, and my drivers says it supports PhysX and the Plasma SMG, and Plasma Rifle STILL causes freezing when firing. Your game doesn't like me. >.<
-> When I entered Deck 3 after disengaging the lockdown I kept getting a message saying that Storage Locker.. B? or is it A? is locked and has to be unlocked with the RAT (whichever one was crowded to the brim with nasties in V0.32). Anyway, I went to check what was causing the message to appear and... ran into about 15 stalkers. Apparently somehow they got out of the storage room WITHOUT it being manually unlocked by me, in the RAT.
-> The Plasma MK3 Rifle no longer shows how many clips are left when you reload your weapon.
-> When an enemy goes "down" shooting its corpse repeatedly in the head has no effect in making sure it "stays" dead. I empty my entire 79 shots from the Plasma MK3 into that rat-biter thing's head and it still got back up. Does shooting a corpse actually work to keep it dead, or waste of ammo?

PS: What happened to the AI since V0.32? It seems the "get back up and alive" routine is out of whack compared to the previous version. Whats up with that do you think?

EDIT: Yes that resolution works. However the other resolutions have you staring into the ammo counter on the Lazer Pistol and the Plasma Pistol is away to your right and you have no clear viewing of the screen.

EDIT2: I went into Nvidia Control Panel manually and changed most of the "feature settings" for UDK.exe (32bit). I turned off most settings and set everything to maximum to performance, and I can now fire the plasma rifle MK3 without freezing... though the Plasma SMG still freezes. Which DirectX are you using for this game? DX9? DX10? or DX11?

Jun 18 2013, 3:03am Anchor

They are the little ones lol, did you not see the signs? watch out for the little ones. They play dead, and take lots to kill. Wait till you see the BIG Ones :)
There are still problems with AI as previously mentioned, they can get through closed doors every now and then, so they would have got out of store room b even if you did not take off the lock. You will have to bear with me on that one :)

The game uses direct 9 onward, so all should be fine. You could try making sure you have the latest versions installed. It may also help other to know which settings you needed to change in your nvidia control panels if helped somewhat. But you are still getting problems with freezing on smg. I will look into this further. What graphics card is it you are using (which model) And i presume its a desktop.

Thanks once again for feedback :)

Jun 18 2013, 4:01am Anchor

Laptop actually. Gaming Laptop. I'm using a Nvidia Geforce 525M. Its a dedicated integrated card (My system reads it as 1.5gb DDR5, however Nvidia tells me its a 1.0gb DDR5 card... so going with Nvidia's assessment). For some finicky games (ie Skyrim) I have to force the game thru the control panel to use the Dedicated Card. By this I mean that my laptop has two graphics cards; 1) Is an integrated Intel Chip that is designed for normal wear and tear and use of most programs. 2) The dedicated card is designed for the heavy duty work.

I don't see how my card could be having trouble with your game. As I've said (probably somewhere) that I can play Crysis 2+3, Farcry 3, Battlefield 3, Skyrim, and a host of other graphically and processor intensive games without too many problems (Crysis 3 requires a number of settings turned off).

Heres a link to my Card on Nvidia, so you can take a look:
Geforce.com

On the main page it does say it supports PhysX, so dunno whats up with that.

EDIT: Actually apparently its DDR3, strangely enough. Though still dunno how that should make any difference as I can run other Unreal Engine 3 games without issues.

EDIT2: Dang on Storeroom B >.> I wanted to check out Storeroom A :(

Jun 18 2013, 6:05am Anchor

Yes its strange, most people run fine but some people do have problems with the SMG especially. Its all down to the particle effect i have used for the hit effects where you can see the the round shatter on impact. Each particle uses real gravity and uses PhysX instead on the engine physics. It is meat to be ATI cards that do not support PhysX so the cpu handles it which can sometimes overload the cpu. But you have a nvidia card, and my other pc which i tested it on also has a nvidia card although it is at least 3 years old, maybe 4. But also had same problem on that mainly with smg. So at least i have a machine with that problem which i can use for sorting it out.

I need to get to the bottom of this, if not by the next alpha release then it will be sorted by the Beta :)

Edited by: MAGStudios

Lord_Porksword
Lord_Porksword Unreal Old Friends
Jun 18 2013, 7:19am Anchor

I haven't had the same performance or freezing issues myself. Admittedly I have a good gaming rig though.

Jun 18 2013, 8:02am Anchor

Laptops, even gaming ones can still struggle, and the older they are the worse they can get. I have an alienware 17x, had it for almost 3 years now still runs games ok, but not as well as it used to.

Are you using a Nvidia card Lord Porksword?

Reply to Thread
click to sign in and post

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.