I have created this list to try and address the most common questions that are asked about the Soulstorm: Strongholds mod. Please read through this before posting any new questions on the mod pages, as there is a good chance they will already be answered here. I will be updating this periodically with any common questions that may arise in the meantime, so be sure to check back occasionally. :)

Posted by on - Basic Other

Q: Is Dawn of War: Strongholds compatible with Ultimate Apocalypse / Titanium Wars / CornCobMan's Funmod / DoWPro / Dawn of Immolation / Codex / Epic Legions / Dawn of Coalescence / Galaxy In Fire / whatever mod?

A: No. All of these mods make major changes to the basic file structure of the game, especially to the makeup of the basic nine factions, which renders them incompatible with Dawn of War: Strongholds. Basically, if a mod isn't listed in the Dawn of War: Strongholds readme file as being compatible, then it almost certainly isn't.


Q: Will you be adding support for race 'X'?

A: Rest assured that I am following the progress of all new race mods with an eye to incorporating them into Strongholds if at all possible. I have only three criteria for inclusion: (1) the mod must be good; (2) the mod must have reached a relatively stable point in development where few if any changes to the attribute files are expected; (3) it must be compatible with the latest public build of Unification.


Q: Can this mod be played in multiplayer?

A: Not a chance. Quite apart from the fact that the missions aren't set up for this, the amount of scripting required for stronghold missions would cause all kind of sync errors if you ever attempted it with multiplayer (both cooperative and competitive).


Q: Is it possible to play stronghold missions as the defender?

A: No, the mission scripting is set up with the assumption that the human player will be the attacker. However, if you are interested in defensive missions the Unification mod has you covered with its Survival missions.


Q: Is it possible to play with an AI ally?

A: Again, no. The mission scripts are not set up to support this, and some of the missions already have all eight available player slots taken anyway so there would be no room for an AI ally.


Q: The mod won't activate.

A: Run the "configure_mods.cmd" file in your "stronghold_missions_ss" folder. Any problems should flag up here. If you still have trouble getting the mod to run, feel free to PM me and I will see what I can do to help.

Comments
BoyarTactics
BoyarTactics

Hey Kasrkin84, man I guess you had a lot of fun with the questions :D

Reply Good karma Bad karma+5 votes
deathtrooper900
deathtrooper900

I know you said the Ultimate Apocalypse doesn't work with SS but it mostly works for me with an occasional SCAR error.

Reply Good karma Bad karma+3 votes
K84 Author
K84

I count SCAR errors as evidence of incompatibility.

Reply Good karma+3 votes
deathtrooper900
deathtrooper900

Fair enough.

Reply Good karma Bad karma+3 votes
lorddrogan
lorddrogan

Hello,I have a problem,I get the last version of Soulstorm: Strongholds, the '[v1.4.0]',I had downloaded all of the mods wich are required for Strongholds but I can't play 'Space Wolfs', 'Tyrannids mod', 'Salamenders mod',' Dance Macabre mod', 'Reneguad Guard mod', 'Khorne Warband mod' units and I can see them in the army painter.
Please,help me,thank's for answer.

Reply Good karma Bad karma+1 vote
Guest
Guest

This comment is currently awaiting admin approval, join now to view.

Angron3000
Angron3000

When I click on cofigure_mods it says access denied. What should I do?

Reply Good karma Bad karma+1 vote
K84 Author
K84

Have you tried "run as administrator"?

Reply Good karma+1 vote
Guest
Guest

When i go to my mod manager and it says Unifiction mod the mod you also need for it then it says lotd MISSING what is lotd? PS Do i need to download all the races for the stronghold mod to play it?

Reply Good karma Bad karma0 votes
K84 Author
K84

I would avoid using the mod manager for this. Just run the configure_mods.cmd file in the stronghold_missions_ss folder, which will tell you if you have everything required. The only required mods are the latest versions of Unification (don't worry about its prerequisites), FreeUI, Bugfix and Objective Points. LOTD is the Legion of the Damned mod, which is only optional for Strongholds along with all the other faction mods.

Reply Good karma+1 vote
Guest
Guest

My mod doesnt work when i go to the game manager then it says $7000000 no range i have all the mods to get it to run but it doesn't work

Reply Good karma Bad karma0 votes
K84 Author
K84

Did you get any error messages when running configure_mods.cmd?

Reply Good karma+1 vote
Guest
Guest

No

Reply Good karma Bad karma0 votes
K84 Author
K84

Possibly a corrupted download then - delete the mod from your PC and try downloading and installing again.

Reply Good karma+1 vote
Guest
Guest

This comment is currently awaiting admin approval, join now to view.

jsailer412
jsailer412

Hi, I've encountered a problem with the latest version of the mod. Basically, my builders cannot build anything. When you click on the build button, it takes you to a blank page rather than the building page.
So, I'm basically stuck with the forces I am deployed with. Is this a common problem, and is there a way to get around it?

Reply Good karma Bad karma+2 votes
K84 Author
K84

Make sure you have the most recent version of FreeUI and Unification installed.

Reply Good karma+1 vote
Reclusiarch95
Reclusiarch95

I too face this issue, I have the latest versions of both FreeUI and Unification but still, I cannot build anything.

Reply Good karma Bad karma+1 vote
Guest
Guest

Hello, I have downloaded all the pre-requisite mods for this, but when I try to run configure mods it says that it cannot find FreeUI. Please help me as I was really excited to try this out :(

Reply Good karma Bad karma0 votes
Samus6319
Samus6319

Okay so I assumed that the problem would be that when extracting FreeUI I only got a freeUI folder and not a module file for it, so I thought something must be wrong with the download and did it again but it still extracted to the same. Did it a third time, no change. Out of desperation I re-downloaded it a fourth time and it finally extracted giving me both a freeUI folder and module file, and stronghold finally compiled and told me I can activate it! I was overjoyed however when selecting it from the game manager, the game restarts and then it says "Failed to activate requested game" :( Could it be because I don't own Winter Assault? (Have all 3 other DoW1 games)

Reply Good karma Bad karma+1 vote
Samus6319
Samus6319

Nevermind I'm an idiot! Turns out that I had accidentally downloaded the 1.73 patch twice instead of downloading the 1.70 mod once and the patch once. Downloaded the proper mod and everything works, and it's heaps of fun! Thank you very much! :D

Reply Good karma Bad karma+1 vote
Guest
Guest

This comment is currently awaiting admin approval, join now to view.

Guest
Guest

This comment is currently awaiting admin approval, join now to view.

SpikeyBoyzAreDaWurst
SpikeyBoyzAreDaWurst

Hello! So i got this weird problem that i managed to do everything Perfectly, The Configure_Mods didn't show any issues and everything seemed perfect, But i still can't load the game, Lie everytie i try to enter the game from the game's menu it says it can't enter said mod, Any help? I can get in depth with more details.

Reply Good karma Bad karma+1 vote
Guest
Guest

This comment is currently awaiting admin approval, join now to view.

Guest
Guest

I played as any race in any map and yet i can't go to tier 2 in any hq of any race why?

Reply Good karma Bad karma0 votes
K84 Author
K84

Turn off "Restricted Tiering" on the mission setup screen.

Reply Good karma+1 vote
Guest
Guest

This comment is currently awaiting admin approval, join now to view.

Post a comment
Sign in or join with:

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.