Dear people of the Modb community, we, former and current MOS members, have created a huge submod for your entertainment. This mod might have started out as a compilation of many smaller mods, but currently houses much unique content as well. MOS aims to be as lore accurate as possible while giving the best game-play experience ever seen in the world of Third Age Total War. After not being active for more than a year we are once again busy updating our mod. This has resulted in the release of version 1.7. We are still at it and we expect that there are yet some updates to look forward to. The Massive Overhaul Mod (or simply MOS) is a submod for Third Age Total War, one of the most popular submods that ever has been made for Medieval II Total War Kingdoms.

Add file Report MOS 1.70 all inclusive patch
Filename
MOS_1.7_all_inclusive_patch.rar
Category
Patch
Uploader
Vetera@n
Added
Size
122.74mb (128,698,281 bytes)
Downloads
21,025 (1 today)
MD5 Hash
f19384318741bdf2feeeea5d3141f642
Embed Button
Embed Widget
Description

This is the latest version (2016 April 13th) of the MOS 1.7 all inclusive patch. It includes all the content from the previous patches, fixes a few serious problems and adds a big settlement buildings update for Gondor. Only this patch has to be installed, after installing the main MOS 1.7 files. Further info can be found in the description paragraph.

Preview
MOS 1.70 all inclusive patch
Comments
fenix02
fenix02

game crashes on launch after installing the all inclusive patch.
tested and MOS1.7 works until this is installed.

Reply Good karma Bad karma+3 votes
☪MidnightWinter❄
☪MidnightWinter❄

Same thing happens to me, it starts and than crashes back to desktop without any error message.

Reply Good karma Bad karma+1 vote
Vetera@n Author
Vetera@n

Run the cleaner.bat file which you can find in the "Third_Age_3" folder.

Reply Good karma+1 vote
fenix02
fenix02

**after more testing looks like the Megaupload link works**

Reply Good karma Bad karma+1 vote
ForgedinBronze
ForgedinBronze

Are you referring to the one from TWCenter? That one is the older all inclusive patch I believe (same exact size as the 1-04 version).

Reply Good karma Bad karma+1 vote
Guest
Guest

Hi, I installed the game but when i want to run it, it crash with statement: Script: C:\...\Third_Age_3\G5BAISwitcher.vbs
Line: 26
Char: 23
Error: Permission denied
Code: 800A0046
Source: Microsoft VBScript runtime error
i have windows 10, which can be the issue, becouse on windows 7 i could play MOS with ease...So guys did someone of u faced and solved this problem? I would appreciate any advice. THX :D

Reply Good karma Bad karma+1 vote
Vetera@n Author
Vetera@n

Looks like the mod may be installed in the wrong folder and/or a problem with UAC.

Reply Good karma+1 vote
Guest
Guest

So i cant install enhanced submod? with this patch

Reply Good karma Bad karma0 votes
Vetera@n Author
Vetera@n

That should be no problem at all. If there is a problem with the enhanced submod, it should not be caused by this patch which is an "official" part of MOS 1.7.

Reply Good karma+1 vote
Zoocharie
Zoocharie

Hi can i install the enhanced submod with this patch

Reply Good karma Bad karma+1 vote
Vetera@n Author
Vetera@n

Yes, see my answer just above your question.

Reply Good karma+1 vote
Yoan84
Yoan84

Hy I really like this submode. I notice the woodland elves are more overpowered that the Lothlorien one and they are some issue I would ask you to change:
- can you exchange the "Galadhrim Guards" with some pike unit with armor piercing attack like the woodland tier 2 axe unit the Knights of |Erynnor.
-the woodland elves rangers are identical with the archers...can you make their stats identical with Lothlorian rangers? the same issue with the Woodland Nobles unit, they have identical stats with the other after barracks archer unit Erynnor Guard Archer I think is their name.

Thank you very much and have a nice day.

Reply Good karma Bad karma+1 vote
Vetera@n Author
Vetera@n

Thank you, glad you like it.

Changing these units is not going to happen anytime soon, I expect. probably not at all.

Reply Good karma+1 vote
Guest
Guest

hey can this mod be used in conjuncture with the Dac mod

Reply Good karma Bad karma0 votes
Vetera@n Author
Vetera@n

No

Reply Good karma+1 vote
thompa91
thompa91

hey can this mod be used in conjuncture with the Dac mod

Reply Good karma Bad karma+1 vote
Vetera@n Author
Vetera@n

No

Reply Good karma+1 vote
eriksmith
eriksmith

So you are pasting this over the folder Third_Age_3

Reply Good karma Bad karma+1 vote
lephuc131194
lephuc131194

i crash when starting custom battle. The screen of custom battle appears with "deployment" and suddenly crash

Reply Good karma Bad karma+2 votes
Dragossilver
Dragossilver

i cant start the game bacuse it crashes before the game starts...

Reply Good karma Bad karma+1 vote
Yipikayyei94
Yipikayyei94

I installed all this. It looks that it works but when I'm only playing for a moment it crashes. I used the cleaner and it does the same thing. Any idea?

Reply Good karma Bad karma+1 vote
blazemaster268
blazemaster268

It's not working for me, After I run it and close it I double click the third age.bat like always but it crashes anyways!
Please help me!

Reply Good karma Bad karma+1 vote
twright90
twright90

Hello, I downloaded MOS and extracted the 1.7 and the all-inclusive patch using 7-Zip; they are located in my Third Age folder which I have renamed 'teutonic' for access via Steam. I have not been asked to overwrite the files - I am uncertain what I have done wrong. If I click the .Bat I am told that 'Windows cannot find medieval2.exe'. Please could you advise me what to do? Apologies for asking for help. Thank you

Reply Good karma Bad karma+2 votes
Xbeny100
Xbeny100

I've run the cleaner but it still crashes saying it had an unspecified error, what do I do?

Reply Good karma Bad karma+1 vote
Guest
Guest

This comment is currently awaiting admin approval, join now to view.

SirAlatriste
SirAlatriste

Same to me

Reply Good karma Bad karma+1 vote
Ameng_Jun
Ameng_Jun

Hello i'm new here. This all inclusive patch is mean that 01-05 version ? or just only have 01-04 version patch? i want to download the dwarven mode so need to know this ...

Reply Good karma Bad karma+1 vote
Guest
Guest

This comment is currently awaiting admin approval, join now to view.

Post a comment
Sign in or join with:

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.

Follow Report Profile
Icon
Medieval II: Total War: Kingdoms
Contact
Send Message
Homepage
Twcenter.net
Release date
Mod watch
Follow
File
Browse
Files
New
Add file
Report
Report
Share
Related Games
Related Groups