BrewLAN is a mod for Supreme Commander: Forged Alliance that has been in on and off development by a team of one for almost a decade. It adds a wide variety of new units for all factions, as well as offering several new game modes and features. The core design goals for the mod are simple; to add new, interesting, and visually aesthetic units which complement those already in existence and to maximise technical compatibility with other mods.

Report BrewLAN 0.5 beta
Filename
BrewLAN_05.7z
Category
Full Version
Uploader
Balthassar
Added
Size
22.34mb (23,426,840 bytes)
Downloads
1,422 (1 today)
MD5 Hash
2c507109fdd9ec71b2ac68816b6a5a0d
Embed Button
Embed Widget
Description

BrewLAN 5 year anniversary edition. Version 0.5 beta. BrewLANniversary. Remove previous versions of BrewLAN before installing, direct overwriting will result in files deleted between versions to remain, causing errors and desyncs. To install, place the 'brewlan.scd' file in the 'gamedata' folder, and the 'BrewLAN' and 'BrewUI' into the 'mods' folder. If a mods folder doesn't exist create one at the same level as the 'gamedata' folder. If the SCD file isn't placed in the 'gamedata' folder you will encounter missing textures (strategic icons for mobile anti-nukes and landmines, and the Gantry mode change icon). The BrewUI module is non-essential and changes the idle engineers tab to include all new field engineers. If you are running on FAF, for best results run on the BlackOps game mode. The irony is strong with this one, but regular FAF breaks a number of things, which work on the BlackOps game mode.

Preview
BrewLAN 0.5 beta
Comments
Battle8111

You guys going to upload this to FAF mod vault also?

Reply Good karma Bad karma+1 vote
Balthassar Author
Balthassar

When the weird issues with the default game mode of FAF are sorted.

Reply Good karma+2 votes
Guest
Guest

It crahes game, used with black ops mod

Reply Good karma Bad karma0 votes
Balthassar Author
Balthassar

Which BlackOps and what else were you using?

Reply Good karma+1 vote
Guest
Guest

Latest version of black ops, turn off all, activate only brewlan 0.5, problem, brewlan 0.4.4 works fine without

Reply Good karma Bad karma0 votes
Balthassar Author
Balthassar

I am pretty sure I tested it with BlackOps extensively before release, but I will look into it.

Reply Good karma+1 vote
EmptySoul01
EmptySoul01

Love this update thank you so much.

Reply Good karma Bad karma+1 vote
Akunde
Akunde

I'm getting a crash between this mod and the Total Veterancy mod. Can anyone else verify?

Reply Good karma Bad karma+1 vote
Balthassar Author
Balthassar

This is a known issue that I couldn't find the cause for before release.

Reply Good karma+1 vote
Tondrai666
Tondrai666

I also have the same crash with BlackOps mod sadly.
During loading of a mission (I have a mod that enables mods in campaign) it crashes at the loading screen.

I use BlackOps 3.2, BlackOps Support 5.0 and BlackOps ACU 3.2

Reply Good karma Bad karma+1 vote
Balthassar Author
Balthassar

3.2? BlackOps Unleashed 6 has been around for years.

Reply Good karma+1 vote
Tondrai666
Tondrai666

Then I should look for a new version xD
I'll download that and retry and let you know!

Reply Good karma Bad karma+1 vote
Guest
Guest

Brewlan 0.4 conflict with blackops 6
Brewlan 0.4.3 and 0.4.4 works fine
Brewlan 0.5 problem

Reply Good karma Bad karma0 votes
Balthassar Author
Balthassar

BrewLAN 0.5 doesn't conflict with BlackOps 6. I have ran the two together fine on both Steam and FAF. It does however conflict with Total Veterancy, and probably other things. What other mods are you trying to run besides BrewLAN and BlackOps?

Reply Good karma+1 vote
Guest
Guest

This comment is currently awaiting admin approval, join now to view.

stanolaser
stanolaser

Please mods compatibility?

Reply Good karma Bad karma+1 vote
stanolaser
stanolaser

Doesn't work for me any mosd only themselves.

Reply Good karma Bad karma+1 vote
Tondrai666
Tondrai666

I found the problem for me...
In my case the mod isnt compatible with Xtrem Wars 1.00
It just crashes to desktop everytime

Reply Good karma Bad karma+1 vote
deathtropper
deathtropper

Yea my issue seems to be any mod with Veterancy, including total Veterancy, Xtrem wars, and Experimental wars.

Reply Good karma Bad karma+1 vote
Trooper_
Trooper_

From what My experiance has been with 0.5 is that it will CTD nearly 95% the time if, I have Black ops icon support activated (I think, I have version 5.0 of that? not 100% sure on that tho),

I will attempt to trouble shoot with the mods I use to see if I can make sure nothing else is giving me issues and give you a better bug report. Weirdly 0.4.4 worked completely fine with the exact same mods that I tried to use with 0.5.

Reply Good karma Bad karma+1 vote
Tondrai666
Tondrai666

I have the same. 0.4.4 worked fine with Xtrem wars.

All my other mods (Antares, Jon mod, Total Mayhem, Black ops and modded Campaign) have no issues.

I have Black Ops Icon 5.0 and it works fine

Reply Good karma Bad karma+1 vote
Balthassar Author
Balthassar

I have a fix for the Xtreme Wars crash. Its caused by their hard changes of the Fatboy conflicting with my scripted changes of the Fatboy: They removed its ability to build, and I tried to give it another unit to build without checking if it can still build.

Currently changing the way the Armored Walls choose what they can build so it will work better with other mods, then I'm going to work on the Total Veterancy crash.

Reply Good karma+1 vote
Guest
Guest

Brewlan 0.5 tested

Works fine with this mods:

-Alien nations unit additions
-Antares unit pack
-BlackOps 6.0
-Crank unit mod 1.0
-Deep blue naval pack
-Experimental wars 1.96
-Global mod
-Hawks unit pack
-Infinite war v2
-Legions Darrath unit pack
-Necro bot mod
-Normalius unit matrices
-Reds unit pack
-Supreme unit pack v6
-T3 engineering stations
-Template rotator
-Terra former
-Total mayhem v1.19
-Wyvern battle pack

Problem with 4th dimension 2.11, works only basic mod without "4th dimension explosions" this cause game crash

Reply Good karma Bad karma0 votes
Balthassar Author
Balthassar

I couldn't recreate the crash with 4th Dimension Explosions. However I am testing this with BrewLAN 0.5.1, 4th Dimension 2.12 and 4th Dimension Explosions 2.1. So I either fixed the problem along with the Total Veterancy & Xtreme Wars fixes, or the problem doesn't exist with 2.12.

Reply Good karma+1 vote
Tondrai666
Tondrai666

Awesome so next version will be bug free again?
AWESOME :3

Reply Good karma Bad karma+1 vote
Balthassar Author
Balthassar

Yep, also I am about to start uploading the next version. Currently sorting out the download page description. It will be a number of hours before its authorised for download. But very soon.

Reply Good karma+1 vote
Guest
Guest

This comment is currently awaiting admin approval, join now to view.

Post a comment
Sign in or join with:

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.

Follow Report Profile
Icon
Supreme Commander: Forged Alliance
Developer
BrewGroup
Contact
Send Message
Homepage
Github.com
Release date
Mod watch
Follow
File
Browse
Files
Report
Report
Share
Related Games
Supreme Commander
Supreme Commander Real Time Strategy
Related Groups
BrewGroup
BrewGroup Developer