Post news Report content RSS feed Invalid User ID or Steam ID Ticket Fix

For the last 2 days, many people have been having: Disconnect: Invalid Steam userID or Invalid Steam ID Ticket. We have a fix for it.

Posted by on

Hey guys!

For the last 2 days, many people have been having: Disconnect: Invalid Steam userID or Invalid Steam ID Ticket. I tried everything, including deleting blobs, restarting steam, restarting my PC; and restarting my router. For some reason my laptop worked fine. So I was searching the steam forums, and it seems I am not the only one with this problem. For the last 48 hours HL2/OB mods have not been working for a ton of people, but someone recently posted a fix, which works:

Go to your steam folder, and delete everything except for Steam Apps and Steam.exe. Steam will be prompted to download all the steam files (not your game files) again after you try to launch it.

Topic with the fix:

Forums.steampowered.com

-MPC

Comments
Mkilbride
Mkilbride

Yeah, this has been happening on every mod...

So frustrating as I saw some of my favorite mods catch **** for this, when it wasn't even their fault.

Reply Good karma Bad karma+2 votes
WS-GS8
WS-GS8

Oooookay, no offense, but that's kinda like carpet bombing a neighborhood just because one guy in one house is a criminal.
Just go to your Steam folder, then to the config folder, then delete ONLY the "config" file in the config folder, and if that doesn't work, then delete (or rename) the entire config folder, but theres no need to empty out your entire Steam folder.
Please note, the steam guard email verification thingy will still be activated.

Reply Good karma Bad karma+2 votes
SteyrKat
SteyrKat

This actually worked for me. Deleting config.vdf fixed the problem. Thank you!

Reply Good karma Bad karma+1 vote
Lubci50cal
Lubci50cal

deleting "ClientRegistry.blob" is enough, I believe.

Reply Good karma Bad karma+1 vote
JuQu
JuQu

Didnt work for me. When you do like Nathan_Hale posted that will help.

Reply Good karma Bad karma+1 vote
Lubci50cal
Lubci50cal

well maybe both blobs... when I had problems like these, it got back to normal without deleting so much stuff, but I can`t remember what exactly I removed.

Reply Good karma Bad karma+1 vote
SteyrKat
SteyrKat

Deleting both blobs still doesn't work.

Reply Good karma Bad karma+1 vote
Post a comment
Sign in or join with:

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.

News
Browse
News
New
Post news
Share
Related Games
Half-Life 2
Half-Life 2 First Person Shooter
Related Groups
Battle Grounds 2 Developers
Battle Grounds 2 Developers Developer & Publisher