Zombie Grinder is the debut game of TwinDrills, an indie game development duo made up of Tim 'Infini' Leonard and Jordan 'Jordizzle' Chewning. It's a multi-platform (windows, mac, Linux!) (also Free!) cooperative multiplayer arcade game, reminiscent in style and gameplay of retro games like 'Zombies Ate My Neighbors' and 'Super Smash TV!', but with the added benefit of some newer game mechanics - achievements, ranking, player-customization, rpg style stats and so forth. The game sports a variety of different game modes, from co-operative 'campaign' style levels, to wave maps and even the classic 'pvp' style game modes - deathmatch, capture the 'bag' and so forth. All of these mods are bristling with a variety of weapons and items, all lovingly displayed in Jordan's classic quirky pixel-art style.

Forum Thread
by member
  Posts  
Not opening on Ubuntu 12.10 via Desura (Games : Zombie Grinder : Forum : Bug Reports & Support : Not opening on Ubuntu 12.10 via Desura) Locked
Thread Options
Jan 21 2013, 7:53pm Anchor

Hi there, 

I just downloaded your game and I'm not able to launch it.
When I open it from Desura, nothing shows up. I also did Right-Click -> Launch, nothing.
I also went directly to the directory that it installed in (/home/shifat/Desktop/desura/common/zombie-grinder/) , then launched both the executable and the .sh file. Still, nothing appeard or launched.
 
Is there a certain minimum requrement for the game? Similar thing happened with Team Fortress 2 via Steam. It would not launch because I did not have the proper hardware to play the game. 

Here's my specs:

Ubuntu 12.10 32bit
CPU: Intel Core 2 Duo 2.4Ghz P8600
GPU: Mobile Intel® GM45 Express Chipset x86/MMX/SSE2
RAM: 4GB DDR 2 (3.8 usable, the 200MB belongs to Graphics)

I'm hoping there is a way to fix the issue. 

It looks like a great game and I can't wait to play it! :)
Thanks,

Shifat Taushif

Edited by: shifattk

Infinitus
Infinitus Developer
Jan 21 2013, 9:49pm Anchor

Hiya,

Can you run the following command from the directory the executable is in and give me the results?

ldd ZombieGrinder

Thanks!

--

Jan 22 2013, 7:45pm Anchor

Hi,
I have ran the command in the install directory as you requested and here is my result:

code:
shifat@shifat-ubuntu:~/Desktop/desura/common/zombie-grinder$ ldd ZombieGrinder
  linux-gate.so.1 =>  (0xb771e000)
  libX11.so.6 => /usr/lib/i386-linux-gnu/libX11.so.6 (0xb75cf000)
  libXxf86vm.so.1 => /usr/lib/i386-linux-gnu/libXxf86vm.so.1 (0xb75c9000)
  libGL.so.1 => /usr/lib/i386-linux-gnu/mesa/libGL.so.1 (0xb756a000)
  libGLU.so.1 => /usr/lib/i386-linux-gnu/libGLU.so.1 (0xb74e3000)
  libfreetype.so.6 => /usr/lib/i386-linux-gnu/libfreetype.so.6 (0xb7449000)
  libXft.so.2 => /usr/lib/i386-linux-gnu/libXft.so.2 (0xb7433000)
  libXpm.so.4 => /usr/lib/i386-linux-gnu/libXpm.so.4 (0xb7421000)
  libstdc++.so.6 => /usr/lib/i386-linux-gnu/libstdc++.so.6 (0xb7337000)
  libm.so.6 => /lib/i386-linux-gnu/libm.so.6 (0xb730b000)
  libgcc_s.so.1 => /lib/i386-linux-gnu/libgcc_s.so.1 (0xb72ed000)
  libpthread.so.0 => /lib/i386-linux-gnu/libpthread.so.0 (0xb72d2000)
  libc.so.6 => /lib/i386-linux-gnu/libc.so.6 (0xb7128000)
  libdl.so.2 => /lib/i386-linux-gnu/libdl.so.2 (0xb7122000)
  libxcb.so.1 => /usr/lib/i386-linux-gnu/libxcb.so.1 (0xb7100000)
  libXext.so.6 => /usr/lib/i386-linux-gnu/libXext.so.6 (0xb70ee000)
  libglapi.so.0 => /usr/lib/i386-linux-gnu/libglapi.so.0 (0xb70d8000)
  libXdamage.so.1 => /usr/lib/i386-linux-gnu/libXdamage.so.1 (0xb70d4000)
  libXfixes.so.3 => /usr/lib/i386-linux-gnu/libXfixes.so.3 (0xb70cc000)
  libX11-xcb.so.1 => /usr/lib/i386-linux-gnu/libX11-xcb.so.1 (0xb70c9000)
  libxcb-glx.so.0 => /usr/lib/i386-linux-gnu/libxcb-glx.so.0 (0xb70b1000)
  libdrm.so.2 => /usr/lib/i386-linux-gnu/libdrm.so.2 (0xb70a4000)
  libz.so.1 => /lib/i386-linux-gnu/libz.so.1 (0xb708b000)
  libfontconfig.so.1 => /usr/lib/i386-linux-gnu/libfontconfig.so.1 (0xb7052000)
  libXrender.so.1 => /usr/lib/i386-linux-gnu/libXrender.so.1 (0xb7048000)
  /lib/ld-linux.so.2 (0xb771f000)
  libXau.so.6 => /usr/lib/i386-linux-gnu/libXau.so.6 (0xb7044000)
  libXdmcp.so.6 => /usr/lib/i386-linux-gnu/libXdmcp.so.6 (0xb703d000)
  librt.so.1 => /lib/i386-linux-gnu/librt.so.1 (0xb7034000)
  libexpat.so.1 => /lib/i386-linux-gnu/libexpat.so.1 (0xb700b000)
 

 

Thanks,
Shifat

Infinitus
Infinitus Developer
Jan 22 2013, 9:51pm Anchor

Huum, seems like you have all the statically linked libraries.

There should be a folder called libs in the install directory, can you copy the contents to /usr/lib and try again?

--

Jan 24 2013, 4:04pm Anchor

I copied the files to /usr/lib but still not opening....

Infinitus
Infinitus Developer
Jan 24 2013, 5:16pm Anchor

Are there any logs in this folder;

~/.ZombieGrinder/install.public/logs ? 

And does anything get printed to stdout/stderr when you run it via the terminal?

--

Jan 24 2013, 7:24pm Anchor

There aren't any logs, in fact, there isn't a folder called "logs" in /.ZombieGrinder/install.public/. The folder is just empty.
When I run it from the Terminal, the process is run, but nothing appears, then after several seconds, i get the "~$" where I enter a command.

Oh, and when I now run it from desura, a window seems to appear, but it closes right away.

Edited by: shifattk

May 1 2013, 8:12am Anchor

What's about launching /folder/where/is/desura/common/zombie-grinder/ZombieGrinder from the console?

Reply to Thread
click to sign in and post

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.