Post news RSS Patch 1.851 Development Update IV

Hello everyone, we're back again with another update for ROTR development. First of all, I would like to let all of you know that there is a new test build available for early testing in the public beta testing forum here. (Remember that you need a forum account to access this) Also in this new test build, we decided to separate the GPS scrambler upgrade from the Observation Van and make it into its own distinct unit.

Posted by on

  • Hello everyone, we're back again with another update for ROTR development.
    First of all, I would like to let all of you know that there is a new test build available for early testing in the public beta testing forum here. (Remember that you need a forum account to access this)
    Also in this new test build, we decided to separate the GPS scrambler upgrade from the Observation Van and make it into its own distinct unit:


    The Scrambler Track is a mobile GPS scrambler that functions much like the old Observation Van with the GPS scrambler upgrade.
    However the Scrambler Track can also activate a jamming pulse which will not only stun enemy vehicles for a short time, but also render them unselectable for a little longer.

    As always, we would like to remind all of you out there that there will be another 1.851 test build live stream on this Sunday:


    Countdown until the stream starts

    Doomhammer will also be doing a live stream with publicly released version of 1.85 of ROTR on the same channel around this time: Countdown

    Also, in case you missed our last stream, you can check it out on our Youtube channel here.


Comments
Erick_Auron
Erick_Auron

i ,liked it

Reply Good karma Bad karma+1 vote
extonjaez
extonjaez

My Question :

How to update from 1.85beta (Apr 1, 2015) to 1.85 patch Update IV (Jun 13, 2015) ?

By an external patch, auto patched during launch of ROTR...?

Many Thanks for your help
Excellent mod!!

Reply Good karma Bad karma+2 votes
Master.Assassin
Master.Assassin

sorry as I don't have .NET framework so I can't launch the game I need help

Reply Good karma Bad karma+2 votes
!!!karmenjell
!!!karmenjell

here is latest version, download and install

Filehippo.com

although, i did not know it was essential to run Rotr?
(please someone correct my comment if it IS essential)
eitherway - it is worth the install anyway

Reply Good karma Bad karma+2 votes
Master.Assassin
Master.Assassin

thanks man

Reply Good karma Bad karma+1 vote
Thirsty_Hirsty
Thirsty_Hirsty

Awesome, keep it up :)

Reply Good karma Bad karma+1 vote
Anxozt
Anxozt

Why i need to MUST HAVE 1.85 PATCH TO PLAY MP WITH FRIEND ?
IS IT NESSESARY ?
When we both have 1.85

Reply Good karma Bad karma+1 vote
Post a comment
Sign in or join with:

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.