The Ultimate Apocalypse mod team proudly presents to the Dawn of War: Soulstorm players and fans, an eagerly awaited and packed with epic content game experience, the Ultimate Apocalypse mod! Imagine a mod featuring massive Warhammer 40,000 battles where all 9 races in Soulstorm (and more!) have a chance at epic victory. A mod where there's no shortage of all new units, buildings, abilities, and even titans! A mod where there's nearly no limits holding you back. It's all about all out, massive war. Wanna nuke your enemies? You can. Gloriously epic titan duels are your thing? Ultimate Apocalypse has you covered. Not only that, but Ultimate Apocalypse is continuously tested to ensure the epic battle experience it delivers remains unique while being completely awesome. Thanks to you (yes, you!) and everyone playing, Ultimate Apocalypse has been steady within the top 20 ranked mods for years.

Forum Thread
  Posts  
Technical Issues (Games : Dawn of War : Mods : Ultimate Apocalypse Mod (DOW SS) : Forum : Feedback : Technical Issues) Post Reply
Thread Options 1 2 3 4 5 6 7 8 ... 34
Jan 4 2013 Anchor

If you have any questions like "How does this work?", "Why do I get this and this error message?" etc, you can post them here and we'll try our best to answer them.
Before you post anything, we would like to ask you to read our Frequently Asked Questions (FAQ) first before posting any questions here.
If the FAQ does not answer your question, feel free to post it here.

Jan 6 2013 Anchor

Um..sorry for bad English. When i try to play multiplayer with my friend (we use hamachi) when game starting,he loose instantly.Um, i mean you start game and when map is booted appeared post that he loose (sorry for very bad English =( ) .We try Ultimate Apocalypse withut new races.

Maybe it's not working with hamachi or something ?

Jan 9 2013 Anchor

Hello, I have a sugest, the "Thunderhawk" can transport "Rhino", "Predator"; but can't transport "razorback".
Thanks.

Jan 9 2013 Anchor

@kyon1234: Please read the Frequently Asked Questions threads regarding the issues about multiplayer issues. ;)

@jackal: We will not let the use of other transports to be transported by a transport. It is an easy steamroll sending hundreds of units in one location by a Thunderhawk, not real time loadout size. At this time, Predators are garrisonable in a Thunderhawk. :3 Takes up two spaces. Thank you.

Jan 19 2013 Anchor

I wasn't sure where to post this, but Soulstorm would always crash on me during multiplayer matches that include more than two players (when playing mods). I saw a suggestion for a program called CFF Explorer and how to "alleviate" this problem. I tried it, now Soulstorm has an "Error Code 51" whenever I try to start it. Anyone had this problem and found a solution?

Jan 22 2013 Anchor

You replied in the right place, sir! ;)

However, unfortunately, I do not have the answer to your question. But it is jotted down here for a reminder!

Feb 1 2013 Anchor

I have the following problem: i play through hamachi, via direct connection (because in lan no one can see the match hosted) with two friends; the game is the same because i gave it to them personally. If i play with only one of my friends, everything is fine. But if we want to play all together (we are three), the game freeze at the "transferring badges and symbols" screen, just before starting to load the scenario. Any suggestion? This doesn't happen with standard soulstorm, but only with ultimate apocalypse.

Another bug (i guess): in multiplayer games, the warning about a super structure or critical threat spotted doesn't show up, nor the voice that announces it.

Moreover, should necron have the Triolith? It isn't in the game :\

Mar 24 2013 Anchor

Hey there, I have just recently encountered a problem when I try to play multiplayer with my friends. Before, it all worked just fine, but now, whenever we go to play, if I join I instantly get kicked and get the message: "Data Sync Error: Game does not match" But if I host the game, my friends get kicked and get that error. My friends and I use Tunngle and we all have the exact same versions of everything. Same mods, same SS version and have been able to play before. Please help D:

Mar 24 2013 Anchor

It ALL THE SUDDEN stopped you from playing multiplayer?

Multiplayer online is very sensitive in DOW Games. You need:
- Same maps
- No modded or added content than your friends
- Same mod versions, including EVERYTHING: Inquisition, Daemons mod 0.96, UA mod 1.71, Tyranids mod 0.52b, Objective Points mod (from UA mod).

If you claim that each of you have the exact same thing, then there is simply nothing nobody can do but guess. This is the standard DOW engine issues, it mostly sounds like you did something like extract or add content to something or updated vice versa? I dunno. There is hardly anything anybody can do. :|

Mar 24 2013 Anchor

If you get a data sync error something is not perfectly sync'd, as in something changed (apparently on your end) recently. Something that tends to cause trouble is the Objective points mod. Try using the version that's bundled with the Grand Release (I've uploaded separately so you don't have to extrat the GR files just for that) Mega.co.nz
To make sure the are no files getting mixed, replace (not merge) the Objective Points folder and .module with the ones from the download I've linked above.

If you want to be certain to fix this, it's safe to have all your friends move to this version of objective points as well. If this doesn't fix your sync problem, then it must be something else causing the mismatch. I'm afraid that in that case you'll have to track it down.
Prime suspects are the required mods, mostly the Tyranids and Daemons mods (as there's only one public release of Inquisition Daemonhunters).

About the weird problem XsauroxPlayer has, honestly I have no idea, I've never encountered anything like that. Sounds like the kind of issue that should be fixed by reinstalling Soulstorm though.
You don't need to reinstall all your mods, you can back all their folders and .modules to restore them later. If you're having weird issues with UA however and you've installed the Grand release from the .exe installer, I strongly advice you reinstall it from the multi-part .7z file, as the installer apparently has a small incidence of data corruption when extracting the files.
There's a detailed tutorial on how to install with the multi-part 7z here.

P.S.: It's multi part for everyone's convenience (plus Mediafire's 200Mb upload limit), you really want to download over 600 megabytes in one go? What if your internet goes trolly for a second during that? ;P

Edited by: Excogitatoris-Logica

--

How to improve performance on DoW: Soulstorm
if TV and Beer == nil then
rgd.GameData.crazy = true
rgd:save() end

Mar 26 2013 Anchor

Lord_Doofus wrote:

We will not let the use of other transports to be transported by a transport


i loled xD it's like a yo dawg i know you like transports so we put a transport in your transport so you can transport while transporting!!

Apr 20 2013 Anchor

hi.I cant use chaos demons and demon hunters,only a opp[onents.When i try to use them,i get and black screen with same error fatal message,and i have to exit game.Tyranids work.I tried demons in their mod,theyn dontwork there either.i installed mod versions shown here.Aid me!Everything else works.

Apr 21 2013 Anchor

That's certainly odd.

So, to recap on your message:
- Daemon Hunters and Chaos Daemons only work when played by the AI in UA, and playing as them results in a Fatal Scar Error.
- Attempts to play as them in their respective mods were unsuccessful.

I need more info, so I'll ask you some questions:
- Can you open the DoW game console? The console shortcut is Ctrl + Shift + ~ (the key right below Esc). If so, get to that Fatal Scar Error, open the console, take a screenshot and upload it so the UA mod team can see what is causing your problem.
- About the Daemon Hunters and Chaos Daemons mods: At what point do you get an error on their respective mods? For example: Right when launching the mod (game failed to launch error), when starting a skirmish (a Fatal Scar Error), or when?

For now, you can try reinstalling:
UA 1.71 patch: Mega.co.nz Mediafire mirror Mediafire.com
Chaos Daemons mod version 0.96: Mega.co.nz Mediafire mirror Mediafire.com
Objective Points mod: Mega.co.nz

Let me know if reinstalling these fixes it :)

--

How to improve performance on DoW: Soulstorm
if TV and Beer == nil then
rgd.GameData.crazy = true
rgd:save() end

Apr 24 2013 Anchor

I get a Sync error in multiplayer every time I use Tyranids.
The sync error ONLY happens if somebody uses Tyranids.

Edited by: faram45

Apr 27 2013 Anchor

Same problem here, Sync error only when me or my friend have Tyranids.

Hope it will be possible to fix it :s.

Apr 28 2013 Anchor

Everytime I play a Arena gamemode in campaign, it freezes and gives me the message "fatal scar error, execution paused". How do I fix this.

Apr 28 2013 Anchor

Interesting, I get the exact same error too.

In the case of a Fatal Scar error, you take a console screenshot and upload it, like this.
Instructions on displaying the DoW console here.

--

How to improve performance on DoW: Soulstorm
if TV and Beer == nil then
rgd.GameData.crazy = true
rgd:save() end

Apr 30 2013 Anchor

Wanted to report that I encounter the same error as faram45.

Anytime someone uses Tyranids during multiplayer the game will encounter a sync error upon start.
No other changes have been made to either installation except the 1.72 update.

Has anyone gotten a multiplayer game to work with the Tyranids?

Apr 30 2013 Anchor

Someone wrote: Anytime someone uses Tyranids during multiplayer the game will encounter a sync error upon start.

Someone wrote: Same problem here, Sync error only when me or my friend have Tyranids.

Someone wrote: I get a Sync error in multiplayer every time I use Tyranids.
The sync error ONLY happens if somebody uses Tyranids.

Uhhh.... uhhhh....

Changelog wrote: ------------------------

Tyranids:
------------------------
* Tyranid Bio Plasma impact FX was redone and no longer annoying.
* Tyranid reinforce FX was updated to the Tyranid mod's 0.52b FX.
* New Superweapon added: Bio Bomb
* New Superweapon added: Spawn the Hive Fleet
* Tyranids now provide power to allied team members including
themselves, which fixes an important bug in team matches. Tyranids still
don't use power, ignore they have power.
* Tyranids AI has been entirely improved now.
* All structures that decrease in cost no longer applies this effect,
hence the "unbeatable" bug has been removed and structures do not give.
you extra requisition in the negatives.
* HQ building now replaces the Hive Fleet that was the main HQ "building" in version 1.71.
* Hive Fleet is a structure, that can be spawned via a superweapon by the Capillary Tower.
* Hive Fleet structure decays in health like normal, with fx
improvement, and can deepstrike squads into the front lines, including
Carnifexes.
* Hive Fleet improvements, consume planet (units), bigger FX, feed to keep alive. No longer HQ.
* Hive Mind (Tyranids Builder unit) attributes were updated and glitched FX was removed.
* Meteor Swarm ability was removed from both the Capillary Towers and Hive Fleet.
* The Hive Fleet ucs description and ability ucs description is now entirely fixed.
* The Hive Fleet no longer produces all of the researches, instead, a new tech system was implemented in game.
* Tier researching removed for tier I and II, HQ addons are back!
* Tier IV research was renamed to "Planetary Assimilation (Tier 4)".
* Reclamation Pools contains all Tyranid research.
* Reclamation Pools increase in cost the more you build.
* Ripper Swarms were moved to the "Gauntii Brood Hive."
* Gaunt researches now increases the maximum number of Gaunts in a squad.
* Genestealer researches were removed from the Broodlord and are now a global research.
* Genestealers are now visually be equipped with Scythes.
* Brood Lord's Acclimatization researches now increases the maximum number of Genestealers in a squad.
* Brood Lord can now reinforce with 19 Genestealers instead of 9.
* Genestealer Retinue reinforce time decreased from 7 seconds to 2 seconds.
* Hive Tyrant research speed increase was heavily reduced.
* Hive Tyrant is no longer affected by the Broodlord's researches.
* Hive Tyrant Catalyst ability recharge time increased, and duration decreased.
* Hive Tyrant melee charge was removed.
* Hive Tyrant melee damage versus commanders decreased.
* Hive Tyrant morale and health decreased.
* Hive Tyrant armor type on hit changed from heavy metal to flesh.
* Hive Tyrant's Venom Cannon weapon reload time versus damage reworked.
* Hive Mind keen sight radius and sight radius was reduced to 1m radius.
* Hive Mind distance above ground is no longer visible.
* Hive Mind cheat removed from game.
* Hierophant Bio Acid artillery weapons were redone, aims faster, and the maximum range is now 50m from 35m.
* Biovore Bioacid requisition cost is now 80.
* Biovore damage output decreased.
* Spinegaunt and Termagaunt costs increased.
* Spinegaunt and Without Number squad Squad Cap = 2.
* Gargoyles squad maximum loadout increased.
* Gargoyles now cost 2 squad cap.
* Gargoyle tooltip was added.
* Gargoyle jump no longer jumps Gargoyles across the map in 3 seconds.
* The cost of the Capillary Tower increased.
* The Capillary Tower increases squad and support cap by 5.
* Every Reclamation Pool built decreases the cost of the Capillary Tower by 50 requisition.
* Tyranids restrict tier wincondition has been fixed.
* Khazi Carnifex Devour weapon damages versus vehicles decreased.
* Raveners health increased.
* Raveners can now burrow underground.
* Raveners "deathspitter" was renamed to "bio plasma", icon and ucs description was changed.
* Raveners burrow (jump) charge cost increased.
* Raveners beep sound when morale is lost was fixed.
* Raveners and Warrior melee claws now pierces vehicle and structure armor.
* Warriors and Carnifex Bio Plasma was changed to a Ravener type Bio Plasma.
* Warriors squad cap now is 2.
* Lictors can now reinforce in squads. Minimum/maximum loadout is 2/4.
* Lictor health and movement speed increased.
* "Accumulation" wargear was renamed to "Acclimatization".
* Acclimatization wargear III no longer requires Hive Tyrant's wargear.
* Bio Acid projectile speed and other bugs was fixed.
* All Bio Acid and Bio Plasma impact radiuses decreased from 10m to 7m.
* Turrets now attacks aircraft.
* Turrets now requires either the Gaunt or Warrior Hive.
* Turrets were extremely nerfed.
* Spore Chimneys now have a voice over.
* Synapse aura abilities squad morale maximum modifier decreased by half.


Maybe problem related in there?

Apr 30 2013 Anchor
May 3 2013 Anchor

Um? At the sync error? Or they don't give your allies power? They should... every HQ gives power.

May 5 2013 Anchor

First off, I have read both the FAQ, and the Install guide.

Done this:
"- To fix your Kaurava Campaign without crashing to desktop everytime you complete a stronghold mission, you must please export the movies from:Engine/Movies, to: UA Mod Campaign/Movies, simple as that. "

Despite following this to the letter, and even after I've tried some creative placing of the files in other parts of the folder, nothing seems to work. I still get a crash to desktop after defeating a stronghold mission on the Campaign 100% of the time.

Since I'm using Steam, these are my folders:

C:\Program Files (x86)\Steam\steamapps\common\Dawn of War Soulstorm\Engine\Movies
To
C:\Program Files (x86)\Steam\steamapps\common\Dawn of War Soulstorm\UltimateApocalypse_Campaign\Movies

Has this bug changed with 1.72.5? Or is this solution now known to not actually work? Or have I been doing something wrong?

Besides this little hiccup, great job guys!

Oh, and I also tried the whole "Save and Reload," trick as well, to no avail.

May 5 2013 Anchor

Someone wrote: Oh, and I also tried the whole "Save and Reload," trick as well, to no avail.

That statement I'm going bonkers on right now, though. It worked for everybody but you so far, who has replied to such an event.

But yeah the movies thing works for some people, not for others... I don't know why, but all of this crash crap will be fully attended in 1.73. :)

There is nothing for you to do then but wait for the moderators to spread a fixable word, or you got unlucky somehow and you can get passed the stronghold by trying one more time? The save game thing is a guaranteed thing as I tried it myself last year and it worked.

May 6 2013 Anchor

Alright then perhaps you can walk me through Exactly what to do with the save game thing:)

I've saved it a few seconds before the map ends.

I've then tried reloading it from the actual battle, but it still crashes upon completion.
I've also tried quitting to desktop, restarting the game, then loading it up once more, but it still crashes when the battle completes.
I tried quitting to the main menu from the battle, however it crashes before the main menu can load, so it won't let me do that either.

It appears to crash as soon as the planets show up once the end mission movie is complete, or when trying to quit the battle to return to the Campaign Map.

Help me Obi Wan, you're my only hope:)
I guess I'll just have to wait for 1.73 unless the gremlins decide to give up and let me play in peace.

I figured it out! Took a while though!

It seems that as soon as I complete the mission, I have to mash the Esc key as fast as I can in order to skip the end scenario movie as fast as possible, then when the post mission script appears I have to quickly press continue, before the narrator's voice kicks in. When the Wargear screen comes up, I also have to immediately press continue without making ANY selections.

It seems that only after screaming through all the end mission screens without viewing them or making any selections what so ever does the game load back to the main Campaign screen. I then manually go into the Commander's screen to choose my latest Wargear.

That took way too long:) I now know exactly how many seconds my game takes to load, and on what word of the introduction speech to the Ork Stronghold mission my computer loads the map:)

May 6 2013 Anchor

OR, try running Soulstorm in compatibility mode for Windows 98.
Yeah, I know it sounds crazy, but I read it can help prevent crashes on the Kaurava campaign strongholds. It also apparently increases loading speeds (confirmed this on the three battles I played yesterday), specifically that time right after you click something on a menu/finish a battle and Soulstorm "spaces out" :S
Still gotta "scientifically" confirm this though. I'm about to fight the sisters stronghold, and will save right before defeating it on numerous different conditions (compatibility modes, with and without movies copied, etc). Hopefully I'll get to some accurate results.

Edit: So, I have tested many compatibility settings on the Kaurava campaign, and I've come to the following conclusions:
(These results may not be accurate due to my system, as I couldn't get the Sisters stronghold to crash regardless of settings used)
First and most important: For Windows 7 users, it is extremely convenient to set the Compatibility mode on the Soulstorm executable to Windows XP SP3. By doing so Soulstorm actually loads faster and has far greater stability (doesn't freeze when alt-tabbing).
There's a good chance this could also prevent crashes on Stronghold missions, but as I didn't get a confirmed crash to begin with I can't ensure this.

Edited by: Excogitatoris-Logica

--

How to improve performance on DoW: Soulstorm
if TV and Beer == nil then
rgd.GameData.crazy = true
rgd:save() end

Reply to thread
click to sign in and post

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.