Same mod, different name, The Galactic Empire, the Rebel Alliance, the Black Sun Pirates, and the Droid Empire, fight for control of the galaxy.

Forum Thread
Bugs (Games : Star Wars: Empire at War: Forces of Corruption : Mods : Super Star Wars: Rise of the Droid Empire : Forum : Bugs for Super Star Wars : Bugs) Locked
Thread Options 1 2 3
Dec 16 2012 Anchor

I've never really tried the Forums thing here on moddb, so I'm not sure if doing this right.

Okay to the point, if find any bugs for Super Star Wars, this is where you post them.

Dec 17 2012 Anchor

I was wondering what to do with the download. It's in .7z format, not .rar.

Dec 17 2012 Anchor

Download this

It's the 7zip program.

Dec 17 2012 Anchor

ok this is not really a bug, but more a idea. the cost of the super star destroyers is 18000. that is a little cheap it think. i have played against the computer on medium with the Galactic Empire and i won within a hour. only because i have 5 super star destroyers. so maybe it is better if you change the cost for a super star destroyer to 205000, and the cost of the eclipse 408000. and the build time is very short, about 1 minute or shorter. maybe you can change the build time to 10 minute for a super star destroyer. and the build time for the eclipse to 16 minute.

like this. i have change a few thing with the cost.

and maybe you can change the cool-down of the eclipse-super laser? because now i can fire every 10 seconds... maybe to 2 minutes?

Edited by: remcovana

Dec 17 2012 Anchor

it sometime crashes, oh and after i successfully captured trandosha in a raiding party, when i sent my space forces, it got stuck on the loading screen :(

Dec 21 2012 Anchor

can some one help me install thi correctly when i installed there were a lot of major bugs

Dec 22 2012 Anchor

Anyone one having trouble with getting Trandosha to work here's how it can be fixed. Go to the mod folder for (SSW), then to data folder, then ART, then MAPS, at the very bottom or end, you'll see Trandoshaspace.ted. Rename it to Space_Planet_Trandosha.

Dec 22 2012 Anchor

i have a huge bug i like to report i dont know if poeple are having the same problems as me so im going to post some pictures of this bug im having when i get the chance

Dec 22 2012 Anchor

Admiral Ace i seem to have a problem with this mod.It looks great but i have an Vista and all the symbols and such are messed up so i was wondering how to fix that.Thank you for your time Admiral Ace.

Edited by: Lord-Vader

Dec 23 2012 Anchor

The Lucrehulk has no Population Value and Droid Empire Starbases Level 3 cannot be build. I would be glad if that could be fixed.

Dec 23 2012 Anchor

It's fairly easy to fix the Lucrehulk population value. Provided that the files that the mod are in do not have a read only attribute, all you need is notepad.

Dec 30 2012 Anchor


I think I found a bug in the Rebel Alliance infantry line. All the alien (non human, so the wookie warriors, twileks, mon calamaris and the pirate looking rebel infantry soldiers - who cannot enter bunkers) rebel soldiers in the mixed platoons seems unarmed (they never shoot just stand and die). The separate wookie warriors (who come with the wookie war party) use their blaster rifle, but those guys placed in the rebel infantry platoons are not.

Jan 2 2013 Anchor

Would you consider doing a Mt commandbar update?
The icons don't work for the menus and the ingame play.

Jan 3 2013 Anchor

For people still having problems with icons, If the icons are messed up it means you installed the mod wrong. Messed up icons usually means the Mt_commandbar.tga was deleted. If you still have the original SSW download extract the file Mt_commandbar.tga from the textures folder and add it to the mod's textures folder.

The Twi'lek, Bothan, and Mon Cal Trooper will not fire because they do not have a fire bone. I CANNOT give them a fire bone, unless I can re-rig them in a model program. I released the mod anyways, because I thought I had found a fix for the problem, but I guess not.

Jan 4 2013 Anchor

Thank you for your answer.
Maybe you can simply change the bothan_trooper to bothan_spy and the wookie_trooper to wookie_warrior in the rebel squads and platoons. This is not an elegant solution but it works.
While I really like the view of several species beyond humans in the rebel squads, I think the bothans and the wookies enough addition to those units and no need for the other three if they do nothing. Or simply replace them by basic rebel troopers and plex soldiers (I really love to watch a mixed weapon unit in those rebels which compose wookies, bothans, rebels riflemen and plex soldiers).

Jan 5 2013 Anchor

Just wanted to post here that I have developed a fix for those who cannot build Droid space stations levels 3, 4, and 5.

1. Go to \LucasArts\Star Wars Empire at War Forces of Corruption\Mods\SSW\Data\XML (what comes before \LucasArts\ will be different depending on where you installed the game and what OS you use), and open the file called STARBASES_UNDERWORLD with a text editor (E.g. notepad).
2. In STARBASES_UNDERWORLD, scroll down until you see this line: StarBase Name="Underworld_Star_Base_3" .
3. From there scroll down further until you see this line: Build_Initially_Locked No Build_Initially_Locked.
4. Replace no with yes, and repeat steps 2 through 4; difference being in step 2, look for lines StarBase Name="Underworld_Star_Base_4" and StarBase Name="Underworld_Star_Base_5" instead.

Edited by: GrandAdmiralUehara

Jan 12 2013 Anchor

I'm still having trouble with the icons, the mod is installed correctly, folder in the mods folder, the bat file in the main game folder, icon on the desktop but still no ingame icons.

Before i had been using the SMG launcher which works for 99 percent of the mods i've tried. same result no icons.

Right now i can play Vader's new order, the legacy mod, Absolute corruption, but not yours, so it's got to be a problem with the mtcommandbar.

Feb 13 2013 Anchor

i can play it with mine smg launcher no problems and admmiral ace do you intend to do another mod at all or just patch this one up this is best mod out for a while now and i love it except if you can put more rebels star ships at the start pls

Feb 22 2013 Anchor

I'm playing galactic conquest as the Droids, every time the Rebel Alliance takes Mandalore the game crashes.
Any suggestions? Would appreciate the help :)

Feb 22 2013 Anchor

No idea, I've taken control of Mandalore myself and had no problems. So I don't know what causes it for the AI.

Feb 22 2013 Anchor

Ye, I sent a couple raiding parties there to try capture it before the rebels could and there was no problem. Oh well, so long as I can hold the planet it doesn't really matter :P Thanks anyway for replying :)

Mar 17 2013 Anchor

I'm havinf a strange problem, at the begining of my Empire Campaign, everything was normal, but then, suddenly, in space battle i have 2 Darth Vader Executor, and in land battles 2 Darth Vader; any reason for this? Any suggestions to fix this?

Mar 17 2013 Anchor

Don't know what causes that, I've never seen it. Which Galactic Conquest is it?

Mar 21 2013 Anchor

I've been having a couple issues. 1) When I play Skirmish mode in space as the Droid Empire, I can't build any defense satellites (e.g. laser and missile defense satellites, ship repair satellites, etc., or whatever they would be as the Droid Empire faction). I can "take over," so to speak, the satellites to get them ready for building, but I can't bring up the options to build any of them. 2) I've noticed, at least while playing as the Rebel Alliance (again in Skirmish mode and in space), that as I increase my space station level, some ship-building options disappear from the reinforcement menu. For example, I could start a skirmish with the option to build X-Wings, but by the time my space station level reaches 5, the X-Wing option is no longer an available reinforcement to build. This happens similarly with the Hero unit Salvation (at least that's the one that I noticed; it may happen to a few other Hero units, as well). Once my space station level is sufficient, I can build it, but again, by the time I reach level 5, it disappears from the reinforcement menu. I'm just wondering whether anyone else is having this same problem, or I just did something wrong myself during the installation process and if there's a fix for it. Thanks.

Apr 12 2013 Anchor

the new republic seems to have the consortium space satellites in space skirmish mode as well as there own.

in galactic conquest the new republic infantry platoon. the small one. is all in single units (idk if this was intended or not) and the wookies and pirates cannot attack

When playing skirmish as the empire when i buy a munificent star frigate from the hutt asteroid base and bring it in to the battle it causes an exception error. also when i grab it from the reinforcement pile there's no model that appears.

in galactic conquest the empire can build ships from there space station during a space battle like in skirmish. these ships use credits and disappear after they are built. in addition the empire's ISD class 1's and dominator cruisers have no pop value.
on Despayre the empire's level 5 space station only puts out fighters and bombers.

in skirmish as any faction several of your units, heros, and upgrades disapear as your space station levels up such as the snow speeder starfighter. also there are upgrades and heros available on your main space station not just the research station.

this is a balance issue
in galactic conquest the empire is completely overpowered. mostly do to there ssd's. i suggest making sdd's population 35-40 and not have them spawn in other capital class and/or destroyer class ships. plus make them ludicrously expensive in gc mode.
the droids carrier ships spawn way to many fighters. i'd take at least a 1/3 out to make things less laggy and balanced.
the killer ewoks are overpowered. but fun.

a planet and unit guide would be quite helpful.

if i find more i'll add them.

Edited by: Darth_Weasel

Reply to thread
click to sign in and post

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.