Adds Starcraft 2 Units, graphics, stats campaign and abilities to Starcraft broodwar Created By Seiji Asuru..............

Add file Report Starcraft 2 Mod 5.27.3
Filename
SC2_5.27.3.zip
Category
Full Version
Uploader
Templarfreak
Added
Size
38.43mb (40,297,767 bytes)
Downloads
13,638 (2 today)
MD5 Hash
b3a504ba0b0e6993e62629af0e18a1e4
Embed Button
Embed Widget
Description

Biggest Changes are a new system in which larva mutate, baneling is now buildable again, and a new system for the reactor in wich you click on a button for the reactor and it will change the button set to where you can train units this is MUCH closer to replicating the double production ability of sc2 P.S. This is the same version of before i had to re-upload it because i changed the name.

Preview
Starcraft 2 Mod 5.27.3
Comments  (0 - 50 of 74)
Templarfreak Author
Templarfreak

Full list of changes:

New Larva System.
Banelings are buildable again.

New reactor system to build units.
Thor is buit at scv again but in advanced buildings tab.

obolisk trains zealot, stalker, and immortal.
(WORK IN PROGRESS) The Phase Prism has a new tab to train units but it doesnt work yet...

and i think thats about it but there could be a few more.

BUGS:

Overlord cannot morph into overseer for some reason.
when a larva finishes morphing the unit gotten will still have the larva command card in it. but when you double click on the unit it will go to its original command card.

For the reactor some of the units cannot be built.

Phase Prism cannot make units yet...

Reply Good karma+1 vote
MPSGA
MPSGA

I can't download it, it says "Not Found"

Reply Good karma Bad karma+1 vote
MPSGA
MPSGA

OK I think I can now got it!

Reply Good karma Bad karma+1 vote
tp1298
tp1298

sweet.! is there any unit sounds.? new unit masks.? when will next update be in.?

Reply Good karma Bad karma+1 vote
TheDoctor42
TheDoctor42

Heh... you'll probably finish this up before Blizzard does.

Reply Good karma Bad karma+2 votes
no-tan-lord-protos
no-tan-lord-protos

el juego sirve?pues lo acabo de descargar y no podia aser addons....(noten que tenia el v1.15.1) si me pudieran responder se los agradeceria mucho....
salu2!!!!!

Reply Good karma Bad karma+1 vote
tp1298
tp1298

na dude. its 1.15.0

Reply Good karma Bad karma+2 votes
lol1234
lol1234

noo.... its 1.15.1 :D

Reply Good karma Bad karma+1 vote
Immortality
Immortality

LOLOLOL

Reply Good karma Bad karma+1 vote
MPSGA
MPSGA

Hey - You can insert thayt to StarEdit doing so:
Open MPGDraft(download it somewhere)
(1.1)Load MPQ Patch
(1.2)Click on Campaign Editor
(1.3)Next
(1.4)Browse for MPQ-s...; All Files; and add SC2 Mod
(1.5)Next
(1.6)Finish
(2.0)CREATE STAREDIT PATCH FROM SC2 MOD
(2.1)Create Self-Executing MPQ
(2.2)Add Custom Name; The EXE of SC2Mod(All Files); OutPut file
(2.3)Select Campaign Editor
(2.4)Next
(2.5)Finish
(2.6)Run It!

Reply Good karma Bad karma+1 vote
MPSGA
MPSGA

I have a problem(or a bug): I can't use "Attack" command(on the menu of units)! I could do it with Carrier but not with any other unit! I can press on enemyes and they attack them, but when I use attack command on my own units/buildings, they don't do anything...

Reply Good karma Bad karma+1 vote
Templarfreak Author
Templarfreak

yes ive been having that same problem and i cannot deduce it its very strange... and a MUCH EASIER WAY TO DO IT is to simply open the mod luancher and select the campaign editor exe instead of the starcraft exe

Reply Good karma+1 vote
Stuart98
Stuart98

Mod launcher? You post starcraft.exe files, not mod launchers. If you have a mod launcher, give us the download link.

Reply Good karma Bad karma+1 vote
Templarfreak Author
Templarfreak

thats what it is when u open the exe it opens a window then u either select the sc exe or the campaign editor exe

Reply Good karma+1 vote
dermeister2
dermeister2

why when i download this i cant tech up with terran? i cant build tech lab for barracks i cant build STALKER i cant tech up the factory ???? PLZ HELP ME!!!!

Reply Good karma Bad karma+1 vote
Stuart98
Stuart98

Wait its no longer 1.15.1? Why?

Reply Good karma Bad karma+1 vote
S.T.A.R.S-Raven
S.T.A.R.S-Raven

Im running into problems with the Siege tank and getting some of the units to build. I cant build a siege tank because it says it still needs the attachment to it.

Reply Good karma Bad karma+1 vote
Fireoblade
Fireoblade

HELP its not showing anything new

Reply Good karma Bad karma+1 vote
Stuart98
Stuart98

I see that re uploading preserved the comments. Excellent.

Reply Good karma Bad karma+1 vote
lol1234
lol1234

I've been trying to open the Zip file and it would NOT open i would appreciate an alternate download, i am trying again to see if unzipping previous versions helps, if this version doesn't work Aple could you try to get me an open-able version?

Reply Good karma Bad karma+1 vote
lol1234
lol1234

ok i have gotten it to work FINALLY after about 7 downloads of the same zip file (from this site) i finally got it to open :D PARTY

Reply Good karma Bad karma+1 vote
lol1234
lol1234

now i have a problem, i have SCD3(it comes with ALL of the patches so it is pretty much a patcher too) and i have downgraded to 1.15 (QUOTE:
na dude. its 1.15.0)what patch version is required D: cause sunkens don't have an attack option -_-

Reply Good karma Bad karma+1 vote
Templarfreak Author
Templarfreak

that! is normal seiji forgot to add the attack command to the sunken colony before release i believe but when a unit will come on by it will still attack

Reply Good karma+1 vote
lol1234
lol1234

kk thanks man

Reply Good karma Bad karma+1 vote
lol1234
lol1234

you know that the sprite for the sunken is mismatched? it is the lurker thingy ^_^ i actually looked in the campaign editor :D have fun aple (contact seiji and find out why the hell ts taking so long for a new version >_>)

Reply Good karma Bad karma+1 vote
lol1234
lol1234

i found a pretty serious bug D: whenever i try THIS version on BGH using darkai it freezes when the guardians acid thingy hits a hydralisk -_- it comepletely FREEZES my game and i have to terminate teh process >_>

Reply Good karma Bad karma+1 vote
lol1234
lol1234

i have a question ^_^ which version is most like SC2? cause i've tried blind93's version and TBF's version (both are focused on a different race) and i just wanted to know so dont be a hater cause i cant tell with my limited knowledge of SC2

Reply Good karma Bad karma+1 vote
Templarfreak Author
Templarfreak

actually ive tried blind93's version (never heard of tbf) and i quite like it! but i still think seijis has the most progress if you ask me just a few more things with it and seiji will be done! anyways i will not give you a straight answer or else i could be lashed... :o

Reply Good karma+1 vote
lol1234
lol1234

who would lash you? :O SEIJI IS A TASKMASTER?

Reply Good karma Bad karma+1 vote
zootycoon
zootycoon

hey um where do you get stalkers? cause i cant find it.

Reply Good karma Bad karma+1 vote
lol1234
lol1234

im not sure you can build stalkers in this version, will be back if you can ^_^

Reply Good karma Bad karma+1 vote
lol1234
lol1234

no stalker in this version D: but it does crash alot -_- probably from the mutalisks AKA corruptors lol o-well and BTW TBF is thebigfenix :D he, seiji, and blind93 are all competing for the best SC2 mod ^_^ all on the same website too :o Sc2-esp.com :D

Reply Good karma Bad karma+1 vote
Sleipher
Sleipher

i can build stalkers in this mod does that make me weird? :S (although its a replacement for kerrigan so it sounds like kerrigan :(

Reply Good karma Bad karma+1 vote
lol1234
lol1234

yeah :P i found out that the reason i couldn't make stalkers was incorrect patch version XD

Reply Good karma Bad karma+1 vote
maandy2
maandy2

That's awesome!The Best mod that i've ever played!The only problem is the attack.....But that's Ok!
Buy the way,who's Big fenix and blin93?Where can i find their mod?sorry for my spanish....I can' find the way to find the mod~~~~

Reply Good karma Bad karma+1 vote
lol1234
lol1234

they are modders competing with seiji_asuru (night_asuru in english) and really blind95 is trying to fuse the 2 together to create -drumroll- MODFUSION XD thats seriously what its called XD

Reply Good karma Bad karma+1 vote
Sleipher
Sleipher

Awesome mod (once i got it working xD had the wrong patch version:P) can hardley wait for the next version ^^ oh and btw only one little complaint: after a few larva mutations my larva stoped spawning for some reason hope it aint a big bugg (i actualy sat staring at my hive for 10 minutes and no larva spawned :'(

Reply Good karma Bad karma+1 vote
gazi05
gazi05

vich version of the game must be to play the mod normaly??

Reply Good karma Bad karma+1 vote
Stuart98
Stuart98

1.15.1 .

Reply Good karma Bad karma+1 vote
gazi05
gazi05

thanks but i used the 1.15.1 version and i couldn't build battlecruisers with terran, or siege tanks becouse it can't attach buildings as upgrades, such as anti-matter core...help please

Reply Good karma Bad karma+1 vote
robocup30
robocup30

Use 1.15.0

Reply Good karma Bad karma+1 vote
gazi05
gazi05

thanks :D

Reply Good karma Bad karma+1 vote
rotcanhoc
rotcanhoc

How do you install starcraft mod?
Which folder do you put it in?

Reply Good karma Bad karma+1 vote
gazi05
gazi05

just put it in your starcraft folder and launch the .exe file

Reply Good karma Bad karma+1 vote
rotcanhoc
rotcanhoc

it says" 404 not found."

Reply Good karma Bad karma+1 vote
lol1234
lol1234

aple i mean it when i say this, i will attack you if you dont convert this for 1.15.1 :D just a REMINDER xD if u dont i will attack u wit spam (i dont know how to without getting banned somehow) and then convert it mahself with my firegraft version :)

Reply Good karma Bad karma+1 vote
lol1234
lol1234

o and btw the latest version of firegraft is 0.93 :) that one is 1.15.1 compatible :D

Reply Good karma Bad karma+1 vote
lol1234
lol1234

i fail :( i ended up BREAKING the mod XD well... i fail :) especially at coding **** like this XD :O GL and HF aple :D

Reply Good karma Bad karma+1 vote
lol1234
lol1234

i think i fixed it :) i forgot to include a save of ur .exe into mine :O and it ended up reversing the entire mod completely D: well... i will get back to u when i find out if it worked or not >:)

Reply Good karma Bad karma+1 vote
lol1234
lol1234

got it to work for 1.15.1 :D ok now i need aples opinion.... should i upload the conversion (all credits to you (except 1 to me for converting it))

Reply Good karma Bad karma+1 vote
Templarfreak Author
Templarfreak

well i dont really care just as long as u clearly state that it is for 1.15.1 now mkaay?

Reply Good karma+1 vote
Post a comment
Sign in or join with:

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.

Follow Report Profile
Icon
StarCraft
Game
StarCraft
Creator
seiji_asuru
Contact
Send Message
Release date
Mod watch
Follow
File
Browse
Files
New
Add file
Report
Report
Share
Related Games
StarCraft
StarCraft Real Time Strategy