Live a week in the life of "The Postal Dude"; a hapless everyman just trying to check off some chores. Buying milk, returning an overdue library book, getting Gary Coleman's autograph, what could possibly go wrong? Blast, chop and piss your way through a freakshow of American caricatures in this darkly humorous first-person adventure. Meet Krotchy: the toy mascot gone bad, visit your Uncle Dave at his besieged religious cult compound and battle sewer-dwelling Taliban when you least expect them! Endure the sphincter-clenching challenge of cannibal rednecks, corrupt cops and berserker elephants. Accompanied by Champ, the Dude's semi-loyal pitbull, battle your way through open environments populated with amazingly unpredictable AI. Utilize an arsenal of weapons ranging from a humble shovel to a uniquely hilarious rocket launcher. Collect a pack of attack dogs! Use cats as silencers! Piss and pour gasoline on anything and everyone! YOU KNOW YOU WANT TO!

Forum Thread
by member
  Posts  
Postal Crash on Startup - libGL.so.1 (Games : POSTAL 2 : Forum : Postal 2 Support : Postal Crash on Startup - libGL.so.1) Post Reply
Thread Options
Jun 29 2012, 11:44am Anchor

Hey everybody,

evertime is start Postal the terminal says: failed to load libgl.so.1
after this it shuts down.

and suggestions?

EDIT: I am using Ubuntu Precise Pangolin

thanks in advance

I solved the problem above with installing the 32-bit libraries.
But now another problems occurs. I have some sort of graphic issue.

The game starts but i see no menu, just the moving background with all this stuff.

I am using Ubuntu 64bit Precise Pangolin.

Edited by: Wazle

Jul 7 2012, 12:27am Anchor

No idea about your secondary problem, but I am having the same issue that you had with it complaining about it failing to load libgl.so.1, but I am already running it from a 32-bit Fedora 16 system. The sharware version from Desura worked fine.

EDIT: I got the problem solved by removing the libgcc_s.so.1 libary that was included with the game. You can find it in your Desura directory by going through desura/common/postal-2/postal2game/System. I just moved it to a seperate "lib" directory and now everything is dandy.

 Still hope someone can help you out though Wazle.

Edited by: hamishwilson

Jul 10 2012, 3:10am Anchor

This game is weird. In some sort of strange idea i just deleted the lib fille you mentioned, Now the game starts properly. See if there occur any other bugs.

Thank you for you hint :)

Jul 19 2012, 3:03am Anchor

There probably should not be any bugs, as it is just loading your system libary instead of it's own staticaly linked one. At least, I have not noticed any bugs related to it, and I am about to complete Thursday. This should also fix Apocalypse Weekend for you BTW. ;)

Edited by: hamishwilson

Aug 2 2012, 12:00pm Anchor

I recently bought the game and it downloaded right but whne it installs to 10% it says the MCF error and i tried all three options to try and re install it and it still says the  same things.

Aug 15 2012, 12:47pm Anchor

Thank you very much,
I had the same problem, this (remove libgcc_s.so.1) helped.

Ubuntu 12.04 64bit.

Mar 3 2013, 7:49am Anchor

I have the same problem but to delete or move the file never made the game works, I still have this message :

Failed loading libGL.so.1History: Exiting due to error

So now, I am stuck, I can't launch the game
I am on Debian Wheezy (actually testing. Squeeze is still stable) and I can't launch the game...
please help :( 

Mar 3 2013, 3:51pm Anchor

I assume other 3D games are working correctly and you have working 3D drivers installed?

It is still working fine for me on Arch Linux once I removed the library.

EDIT: Maybe try copying the libgcc_s.so.1 from /usr/lib to your Postal 2 system directory. A long shot, but worth a try.

Edited by: hamishwilson

Mar 4 2013, 6:42pm Anchor

Trine works well, I make more than 300 FPS with Minecraft.

I installed nvidia-glx from wheezy depositories

I will try for copy, I keep you in touch

thank you for helping me

EDIT : locate libgcc1
/usr/share/doc/libgcc1
/usr/share/lintian/overrides/libgcc1
/var/lib/dpkg/info/libgcc1:amd64.list
/var/lib/dpkg/info/libgcc1:amd64.md5sums
/var/lib/dpkg/info/libgcc1:amd64.postinst
/var/lib/dpkg/info/libgcc1:amd64.postrm
/var/lib/dpkg/info/libgcc1:amd64.shlibs
/var/lib/dpkg/info/libgcc1:amd64.symbols
/var/lib/dpkg/info/libgcc1:i386.list
/var/lib/dpkg/info/libgcc1:i386.md5sums
/var/lib/dpkg/info/libgcc1:i386.postinst
/var/lib/dpkg/info/libgcc1:i386.postrm
/var/lib/dpkg/info/libgcc1:i386.shlibs
/var/lib/dpkg/info/libgcc1:i386.symbols

I don't have libgcc1 available for use, it seems :(
I am running on a amd64 but I already did :

# dpkg --add-architecture i386
# aptitude update
# aptitude install ia32-libs
# aptitude install nvidia-glx-ia32

On Debian Squeeze, the game already worked really well but now on Wheezy... it is not

Edited by: Adrien2002

Mar 4 2013, 9:29pm Anchor

You do not have libgcc? It seems to be available for Wheezy:
Packages.debian.org 

Mar 5 2013, 3:39pm Anchor

Yes, it is already installed and even the 32 bits version
 
aptitude search libgcc
i   libgcc1                        - Bibliothèque de support GCC
i A libgcc1:i386                    - Bibliothèque de support GCC
p   libgcc1-dbg                     - GCC support library (debug symbols)
p   libgcc1-dbg:i386                - GCC support library (debug symbols)
p   libgccxml-dev                   - Libraries for building extension to gccxml
p   libgccxml-dev:i386

Edited by: Adrien2002

Mar 6 2013, 12:32am Anchor

Well, colour me confused. Not what you probably want to hear i take it? :(

Mar 6 2013, 9:52am Anchor

Oh :(
I succeed to access the menu by doing this

ln -s /usr/lib/mesa-diverted/i386-linux-gnu/libGL.so.1 /usr/lib/libGL.so.1

But now, on the menu I don't see anything but I hear the game and the weird sound of the select menu. So I succeed to launch the game but now I JUST don't see anything... any idea ?

I have also a problem with Trine 2. The game is, like Postal 2, only 32 bits binary and before to make this action, the game never made anything but since I did the command, I have the little windows asking me which resolution, the graphics etc... but when I start the game, it come all black for a few seconds and then return to desktop...

Why there is NO 32 bits game working on my Debian ?? It's really strange !!!
I mean, Amnesia is 64 bits and Trine 1 too, and both run more than perfectly on my system !!

I won't let it win, I will find the solution to my problem and I will post it here for every other people having the same issue !!

Edited by: Adrien2002

Mar 6 2013, 12:31pm Anchor

I know with WINE you need 32-bit versions of certain graphics components to get it to work on 64-bit systems. Since you are using the proprietary Nvidia blob I do not know how to help you, as my only experience with this was using the free Radeon drivers on Fedora, where I just grabbed the 32-bit Mesa packages to get around this issue. Still, maybe that has something to do with it, although it could still be unrelated.

Shame to since Trine 2 is running really well for me on my setup as well. Hope you can get things working. 

You could try issuing this into a terminal and then trying to launch Postal/Trine from the same terminal though:
export LIBGL_DRIVERS_DIR=/usr/lib/dri

Edited by: hamishwilson

Mar 6 2013, 10:41pm Anchor

I FOUND !!!!

I finally found, after sooooooooo many hours of researches. 

Finally, I don't have to use ia32-libs.

Let me explain you what I did... Firts of all, I format my partition to be sure to start from 0.
I installed nvidia-glx (the x64 version, of course)
I added repositories of architecture i386 to my computer
AND I made this :
# aptitude install libgl1-nvidia-glx:i386
# aptitude install libasound2:i386 

I never had to remove any files from the game, not even to create a link from libs files, nothing at all !!
The first one gave me what I need to start the game correctly (it's about graphics) and the second one is for the sound of 32 bits 3D applications.
I can play POSTAL 2 NOW !!!!
Oh and I will try Trine 2 later, I have to download it.

I had to know between Squeeze and Wheezy, about architecture, it completely changed.
Before I had to just add ia32-libs and nvidia-glx-ia32
but now it should disappear because it doesn't work anymore 

I really thank you so much to help me until we finally have the solution, hamishwilson. I am really happy to know there is people like you :) 
Hope what I wrote will help some poor guys in the same trouble as I was

Edited by: Adrien2002

Mar 7 2013, 11:50am Anchor

Great that you found a solution! :D

Sep 5 2013, 3:28pm Anchor

Error setting display mode: CreateDevice failed (D3DERR_DRIVERINTERNALERROR). If you just started the game then delete your 'Postal2.ini' file and try again.  Otherwise check the Tech Support web site.History: UD3DRenderDevice::UnSetRes <- CreateDevice <- UD3DRenderDevice::SetRes <- UWindowsViewport::TryRenderDevice <- UWindowsViewport::OpenWindow <- UGameEngine::Init <- InitEngine   

Please Help I don't know what to do ?!?!??

Sep 5 2013, 8:01pm Anchor

Try deleting the Postal2.ini like file it suggested?

 Also, are you on Linux or not, as it seems to be looking for DirectX?

Edited by: hamishwilson

Reply to Thread
click to sign in and post

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.