Post news RSS DM and DMUC version 6,5 released

I decided to offer a patch than a complete new DMUC because of the CTD issues of the new launcher. The DMUC will develop later, when hip finds the appropriate time to work on it. And do not forget to vote for DarthMod Empire if you enjoy it!

Posted by on

You have to install DMUC 6,2 and then install DMUC 6,2->6,5 Patch.
The download links are at this link.
Read also the simple installation instructions at this link.

Read the latest changelog here.

Comments
Bird_of_Prey
Bird_of_Prey

Great news! Turns out I have the setup file from 6.0 still. Too bad that won't do me much good. >_<

Reply Good karma Bad karma+1 vote
Post a comment
Sign in or join with:

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.