Post news RSS 1.20.0 - Compatibility?

Some of you maybe ask: Is Beta 1.3 compatible with the new patch? Or will you update the recent version? Or will you upload a new one?

Posted by on

Answers: Maybe; No; Yes.

What I'm going to do is making a new version of the mod (Beta 1.4) which is going to be compatible with the new patch of EU4 during April.

Answers: Maybe; No; Yes.

What I'm going to do is making a new version of the mod (Beta 1.4) which is going to be compatible with the new patch of EU4 during April.

Post a comment
Sign in or join with:

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.