The Battle for Middle-earth has just begun! The Edain Mod returns to the classic gameplay of the first Battle for Middle-earth, reimagined with countless new heroes, units and abilities. Journey deeper into Tolkien's world than ever before, relive the movies through meticulously crafted visuals and forge your path to victory in epic strategic battles. Follow your destiny... Middle-earth awaits.

Report Edain 4.5 Demo
Filename
edain4.5.zip
Category
Demo
Uploader
ElendilsCousin
Added
Size
2.02gb (2,165,356,255 bytes)
Downloads
10,526 (64 today)
MD5 Hash
0ca1c508878314a327f73af08c792bb3
Embed Button
Embed Widget
Description

This download contains all files you need to play the latest version (4.5) of the Edain Mod. If you experience any problems, please refer to the Readme for frequently asked questions or check out our support forums at the Modding Union website.

Preview
Edain 4.5 Demo
Comments  (0 - 50 of 67)
zxcasd17
zxcasd17

YESSSS

Reply Good karma Bad karma+7 votes
Kmogon
Kmogon

So it begins

Reply Good karma Bad karma+6 votes
Kmogon
Kmogon

For anyone who want to join our little community of fans you can join unnoficial edain disocrd server here Discord.gg

Reply Good karma Bad karma+4 votes
CaptainCorrigan
CaptainCorrigan

Hurray! 4.6 wen?

Reply Good karma Bad karma+4 votes
Kmogon
Kmogon

Gobbos wen ? Kappa

Reply Good karma Bad karma+3 votes
OakenShield224
OakenShield224

You: "4.6 wen?"
Me, an intellectual: "4.5.1 wen?"

Reply Good karma Bad karma+6 votes
spike177
spike177

Hey CaptainCorrigan has anyone had difficulty getting 4.5 download to start cause its not letting me start the installation for 4.5. Thanks in advance man

Reply Good karma Bad karma+1 vote
spike177
spike177

Disregard Anti Virus issues

Reply Good karma Bad karma+1 vote
fparker92
fparker92

It's being blocked by my anti virus - claimed the exe file is a Trojan.

Fixed it.

Reply Good karma Bad karma+1 vote
Primer_Sartoris
Primer_Sartoris

Let the old world burn in the fires of industry!!

Reply Good karma Bad karma+5 votes
Aristomakhos
Aristomakhos

Game crashes on startup.

Expected floating point value, math op, or predefined macro, but found 'ARCHER_VISION_SIDE'

Error parsing field 'VisionSide' in block 'Object' in file 'data/ini/object/mapobjects.ini', line 982.

Does anyone know a fix?

Reply Good karma Bad karma+1 vote
officialNecro
officialNecro

Make sure rotwk in on 2.01, bfme2 is on 1.06 and that you don't have any other mods installed.

Reply Good karma Bad karma+2 votes
Aristomakhos
Aristomakhos

Ok, rechecked everything. That problem no longer exists :)

However, it is asking me to insert a disc now for some reason, both AotR and RotWK did not have that problem (I uninstalled AotR prior to installing edain 4.5)

Reply Good karma Bad karma+1 vote
officialNecro
officialNecro

You need to mount mini images using a tool such as wincdemu

Reply Good karma Bad karma+1 vote
Aristomakhos
Aristomakhos

Damn, this really does not want to work, mounted with poweriso, did not work, but found a crack that settled the problem.

Now though, it says Invalid Sound 'WOTR_MusicRohanMS'

Reply Good karma Bad karma+1 vote
Kmogon
Kmogon

Change music in 2.02 launcher to minimal. Also. Applaying crack makes you unable to play online.

Reply Good karma Bad karma+1 vote
Aristomakhos
Aristomakhos

Downloaded the game from someplace different and reinstalled it. Also was forced to use daemon tools, which is cool because I'm hoping I could also drag a friend into this ;)

Thanks Kmogen and thank you officialNecro too!

Reply Good karma Bad karma+1 vote
dmallinson300
dmallinson300

Hey any possible way you could share where you downloaded from please?

Reply Good karma Bad karma+1 vote
Rothnaric
Rothnaric

Install BFME 2 and Rotwk, patch both (2.01 and 1.06) after this install 2.02 (v8.0.0) delete only the Patch file it creates manually then install what ever mod, the exe of the game will be fixed and not ask for cd and the game will now work fine...(delete the timer file and patch file of 2.02 only)

Reply Good karma Bad karma+1 vote
kubaschornik
kubaschornik

Chang version 2.01

Reply Good karma Bad karma+1 vote
YeshuaEnthusiast
YeshuaEnthusiast

So excited!

Reply Good karma Bad karma+3 votes
bayramakbak
bayramakbak

will we build my superior game?
I have 4.4.1

Reply Good karma Bad karma+1 vote
YeshuaEnthusiast
YeshuaEnthusiast

anyone have the link for the readme? I am having issues getting the game to display everything in English...

Reply Good karma Bad karma+2 votes
YeshuaEnthusiast
YeshuaEnthusiast

Never mind, I reinstalled it and it fixed it

Reply Good karma Bad karma+1 vote
grimbord93
grimbord93

is not english

Reply Good karma Bad karma+1 vote
ElendilsCousin Author
ElendilsCousin

Your files could be corrupted, downloading and then installing it again fixed it for others.

Also make sure your Antivirus doesn't interfere.

Reply Good karma+1 vote
YeshuaEnthusiast
YeshuaEnthusiast

Did the command points drop by 300? I can only get to 1500 with the expanded storeroom...

Reply Good karma Bad karma+1 vote
ElendilsCousin Author
ElendilsCousin

Yes, we lowered the maximum CP to 1500 in the standard mode.

Reply Good karma+1 vote
bayramakbak
bayramakbak

Galadriel very good
story section reminiscent of The hobbit movie beautiful

Reply Good karma Bad karma+3 votes
dunjam2
dunjam2

Why is it in German?

Reply Good karma Bad karma+2 votes
Resid5
Resid5

Hey, Edain team
My gandalf is speaking Germany in campain.
Some hobbits write in Germany too.
How to resolve this?

Reply Good karma Bad karma+3 votes
Aristomakhos
Aristomakhos

Same goes for me too, tried reinstalling, nothing.
Hope they fix soon.

Reply Good karma Bad karma+1 vote
Kmogon
Kmogon

For people experiencing language.ini related crashes: go to your files folder, the rotwk one where edain is installed. There is a folder called "lang" inside that folder, there are the .big files for the game. You need to disable the german one (adding .bak extension to it) and enable english.big (removing .bak extension)
then, if your game is still in german, quit, open the launcher, change language to german and back to english, and should be solved

That should work for wrong language too. Otherwise visit modding union or discord server.

Reply Good karma Bad karma+1 vote
Kmogon
Kmogon

For people experiencing language.ini related crashes: go to your files folder, the rotwk one where edain is installed. There is a folder called "lang" inside that folder, there are the .big files for the game. You need to disable the german one (adding .bak extension to it) and enable english.big (removing .bak extension)
then, if your game is still in german, quit, open the launcher, change language to german and back to english, and should be solved

That should work for wrong language too. Otherwise visit modding union or discord server.

Reply Good karma Bad karma+1 vote
nitebones
nitebones

i installed the game from the download and all the launcher has is label label texblock and i cant press play, in updates it just sits there scaning and doing nothing, did i do something wrong

Reply Good karma Bad karma+1 vote
ElendilsCousin Author
ElendilsCousin

The launcher is being pushed to its limits because we didn't expect this many people to immediately download it :D

If you've run the installer and successfully installed 4.5, you can just go play, no need to get any further updates. Make sure you delete all submods from previous versions (Angmar campaign, balance fixes,etc.).

Reply Good karma+2 votes
nitebones
nitebones

cheers, i cant click on the play button from the launcher or even close it normally, but as you said alot of people are stretching it to its limits so i give it a while. but trying to launch the game with the mod running i was getting a crash on start up something to do with rohan sound

Reply Good karma Bad karma+1 vote
ElendilsCousin Author
ElendilsCousin

That happens when you don't disable 2.02 properly. Make sure you not only disable the patch itself, but also pick "minimal music" in their launcher.

Reply Good karma+2 votes
nitebones
nitebones

i did a full fresh install, completely forgot cd keys was a thing, i will try and figure this all out tomorrow when it is calmed down, but thanks for the help

Reply Good karma Bad karma+1 vote
matheusantos98
matheusantos98

Feliz.

Reply Good karma Bad karma+1 vote
obi83
obi83

GRAZIE!

Reply Good karma Bad karma+3 votes
007hasan
007hasan

Wooooooooooooooooooooooo enjoy!

Reply Good karma Bad karma+3 votes
007hasan
007hasan

Elf upgrades. Weapon upgrades open very late. Please do the times as before.
These long waits make the game boring.

Reply Good karma Bad karma+1 vote
BalrogSlayerReforge
BalrogSlayerReforge

BOUT TIME LOL

Reply Good karma Bad karma+1 vote
Naits
Naits

to much downloading from servers so cant update, just one server to download from?

Reply Good karma Bad karma+1 vote
Kmogon
Kmogon

You can dowload patch 4.5 form here and install it over 4.4.1 . There shouldn't be any problems

Reply Good karma Bad karma+1 vote
dmallinson300
dmallinson300

Are you likely to have 2.02 support?

Reply Good karma Bad karma+1 vote
officialNecro
officialNecro

Edain will never have 2.02 support

Reply Good karma Bad karma+1 vote
AodhHammerhelm
AodhHammerhelm

Hi,
Thanks for all the work on new version of EDAIN.
I've downloaded the file but am getting this error/message when trying to unzip: (I'm running Edain on an XP Machine)

Could not write data into a file which has been previously opened. Most likely cause is the disk is full or write protected.

Archive: C:\Edain Downloads\edain4.5.zip
File:

Reply Good karma Bad karma+1 vote
anton4
anton4

hello i was install correct the game with 2.02 install but i change it on launher with minimal music but when i go in game my screen its pink why ?

Reply Good karma Bad karma+1 vote
ElendilsCousin Author
ElendilsCousin

Edain isn't compatible with 2.02. RotWK needs to be patched to 2.01, also you need to have BfME on 1.06, not 1.09.

Reply Good karma+2 votes
Dwarf_Fan
Dwarf_Fan

Good to know :)

Reply Good karma Bad karma+1 vote
anton4
anton4

ty i fix it

Reply Good karma Bad karma+1 vote
Post a comment
Sign in or join with:

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.

Follow Report Profile
Icon
Battle for Middle-earth II: Rise of the Witch King
Developer
Edain Team
Contact
Send Message
Release date
Mod watch
Follow
File
Browse
Files
Report
Report
Share
Related Games
Related Groups
Edain Team
Edain Team Developer & Publisher
Tags

Edain 4.5 Demo has not been tagged yet.