BLACK I.C.E. is an extensive mod of HOI3 under development by Panzeroo and many other members of the Hearts Of Iron 3 forum.

Add file Report Black ICE Mk VII Version 4.2 beta
Filename
MkVIIr1806.exe
Category
Full Version
Uploader
PANZEROO
Added
Size
561.7mb (588,983,453 bytes)
Downloads
5,715 (1 today)
MD5 Hash
2e2e936ca0fd97273625d7855617d815
Embed Button
Embed Widget
Description

New Version of the Mod which overhauls the vanilla game, adding in 1000's of new events, 100's of new units and techs and a much improved AI.

Preview
Black ICE Mk VII Version 4.2 beta
Comments  (0 - 50 of 71)
Guest
Guest

great mod keep up the good work.

Reply Good karma Bad karma+2 votes
modfreak22
modfreak22

thank you for this late X-mas gift can't wait to open it up and see whats inside!

Reply Good karma Bad karma+3 votes
roeschma
roeschma

please provide a rar or zip, on a mac, i cant open a exe :D

Reply Good karma Bad karma+1 vote
PANZEROO Author
PANZEROO

the mac version is being worked on this week

Reply Good karma+3 votes
roeschma
roeschma

any update here? :D thanks for your efforts

Reply Good karma Bad karma+1 vote
German_Bacon
German_Bacon

Do we need to install 3.2 first, then this version? Or is this the only required? New to the mod so never downloaded 3.2 :)

Best Mod.

- r

Reply Good karma Bad karma+1 vote
Hadadad Creator
Hadadad

no, do not install 3.2 first

Reply Good karma+3 votes
German_Bacon
German_Bacon

Thanks Hadadad, appreciate the response. I like the new Red and Yellow Colours for structures on the map. :)

Reply Good karma Bad karma+1 vote
voltar
voltar

Patiently waiting for the official, out of beta release :-)

Keep up the good work guys!!

Reply Good karma Bad karma+2 votes
PANZEROO Author
PANZEROO

That might be a few months away as we will slowly be adding in new GFX first. However I will say that 4.2 is as stable as 3.2 so long as you use podcat's TFH exe.

Reply Good karma+1 vote
voltar
voltar

Ah very good! 3.2 worked just fine for me, I will go ahead and give this a whirl. Thanks again!

Reply Good karma Bad karma+1 vote
voltar
voltar

Loaded ok! But I got tech buttons in the tech menu on top of other buttons and in some tech-tabs one button at top left.

Also as before game is letterbox on 16:9 resolutions. So on my 21.5" mon I'm using 1600x1200.

Reply Good karma Bad karma+1 vote
PANZEROO Author
PANZEROO

did you install 4.2 over a fresh TFH 4.02 game ? If there are old BICE files in the mix you will get problems. What checksum do you have ?

Reply Good karma+1 vote
voltar
voltar

Thank you so much for your reply.

I had run the uninstaller for v3 and then deleted the blackice folder that remained and wiped the files in Documents. Reinstalled problem persisted.
But then I opted to re-install HoI3 from scratch and now the issue is gone. Sorry I couldn't figure out where the conflict was, but hey if anyone has this issue tell them to fresh install hoi3 :-)

Reply Good karma Bad karma+1 vote
Guest
Guest

I have a persistent crash at [6 a.m.; 14 september; 1937].
Play Japan, have a heavy fighting in China.

hoi3_tfh.exe is replaced with podcat's file.

CTD report:
Имя события проблемы: APPCRASH
Имя приложения: hoi3_tfh.exe
Версия приложения: 0.0.0.0
Отметка времени приложения: 50e56591
Имя модуля с ошибкой: hoi3_tfh.exe
Версия модуля с ошибкой: 0.0.0.0
Отметка времени модуля с ошибкой: 50e56591
Код исключения: c0000005
Смещение исключения: 0066fe7f

Reply Good karma Bad karma0 votes
PANZEROO Author
PANZEROO

what is your checksum ? Are you using a fresh install of 4.2 ?

Reply Good karma+1 vote
Guest
Guest

Fresh installed tfh ver. 4.02; then podcat's file; then MkVIIr1806.exe installed.

Main game was localised, so result checksum is MMFQ.

Reply Good karma Bad karma0 votes
PANZEROO Author
PANZEROO

ow do you mean Localised ? The correct reported checksum is KGEX.

Reply Good karma+1 vote
Guest
Guest

My original HoI3 has a russian localisation pack so it contain russian language localisation files as well as english, and checksum differs in result.

I played BlackICE 3.2 smooothly before. And now i experience no bug from the start till september 14, 1937.

Reply Good karma Bad karma0 votes
PANZEROO Author
PANZEROO

the problem which 4.2 fixed was a crash when heavy fighting began. So this indicates that possibly your install has not worked correctly. The localisation pack should not hurt the mod, though BICE is only designed for English language. The bigger problem is that it will be difficult for you to know if you have the mod installed correctly. I can say that there are no other reports of a crash in 1937.

Reply Good karma+1 vote
Guest
Guest

Thank you for the hard work.

//
I stop all assaults and manage to pass this particular botleneck.

Reply Good karma Bad karma0 votes
Kost_
Kost_

No help. When fightings become more or less intensive game crashes. :(

Sorry for annoyance.
Will wait for ongoing patches, they can accidently fix my bottleneck. :)

Reply Good karma Bad karma+1 vote
PANZEROO Author
PANZEROO

do you have the correct checksum for 4.2 ? Because 4.2 is stable enough and you should not be getting crashes in combat if its installed correctly.

Reply Good karma+1 vote
Kost_
Kost_

I reinstall all once again and game running well now.
Sorry again, it was just my dumbness. :)

Reply Good karma Bad karma+1 vote
Guest
Guest

This comment is currently awaiting admin approval, join now to view.

German_Bacon
German_Bacon

Why are the land structures coloured red and yellow?

Reply Good karma Bad karma+1 vote
PANZEROO Author
PANZEROO

That's the colour combo the GFX guy chose . I guess it stands out better on the map ?

Reply Good karma+1 vote
German_Bacon
German_Bacon

I suppose. But to be honest kind of liked the original colours better, though those colours would look nice with the Soviet Union or PRC hehe.

I can just edit it manually in the files anyway, just have to find them (which can sometimes be a pain!).

Reply Good karma Bad karma+1 vote
Guest
Guest

This comment is currently awaiting admin approval, join now to view.

PANZEROO Author
PANZEROO

its not so much a bug as the nature of how the pact expires. You have 10 months from when you first take the pact, which may have been in Jan 1939 ? After this ten months the Soviets need to have at least twice the amount of troops facing you on the border. If so they can break the pact. The first way to prevent this is to sign the pact on the same day you invade Poland. You can also try manning the border with a lot more troops, even garrisons and militia will count. The other thing is we are reviewing the NAP settings to perhaps increase the troop ratio needed to break a NAP for the hotfix.

Reply Good karma+1 vote
Guest
Guest

I did, i made the pact in Sept 1939 but they broke it just as i defeated France in July. Taking France would be delayed so much if I kept like 3-4 stacks of units in every province. 3.2 didnt have this feature /=

Reply Good karma Bad karma0 votes
PANZEROO Author
PANZEROO

we are working on giving Germany more time before the soviets get angry. However you will need to keep a decent garrison on the border. You can use garrisons/ militia to do this. It also helps if you don't sign the M/R pack until right before invading Poland. That gives you more time before the soviets can break it.

Reply Good karma+1 vote
liuxinyu0428
liuxinyu0428

that is actually a bug。4.2 SU AI adds some baltic_states provinces in sealion check to prevent human players invade baltic_states before SU annex them。as province 1440——pogegen,the province besides memel。but in the GER claims memel event the pogegen is seceded to the GER。So it will inevitably cause the SU attacks。you can delete the check sentence in the SOV.lua。

Reply Good karma Bad karma+1 vote
PANZEROO Author
PANZEROO

Yes this was the issue with the soviet DOW. It took some time to uncover it as it was a simple province ID error. However the fix for this and everything else we dug up hunting for it is in the hotfix.

Reply Good karma+1 vote
ilcharlie
ilcharlie

The game keeps crashing after 30s playing as republican spain, i'm using the TFH launcher.

Also what is "the podcast file" and if i need it?

Reply Good karma Bad karma+1 vote
PANZEROO Author
PANZEROO

the mod won't run with out podcat's TFH exe. This was made by paradox to overwrite the vanilla TFH exe. It opens the game engine up to use more then 2Gb computer memory. You 100% need it to play BICE and prevent CTDs. You have to register your HOI3 base game on the paradox HOI3 forum to access their link for the exe.

Reply Good karma+1 vote
ilcharlie
ilcharlie

Also, do i have to wait to the official version? i mean a more stable version, would something happen to my save games on the beta?

Reply Good karma Bad karma+1 vote
PANZEROO Author
PANZEROO

4.2 is as stable as 3.2 if you use the podcat's TFH exe

Reply Good karma+1 vote
Guest
Guest

This comment is currently awaiting admin approval, join now to view.

ilcharlie
ilcharlie

No more chrashes, i have other bugs though.

I can't research "heavy industry" i alredy have "industry" at level 3, which is the only requirement, but "heavy industry" is still locked.

Also there are some techs in the "air to air" section that are alredy unlocked but i cant start them, i click "start" but nothing happens.

Reply Good karma Bad karma+1 vote
PANZEROO Author
PANZEROO

bad install ? This is not being reported as a bug elsewhere, nor do I have the problem.

Reply Good karma+1 vote
Dudok22
Dudok22

One small bug: I researched broadcasting level 1 as France and it opened decisions on grand infrastructure projects (mining, rail tycoon, highways agriculture...) as well as broadcasting. I have not researched any grand infrastructure projects.

Reply Good karma Bad karma+1 vote
PANZEROO Author
PANZEROO

you don't need research for the first grand infrastructure project, only if you want to gain more afterwards.

Reply Good karma+1 vote
JKKreule
JKKreule

Hey 4.2 runs great for me apart from some issues in the tech tree. Certain techs can't be researched even when the requirements are met; Most of the artillery tree (requiring infantry division 1 research) and armour tree (requiring AFV tracks and suspension 1 research). I was wondering if there is fix for this? Thanks

Reply Good karma Bad karma+1 vote
PANZEROO Author
PANZEROO

you must have install issues as I don't have this problem, nor is it reported outside of bad installs.

Reply Good karma+1 vote
Guest
Guest

This comment is currently awaiting admin approval, join now to view.

corleone101
corleone101

are there any post war events? like creation of west/east germany, n and s korea?

Reply Good karma Bad karma+1 vote
ilcharlie
ilcharlie

As far as i know you can create the ddr or eats germany, i guess if the allies are in germany too west germany could also be created, as for korea i dont think so, since that's in the fifties years after the 1936-1948 time period the game is set in.

Reply Good karma Bad karma+1 vote
corleone101
corleone101

what about outcome of china's civil war?

Reply Good karma Bad karma+1 vote
PANZEROO Author
PANZEROO

nothing major has been done in terms of post war events. This may occur sometime in the future.

Reply Good karma+1 vote
Post a comment
Sign in or join with:

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.

Follow Report Profile
Icon
Hearts of Iron III: Their Finest Hour
Developer
Black ICE Mod Team
Contact
Send Message
Release date
Mod watch
Follow
File
Browse
Files
New
Add file
Report
Report
Share
Related Games
Related Groups
Black ICE Mod Team
Black ICE Mod Team Developer & Publisher