Post feature RSS BUGS AND ISSUES

Read about and report about bugs in this article.

Posted by on

KNOWN BUGS AND ISSUES


Q: I can't select certain bombers in my Airbase! They are bombers, but their icons show as helicopters and when I click them, nothing happens.
A: This bug is related to the Light Bomber and MB-1 units. Those 2 units are new bomber units for the Industrial Age, and since the game doesn't originally have bombers in those age it doesn't recognize their unit type (hence they appear as bugged out helicopter icons in the Airbase). Use this workaround when building those units: build an airbase specifically for fighters or bombers or helicopters. Then just deploy one or all of the units docked in the base by right-clicking on the terrain (or shift-right-click to deploy all). You can also set rally points with 'R' and 'Shift+R' to cancel the rally point.

Q: I can't harvest certain rare resources! I see them but when I send a Merchant to gather them, he won't deploy.
A: I'll try to fix it as soon as I figure out how. Certain rare resources will be visible on the map but won't blink when you select a Merchant, Market, Fisherman or Dock. So always remember that the only rare resources you can harvest are the ones that are also visible (and blinking) on the minimap when selecting a Merchant, Market, Fisherman or Dock.

Q: Some textures aren't displaying right, or flicker!
A: (ONLY FOR NON-STEAM VERSION!) Make sure you copied the iface_buildings_CTW.tga, iface_units_03.tga and iface_units_03_half.tga to \art folder and overwritten files (if non-Steam version)! If you haven't messed with the folder structure of the .rar file and extracted to your game directory, it should work fine!

Q: The game crashed during loading of a map!
A: Since the mod increases the 'Big Huge' map size by 20%, certain maps may not load at this size. Known maps with this issue are Atlantic Sea Power, East Meets West and Nile Delta. When playing these maps, set map size to 'Huge' or lower to avoid crashes.

Q: Some buildings/units cost several hundred thousand resources!
A: This is a workaround I did in order to prevent having more than one building or unit (mostly unique buildings and unique units). I basically set the support cost of those buildings to over 200k resources so you could never gain enough resources to build another one after the first one is built.

Q: Some player scores go over several million at certain points in the game!
A: This is related to the above issue. Since certain buildings have an unobtainable support cost, the player who destroys said building/unit gets a much higher score for it (because the unit is considered much more expensive because of this increased support cost).

Q: I can't produce any new units / new units have issues with textures / unit prices are messed up / etc.
A: This can be caused by a lot of different things, but usually it's because the mod is conflicting with another mod that's also active. If on Steam, unsubscribe from any other mods as that causes issues with my mod. If that fails, try unsubscribing to the mod and re-subscribing. If that fails, download the mod manually from this website (the 'Steam version') and install the mod manually (read instructions here: Installing the mod). In the main menu of the game, go to 'Tools and Extras' and make sure that only one version of the mod is active: either the LOCAL version (the one installed manually) or the one that doesn't say LOCAL at the end (subscribed on the Workshop).

Q: I get an error followed by a crash ("NO DEFAULT UNIT G PIECE" or similar)!
A: This can be caused by a whole lot of reasons. I have tested the mod several times and this usually happens when I update the mod to a newer version. However, as of 5.94.1 I haven't encountered this bug as of yet. Make sure to follow these steps before posting a bug report:

  1. Try unsubscribing and resubscribing to the mod (reported to work by several users)
  2. Since the mod has been posted on the Steam Workshop it now has a different file structure, so make sure you delete ALL of the mod's folders from the 'mods' folder in "...\Steam\steamapps\common\Rise of Nations\mods" before subscribing to the mod. Make sure you close Steam before doing this.
  3. You can also try deleting your "My Documents/My Games/Rise of Nations" and "AppData/Roaming/Microsoft Games/Rise of Nations" folders in case it still doesn't work.
    P.S.: This WILL delete your save games and reset your player profile!
  4. In case it still doesn't work, please follow this link to the mod group page on Steam (Steamcommunity.com) and post under the 'BUG REPORTS' section (you don't need to join the group) or post a comment here under the latest downloadable link.
Comments
Guest
Guest

not working . i play bug alot game

Reply Good karma Bad karma+2 votes
0wcabibi88 Author
0wcabibi88

Can you be a little more specific? I can't really fix the problem if I don't know what's causing it..

Reply Good karma+1 vote
RakhGamer
RakhGamer

Hello, i'm new to this mod, and I followed the installation article, but, when I start the game with Americans and Turks (2 examples only) with the Rise of the Ages mod ON, the photo of unique unit when you start the game is not as the same as the "governments, wonders & nations.jpg" in which came inside the mod

for example: the RAH-66 Comanche of Americans is a black helicopter (in the picture inside the mod, with all details about units, nations, wonders, etc.), but when I start a new quick game, it show a 4 in a blank square instead of the black helicopter... this is normal???

Reply Good karma Bad karma+1 vote
RakhGamer
RakhGamer

It's definitive... some PICTURES (not skins in-game) are bugged or copied from another unit... plz fix it

Reply Good karma Bad karma+1 vote
0wcabibi88 Author
0wcabibi88

This sounds like an installation issue. Do you have the Steam or the non-Steam version? If you have the non-Steam version make sure your game is updated to at least to version 1.4. If you have the Steam version, subscribe to the mod on the workshop instead.

Also make sure that, when installing, you overwrite the files and don't mess with the folder structure inside the .rar.

Reply Good karma+1 vote
RakhGamer
RakhGamer

When I delete the sniper nest (at least with the Russians) I won a pack of 776 food!!

Reply Good karma Bad karma+1 vote
0wcabibi88 Author
0wcabibi88

This is intentional. Razing a building gives you a plunder value of 75% of the total resource cost of that building, but only in one resource. Since the sniper nest costs around 1000 resources in total to build, you get 776 food back if you raze it. I could not give back 75% of all the resources if you raze it because that's just how the game works - it only gives you back one.

The reason I made it food was that the sniper in the tower has a lot of food stored inside since he's always up there lol. In retrospect, I could have made it metal or wood..

Reply Good karma+1 vote
Guest
Guest

Your mod is great so far! But I have one strange bug (I think), last time when I played with 7 AI on Big Huge (Amazon rainforest) around the second age AI goes derp and sells all of its resources on market (probably becaose of the higher gold cost for tech) and as a result of that price crashes to 20 / 1 for ALL resources, and AI just stagnates becaose of that. No idea what is causing that, I will try to play team games with AI and to see what he is doing.
I tried fixing that like number of farms (in AI script), but I can't seem to find conditions for buying/selling resources on market.

Reply Good karma Bad karma+1 vote
0wcabibi88 Author
0wcabibi88

It think it's hardcoded, or a new script would have to be written to fix that. The AI does tend to spam the market too much because of the higher prices on everything because it's code was not adapted to match the changes.

Updating the AI so it works properly is one of the changes I have left to do in this mod, but I'm currently struggling with it.

Reply Good karma+1 vote
Guest
Guest

My game's AI will never attack each other, and will never seem to build supply wagons or have an army beyond 10 units. Is it just my game or have others had this problem?

Reply Good karma Bad karma0 votes
0wcabibi88 Author
0wcabibi88

I've never encountered this. Did you follow the installation procedure here? Moddb.com

Reply Good karma+1 vote
Guest
Guest

Hey, I followed the installation procedure and everything for a non-steam version of Rise of nations gold, but when I start a new game, it crashes immediately with the error message: Number of tribes in rules.xml does not equal NUM_TRIBES

[Click RETRY to debug etc...]
Safe to ignore : NO

Whatever I do afterwards the game closes up. Any idea how to solve this?

Reply Good karma Bad karma+1 vote
0wcabibi88 Author
0wcabibi88

You need the Extended Edition v1.04 or up. I'm not sure it works on Gold anymore..

Reply Good karma+1 vote
Post a comment
Sign in or join with:

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.

Feature
Browse
Features
Share
Related Games