Description

Welcome to Jedi Knight Remastered! This installation file will install the JKGFXMOD the Jedi Knight Neural Upscale Texture Pack and the Enhancement mod all together in a nice installer! The FOV Mod is also been added. This also patches the game with the unofficial patch. All mods can be downloaded and installed separatly if you desire.

Preview
Jedi Knight Remastered v1.0
Comments
FastGamerr
FastGamerr - - 580 comments

Excellent work! No need for convoluted installation instructions anymore. :]

Reply Good karma Bad karma+4 votes
GeneralTantor Author
GeneralTantor - - 637 comments

Thanks took awhile to find a good installer program that I could really customize easy! The program made it so easy to make! its called install Creator. The best thing was it was free to use just had an ad for the software at the end.

Reply Good karma+4 votes
joshdavison309
joshdavison309 - - 5 comments

This is incredible! I've been trying to get the enhanced textures to work for years, but the numerous tutorials always ended up being too much of a pain or led to some sort of compatibility issue.
A few bugs I've noticed thus far though:

-The Bloom effect on the lightsaber reverts to the vanilla blade if you raise the brightness too high in game.
-Raising brightness at all causes some texture bugs when firing the pistol and E11.
-The game chugs (even when all toggled effects are set to false) on my setup. I have to run the game in 800x600 just to have an FPS above 30. My setup isn't high end, but with what it is I should be able to handle most of the effects running.
-Running animations don't work for any of the weapons in first person.
-Changing anti-aliasing settings causes a black screen on launch.
-Exiting the game leaves my desktop in the same resolution as the game, and requires me to manually reset it from my control panel.

Regardless, this is absolutely incredible, and I hope that the word gets out about this new download. You should be really proud, because people have been looking for something like this for at least 15 years.

A few suggestions I have for updates:
-Allow an option for Bloom turned off on everything but lightsabers and blaster bolts.
-See if you can get resolution to be an in game toggle.
-Get this compatible with MOTS asap!!! :)

Reply Good karma Bad karma+5 votes
GeneralTantor Author
GeneralTantor - - 637 comments

Awesome glad you were able to get it working! I will be working on an installer for MOTS for sure! as for the other stuff I only made the installer please consult the Mod authors. A form of bugs can be reported on here: Github.com

Reply Good karma+4 votes
joshdavison309
joshdavison309 - - 5 comments

Will you update the files to the latest versions if the original authors update things on their end?
I'm kind of nervous to update without using your installer, since this is the first time I've ever had it all working.

PLEASE respond here when you get MOTS launched! I'll be one of the first people to test the install for you!

Reply Good karma Bad karma+2 votes
GeneralTantor Author
GeneralTantor - - 637 comments

yeah sure thing! yeah I will update to a new installer as new versions come out! and Ill let you know when MOTS is done ;)

Reply Good karma+2 votes
Guest
Guest - - 699,659 comments

Thanks for the efforts!

Reply Good karma Bad karma+1 vote
JohnMidnight
JohnMidnight - - 65 comments

Does not do 4K Resolution it seems. True or false, fullscreen or no:
I.imgur.com

Reply Good karma Bad karma+2 votes
GeneralTantor Author
GeneralTantor - - 637 comments

This is an issue with display % right click on your desktop and click display settings make sure the % part is only zoomed to 100%. When it was at 150% I got this mess: Media.moddb.com

Reply Good karma+4 votes
redcubeasdf
redcubeasdf - - 5 comments

This is honestly a godsend, only issue I'm having is that the game won't accept my native resolution (1920x1080) and only allows 1440x1080 letterboxed. other variables in the config file (bloom, ssao, etc.) work just fine. I even checked windows display settings.

Reply Good karma Bad karma+1 vote
GeneralTantor Author
GeneralTantor - - 637 comments

Thats strange did you check this setting in display settings? Moddb.com

Reply Good karma+1 vote
Matt4545
Matt4545 - - 3 comments

Was excited to see this! Installed successfully (seemingly?), adjusted the configuration and then when I double clicked the desktop shortcut it launched inject.exe and was hogging a lot of system resources in the background but never launched the game? What could I do be doing wrong? Thanks,

Reply Good karma Bad karma+1 vote
GeneralTantor Author
GeneralTantor - - 637 comments

check the configuration the command launch could be launching the wrong .exe file... Do not command the configuration to launch the original JK.exe you need to have it launch the "JKR-fovno.exe" Or one of the FOV versions of the exe. The original JK.exe has not been touch therefore its not going to have the patch in order to run the mod. I do this so the mod can be easily uninstalled without messing with the Original game files therefore playable again normal.

Reply Good karma+1 vote
Matt4545
Matt4545 - - 3 comments

Seems to work seamlessly now. I just did a fresh re-install of everything and let it launch using the default settings. My only question now is that the on screen text, like the multiplayer scores, are sort of bunched up? Any idea why that is?

Reply Good karma Bad karma+1 vote
Matt4545
Matt4545 - - 3 comments

Also, the textures are all wierd and rainbow in the MP character selection screen, but fine in the game. Not a deal breaker, but odd.

Reply Good karma Bad karma+1 vote
arcariandelvers
arcariandelvers - - 1 comments

I have the same issue. I've double checked and the config is set to jrk-fovno.exe and that is what is running. The exe is running in the background soaking up CPU, but there is nothing on screen.

Reply Good karma Bad karma+1 vote
Guest
Guest - - 699,659 comments

Is it capped at 30 fps?

Reply Good karma Bad karma0 votes
IAmTheWalrus!
IAmTheWalrus! - - 122 comments

Technically no, but the mouse input still feels like it is.

Reply Good karma Bad karma+1 vote
Guest
Guest - - 699,659 comments

The textures are all messed up it looks like there are missing textures when i play the game, can someone help??

Reply Good karma Bad karma0 votes
GeneralTantor Author
GeneralTantor - - 637 comments

make sure to enable 3D acceleration in the menu before starting... but also with different hardware the game has been know to act up whats your specs? And what is your configuration settings?

Reply Good karma+2 votes
Guest
Guest - - 699,659 comments

Fantastic mod, thanks for all the hard work. I do have an issue with the letterbox in DF2 (GOG version), my monitor is 2560x1440 and the game only runs in a sort of wierd box with the top alinged to the upper screen edge, but the sides and bottom bit are large black areas. The HUD is at the bottom where it should be though. Changing the resolution does not help and I've tried fiddling with all I could think of in the settings but no dice. Even reinstalling the game and the mod did not help. Strangely enough MOTS runs perfectly in full screen, same settings. Any insight would be appreciated.

Reply Good karma Bad karma+1 vote
Guest
Guest - - 699,659 comments

I had the same problem and tried basically everything before finally realizing that in display settings there is a "view size" slider, putting that on the 2nd highest position makes the game fullscreen and you can see the HUD (you can't see the HUD if you max out this weird setting).

Reply Good karma Bad karma+1 vote
Guest
Guest - - 699,659 comments

You, my friend, are a star and deserve a long life full of happiness

Reply Good karma Bad karma+1 vote
ElCabron187
ElCabron187 - - 4 comments

I only get a black screen when playing the game and with healthbar visible.. Any help?

E: Im running a Lenovo Legion Y540 laptop and it has 144hz screen. If that is any help.

Reply Good karma Bad karma+1 vote
Guest
Guest - - 699,659 comments

No matter what I try it keeps launching with 3 quarters of the screen missing and won't load into the level, and I have a really high end pc!!

Reply Good karma Bad karma+1 vote
cobra7667
cobra7667 - - 1 comments

mine keeps launching with green and white bars across the screen

Reply Good karma Bad karma+1 vote
Guest
Guest - - 699,659 comments

Ok, so I am running a GTX 1660 Super on a i5 9400f. 16 gb 3333ghz Ram. I have two major problems when running this mod:
1. Textures are all screwed to hell, swapped out and dont like right at all.
2. When I try to fire my weapon, it causes the game to crash.

Reply Good karma Bad karma+1 vote
Guest
Guest - - 699,659 comments

Note to anyone encountering this issue: Try a fresh game. I was loading an old file and it was causing the problem.

Reply Good karma Bad karma+1 vote
Archiwista
Archiwista - - 6 comments

Amazing job. Works like a charm. Thank You :)

Reply Good karma Bad karma+1 vote
Guest
Guest - - 699,659 comments

Hi GeneralTantor, just wondering what I would need to tweak to stop the texture glitch whenever I fire the pistol or the blaster rifle. It's mainly the firing texture from the gun's barrel that displays a multicoloured sprite which I don't think is rendering in properly. Any hints on how to make it appear as intended?

Reply Good karma Bad karma+1 vote
Guest
Guest - - 699,659 comments

Okay nvm! Just quickly read in a previous comment that it's affected by the brightness. I've notched it down to 0 in the Display settings and it's rendering as normal.

Reply Good karma Bad karma+1 vote
jakewreichert
jakewreichert - - 1 comments

When I play the game some of the textures are missing, plus when I go into first person mode the game crashes, how can i fix this?

Reply Good karma Bad karma+1 vote
Geomage73
Geomage73 - - 1 comments

Hello, In my system it seems that Jk.dll prevents the mod from starting. Any ideas?

Thank you!

Reply Good karma Bad karma+1 vote
Guest
Guest - - 699,659 comments

Now that JkGfxMod 1.0 is officially released, could you update these to include it? I still get weird stuttering after 5 minutes play and it sounds like that is addressed. I tried copying files over the ones installed by JKR but it immediately crashes. Thanks again

Reply Good karma Bad karma+3 votes
Guest
Guest - - 699,659 comments

bump - any direction on how I can add JfGfxMod 1.0 myself? I've tried several ways. Sure would be good to have all the fixes 1.0 adds to this "ultimate edition". Thanks

Reply Good karma Bad karma+3 votes
Guest
Guest - - 699,659 comments

Thanks so much I just did all my research on trying to play this again after all these years and arrived at this one stop shop!

Reply Good karma Bad karma+1 vote
Guest
Guest - - 699,659 comments

I've run into an issue where I start the game staring at the ceiling and can't look down. I don't use mods often so I'm sure I'm missing something simple.

Edit: override the DPI settings. I think that's what it was.

Reply Good karma Bad karma+1 vote
Guest
Guest - - 699,659 comments

I noticed something that I don't think is attributable to the base game. on level eight, after killing Yun, you have to jump down a pit into a duct, but when I play remastered, the duct seems to be entirely absent, rendering progress impossible without cheats. Did I install something wrong?

Reply Good karma Bad karma+1 vote
Guest
Guest - - 699,659 comments

This comment is currently awaiting admin approval, join now to view.

Guest
Guest - - 699,659 comments

Found that this is entirely non-functional for me as no matter what I have tried launching this tells me that I do not have Direct Play and then crashes, no compatibility modes or manual activation of direct play seems to change anything either.

Reply Good karma Bad karma+1 vote
guest_134532
guest_134532 - - 227 comments

Can you update the pack and include the things from here:
Pcgamingwiki.com

Reply Good karma Bad karma+1 vote
Guest
Guest - - 699,659 comments

This comment is currently awaiting admin approval, join now to view.

Guest
Guest - - 699,659 comments

This comment is currently awaiting admin approval, join now to view.

DivingDeep39
DivingDeep39 - - 2 comments

I'm having trouble with running the game. Framerate hovers around 15 and there's input lag. Everything feels sluggish. I'm on a i5-9300H, GTX 1650, 16GB Ram machine. Any way to fix it?

Edit: setting "enable_ssao: false," improves framerate and input lag.

Reply Good karma Bad karma+1 vote
ThanosAthaYT
ThanosAthaYT - - 16 comments

makes the game look 10 years younger!

i see that purple models Imgur.com
edit: fix Youtube.com

Reply Good karma Bad karma+1 vote
Post a comment
Sign in or join with:

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.