Description

This Tool was written by me to make your life with Mods in Dawn of War much more easier! In the current version i've added both the old legacy 1.2 version along the new 1.3 version of the Mod Manager in case 1.3 causes trouble for you. Changes in current revision 1.3:

Preview
DoW Mod Manager 1.2 + 1.3 (OUTDATED)
Comments  (0 - 50 of 122)
Talic
Talic - - 449 comments

This is so needed, especially when having multiple different mods in one game.

Reply Good karma Bad karma+14 votes
moddlord1
moddlord1 - - 11,188 comments

Very coool!! much thanks!!

Reply Good karma Bad karma+4 votes
Racerking98
Racerking98 - - 165 comments

Do I need to overwrite the readme?

Reply Good karma Bad karma+3 votes
FragJacker Author
FragJacker - - 1,624 comments

No you don't have to ^^. Just put the .exe and the Resource Folder into your Soulstorm Root Directory and that's it.

Reply Good karma+1 vote
Zeksi42
Zeksi42 - - 19 comments

please, do you can create version mod manager for Win 32?

Reply Good karma Bad karma+1 vote
THEONLYDarkShadow
THEONLYDarkShadow - - 117 comments

What do you mean by that, exactly? Do you mean something like this?
Moddb.com
Or do you mean something different?

Reply Good karma Bad karma+1 vote
Guest
Guest - - 693,140 comments

where can I find the root directory?

Reply Good karma Bad karma+1 vote
FragJacker Author
FragJacker - - 1,624 comments

It's ...\THQ\Dawn of War Soulstorm

Or in case of Steam ...\Steam\SteamApps\common\Dawn of War Soulstorm

Reply Good karma+3 votes
dopeycarmine
dopeycarmine - - 4 comments

It says I'm missing the Daemons mod but I have the Ultimate apocalypse daemons, help!

Reply Good karma Bad karma+4 votes
FragJacker Author
FragJacker - - 1,624 comments

UltimateApocalypse_Daemons Not Equal Daemons Mod! You'll still need the base daemons mod installed since the UltimateApocalypse_Daemons is more like a plug-in to make the base Daemons Mod compatible with UA and add UA content to it!
Get it from here Forums.relicnews.com(1-6)-Complete-Released!

Seems like my Tool already proved it's worth then ^^.

Reply Good karma+7 votes
Kriegtooth
Kriegtooth - - 1,608 comments

Soooo, I know you dont want me to ask. But I gotta ask

All this...is it almost time?

Reply Good karma Bad karma+5 votes
CubeZeroZero7
CubeZeroZero7 - - 33 comments

Nice :D

Reply Good karma Bad karma+2 votes
Guest
Guest - - 693,140 comments

is this mod manager an essential? or can I run the mod without it?

Reply Good karma Bad karma0 votes
FragJacker Author
FragJacker - - 1,624 comments

This is absolutely optional. Its more of a helper tool not a required Mod launcher. The purpose of it is to track down missing requirement mods and allow for a safe and easy start.

Reply Good karma+2 votes
Dark_Ansem
Dark_Ansem - - 433 comments

where do I throw money?

Reply Good karma Bad karma+5 votes
deathtrooper900
deathtrooper900 - - 780 comments

Ok I've got an issue here, it says I'm missing Renegade guard but its in my folder and matches the module letter for letter, and it worked before, any ideas?

Reply Good karma Bad karma+1 vote
FragJacker Author
FragJacker - - 1,624 comments

The tool reads the content of the .module file. Inside each module file is a line named "Modfolder = NameOfModFolder". This name must match the one of the folder that contains all the mods assetts! I figured that sometimes the name of a .module differs from the name specified in the .modules "Modfolder" line.

The issue might be that the modfolder is somehow named after it's module file eventhough there's a different Modfolder specified WITHIN the .module file.

I'd recommend you opening the renegade guard mods .module file and check if the Modfolder name specified in there. If that name also matches the mod folder, then there might be some formatting error within the .module file which i haven't handled in my tool yet.

If that's the case send me a PM via moddb.

Reply Good karma+1 vote
MrKindCat
MrKindCat - - 90 comments

Today is a release day FOR THE EMPEROR!We want the mod!)))

Reply Good karma Bad karma+1 vote
LorD_Horusa
LorD_Horusa - - 18 comments

For some reason ( mby because i use windows xp) this is not working.

Reply Good karma Bad karma+1 vote
Guest
Guest - - 693,140 comments

It works perfectly on my computer with Windows 8 but my other one with XP can't run it. It says this is not a valid Win32 app. Any ideas?

Reply Good karma Bad karma+1 vote
FragJacker Author
FragJacker - - 1,624 comments

Probably you're lacking the latest .NET and/or Visual C runtimes. Try getting them from the micro$oft website if they're still available though.

Besides from that I can't help you very much then since XP is not supported anymore from even Micro$oft itself :(

Reply Good karma+1 vote
Eleddon
Eleddon - - 24 comments

Grand release: 23h 59min 59sec

Reply Good karma Bad karma+1 vote
Blizardbear69
Blizardbear69 - - 23 comments

sorry for being a noob and asking for help but i have installed daemons and Inquisition then THB but the manager says all im missing is UltimateApocalypse_Daemons and UltimateApocalypse_Inquisition. :/

Reply Good karma Bad karma+1 vote
FragJacker Author
FragJacker - - 1,624 comments

Hmm I tested this on my end installing first THB into my STEAM DoW version and it already got UltimateApocalypse_Daemons and UltimateApocalypse_Inquisition showed as installed.

Did you check that you was THB installing indeed to the right folder? I managed to mix it up because i've got two different Soulstorm installations here and then wondered why the mod was not showing up xD...

Reply Good karma+1 vote
Blizardbear69
Blizardbear69 - - 23 comments

i gave up and wiped it all and reinstalled.... it worked :P

Reply Good karma Bad karma+1 vote
redar2013
redar2013 - - 45 comments

Strangely, I stand all the necessary modifications, but THB_new_races but still does not work (

Reply Good karma Bad karma+1 vote
Blizardbear69
Blizardbear69 - - 23 comments

rest in peperonis (try a clean install and dont install UA just install THB worked for me)

Reply Good karma Bad karma+2 votes
redar2013
redar2013 - - 45 comments

So you offer, to remove to ebony Ultimate Apocalypse and install THB?

Reply Good karma Bad karma+2 votes
redar2013
redar2013 - - 45 comments

Don't work...

Reply Good karma Bad karma+1 vote
FragJacker Author
FragJacker - - 1,624 comments

Be sure that the other races are also UP-TO-DATE. You might have an outdated daemons mod which will NOT BE DETECTED by my Modtool yet! Just in case download the full version here and delete the old folder and drop in the new one. Mediafire.com

Reply Good karma+1 vote
sieferdarkstar
sieferdarkstar - - 1 comments

I'm having trouble is says c:/users/lance/desktop/gamefi~1/dlltie.dll is missing anyone know what this is

Reply Good karma Bad karma+1 vote
Guest
Guest - - 693,140 comments

посоветуйте программы для запуска разных модов например тираниды и демоны

Reply Good karma Bad karma+1 vote
Guest
Guest - - 693,140 comments

Its coming up at a .7z file and not letting me open it :/

Reply Good karma Bad karma+1 vote
FragJacker Author
FragJacker - - 1,624 comments

You need the programm .7zip in order to open .7z files. Get it here already! 7-zip.org

Reply Good karma+1 vote
THEONLYDarkShadow
THEONLYDarkShadow - - 117 comments

Are they any plans on making this tool open-source? I might be interested in looking at the code and seeing if I could contribute some improvements (depending on the language). =3

Reply Good karma Bad karma+1 vote
FragJacker Author
FragJacker - - 1,624 comments

This is definetely going to be open source, so that more skilled people might do some new amazing changes ^^. The program was written in C#.

I just need to do some documentation for my code to make it easier for others to understand what's going on. I am just not that much fond of the documentation style used in Visual Studio since I am an Eclipse user which has the nice JAVAdoc feature ^^.

Reply Good karma+1 vote
SpartanofApproval
SpartanofApproval - - 97 comments

Does the Ntcore executable automatically work with the mod manager?

Reply Good karma Bad karma+1 vote
FragJacker Author
FragJacker - - 1,624 comments

I don't see any reason why not. It's just important, that there's a Soulstorm.exe file present in the folder. The tool will only recognize the name of the .exe file not it's content/hash value.

Reply Good karma+1 vote
SpartanofApproval
SpartanofApproval - - 97 comments

Ok! Right now I'm testing between using your Mod Manager and then just using the .exe solo for comparisons.

I'll let you know what I can come up with.

Reply Good karma Bad karma+1 vote
SpartanofApproval
SpartanofApproval - - 97 comments

Noticing a slight difference in loading times.

Using the .exe alone is barely faster then when using mod manager.

So nothing significant.

Side note: This Mod Manager is a HUGE leap for mod users and kinda wished somethin like this appeared sooner.

Many brownie points Cosmo!

Reply Good karma Bad karma+1 vote
FragJacker Author
FragJacker - - 1,624 comments

Also if you want to use the NTCore.exe improvements for the disc version as well you might want to download the LAA Patcher from here Steamcommunity.com that patcher can patch any game as far as I understand to use moar RAM for the love of the RAM God.

Reply Good karma+1 vote
Guest
Guest - - 693,140 comments

Every time I try to install this, I get a 404 page not found error, is the link broken?

Reply Good karma Bad karma+1 vote
FragJacker Author
FragJacker - - 1,624 comments

It works fine for me. Maybe you got issues in general on the moddb page? If you still have trouble here's the mediafire link Mediafire.com

Reply Good karma+1 vote
makiyu1019
makiyu1019 - - 63 comments

dont download as a guest, try registering moddb then download it again

Reply Good karma Bad karma+1 vote
SepulchureX
SepulchureX - - 14 comments

Is it possible to estimate the date of the next update of this mod manager? And when will it feature things listed in ,,this tool will currently not:" list? That would be a really great addition.

Thanks.

Reply Good karma Bad karma+1 vote
Guest
Guest - - 693,140 comments

Okay I everyone looks good for New Factions. It says i have the Three new races installed but not the UA ones. Not sure what to do about fixing that. Any Ideas?

Reply Good karma Bad karma+1 vote
Guest
Guest - - 693,140 comments

I have a prblem...I installed every mod and everything is ok except that the only mod that seems to be missing is tyranid mod

Reply Good karma Bad karma+1 vote
FragJacker Author
FragJacker - - 1,624 comments

Does it work over the in-game mod manager without any flaws? If you need the Tyranids, get em here Moddb.com

Reply Good karma+1 vote
Guest
Guest - - 693,140 comments

Downloaded as a z-zip files but when I try to extract it I get "0 Can not open output file C:\Program .....\DoW Mod Manager 1.1.exe" Does anyone more experienced here know why this happens?

Reply Good karma Bad karma+1 vote
FragJacker Author
FragJacker - - 1,624 comments

I packed it with 7-zip. You may want to try using the 7zip extractor tool for unpacking unless you did already so. If in doubt get it here 7-zip.org

Reply Good karma+1 vote
Guest
Guest - - 693,140 comments

Than you for your very rapid response, I just checked that the tool was up-to-date and re downloaded the compressed file. I don't use 7-zip very often and am relativley inexperienced, I've used it today for other files of the same type and it worked but for some reason with the mod manager I get error message "can not open output file DoW Mod Manager 1.1.exe

Reply Good karma Bad karma+1 vote
Jamster023
Jamster023 - - 2 comments

Investigated further,7-zip refuses to extract any .exe files, no idea why!

Reply Good karma Bad karma+1 vote
Post a comment
Sign in or join with:

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.