Description

I reeskined all the original Brutal Doom v20b weapon sprites to make a differente arsenal to play BDv20b. In this version i recolored all the kick green sprites to Blue kicks for those Blue Brutal Marines like me!

Preview
BD v20b Jrmyxd Arsenal v4 [Update 07/07/16]
Comments  (0 - 50 of 103)
David_Jackson
David_Jackson

Awesome!!!

Reply Good karma Bad karma+6 votes
leehandwave5
leehandwave5

dat rifle :3, needs to be in v20b

Reply Good karma Bad karma+1 vote
SheToldMeSheCouldFly
SheToldMeSheCouldFly

The skins are hot! The blue light added to the base of the fire for the flame thrower is nice too!

Reply Good karma Bad karma+1 vote
Titus27
Titus27

Its not working. Everytime I load only the original doom shows up.

Reply Good karma Bad karma+1 vote
Jrmyxd Author
Jrmyxd

Dont run it with BDv20b , Just run with this mod cuz is BDv20b main file with other weapon sprites

Reply Good karma+2 votes
Titus27
Titus27

I didnt run it with BD V20B. Does it require open GL 3.0?

Reply Good karma Bad karma+1 vote
Jrmyxd Author
Jrmyxd

Maybe Gzdoom 2.1, but its only the same BDv20b only with other weapons D:. Try play it only with this wad

Reply Good karma+1 vote
Titus27
Titus27

I did. But each time I load, the normal doom shows up. Not this one.

Reply Good karma Bad karma+1 vote
Titus27
Titus27

It's like it didnt even read the mod.

Reply Good karma Bad karma+1 vote
SheToldMeSheCouldFly
SheToldMeSheCouldFly

Try gzdoom 1.8.10 dec 2014, it works for me fine with that branch and 2.1 dated for jan. 14th 2016! And enter it as the 1st pk3 under 'global autoload' in your .ini file.

Reply Good karma Bad karma+1 vote
Titus27
Titus27

First off im using a port for android. Which means I play this game on android. It uses gzdoom 1.8 and 2.1 pre(optional). All mods work except this and project brutality. Because brutality requires open gl 3.0 I have only 2.0. I think this mod requires open GL 3.0 too

Reply Good karma Bad karma+1 vote
SheToldMeSheCouldFly
SheToldMeSheCouldFly

The 1.8 branch doesn't require the newer open gl. You have to find a 1.8 branch dated from 2014 tho. It's a nice mod. Try this one -

Forum.drdteam.org

The 2nd zip in 1st post is 1.8.10 from DEC. 2014. Works great for me!

Reply Good karma Bad karma+1 vote
Titus27
Titus27

It won't work that way. To add a new gzdoom build whoever made this port has to do it themselves. Things are different in android

Reply Good karma Bad karma+1 vote
Ultraremi
Ultraremi

I know your issue. Try rename the pk3 file to bdv20bjrmyxdarsenal.pk3 Yes, you need to put them together to make it work.Because if the pk3 file has spaces between its file name it will always show normal DooM. Hope it worked for you.

Tested it with GZDoom Build 2.1pre on Doom touch. Works like a charm.

Reply Good karma Bad karma+1 vote
Guest
Guest

This comment is currently awaiting admin approval, join now to view.

aleximax
aleximax

This is great!!!

Reply Good karma Bad karma+3 votes
Jrmyxd Author
Jrmyxd

Thx marine

Reply Good karma+1 vote
⋆Ƅarge™
⋆Ƅarge™

im so sorry i didnt get the legs done in time ;~;

Reply Good karma Bad karma+1 vote
⋆Ƅarge™
⋆Ƅarge™

but bruh that rocket launcher is the beta sprite from v20b!! and the minigun is AWESOME! i should make the v15 chaingun beta sprites if you want them? ive already started them and could finish them soon!!

Reply Good karma Bad karma+1 vote
Jrmyxd Author
Jrmyxd

Sure bro!

Reply Good karma+1 vote
⋆Ƅarge™
⋆Ƅarge™

some sprites are missing and people say that it looks like an LMG barrel so i shouldn't do it, are you okay with that? :o im real sorry again just thought it looked nice!!

Reply Good karma Bad karma+1 vote
Jrmyxd Author
Jrmyxd

Mmmm let's see what can i do D:

Reply Good karma+1 vote
⋆Ƅarge™
⋆Ƅarge™

oh bro you dont have to make anything ive made too many sprites to count! :D im not saying i CANT do it, goodness no haha im saying i dont want people to think its an LMG variant! :)

Reply Good karma Bad karma+1 vote
FPSNation
FPSNation

Looks cool! As you have supported me, I will support you too! Downloading instantly! =D

Reply Good karma Bad karma+2 votes
Jrmyxd Author
Jrmyxd

Thx bro! ^^

Reply Good karma+1 vote
Titus27
Titus27

What are the requirements for this mod?

Reply Good karma Bad karma+1 vote
Jrmyxd Author
Jrmyxd

Maybe with a new Gzdoom 2.1 like gzdoom-g2.1.pre-1778-g1a63167.7z
Devbuilds.drdteam.org

Reply Good karma+1 vote
Titus27
Titus27

That's exactly what I'm using. The thing is I'm playing doom on my phone using a port I got from Amazon app store. And its using 2.1 pre.

Reply Good karma Bad karma+1 vote
Jrmyxd Author
Jrmyxd

Did you try download it again?

Reply Good karma+1 vote
Titus27
Titus27

Yes

Reply Good karma Bad karma+1 vote
Guest
Guest

This comment is currently awaiting admin approval, join now to view.

wpninja
wpninja

This mod can be played on an android? I can't see this being played smoothly at all on one of those lol. *edit* nevermind, I just seen a youtube video of someone playing it on one but it looked like a picture slide show lol.

Reply Good karma Bad karma+1 vote
Titus27
Titus27

There's this port called D-touch by beloko games available at the Amazon app store.

Reply Good karma Bad karma+1 vote
sonicteam2k7
sonicteam2k7

plays fine on the SHIELD tablet good sir

Reply Good karma Bad karma+1 vote
_Claws_
_Claws_

So does it work or not with Project Brutality?

Reply Good karma Bad karma+1 vote
Jrmyxd Author
Jrmyxd

Nope cuz it's BDv20b main file with another weapons.

Reply Good karma+1 vote
Jellyman1303
Jellyman1303

1)Chaingun looks way too black and BFG looks like a toy.
2)AR looks freakin' sweet and the rocket launcher looks way better than the default one.
3)It would be nice if you replaced the revenant's missile launcher with PB's version of it.

Reply Good karma Bad karma+1 vote
Jrmyxd Author
Jrmyxd

Im gonna try but now im adding a new chaingun and im going to look for another BFG bro. Also im working on a different arsenal to Classic mode

Reply Good karma+1 vote
Jrmyxd Author
Jrmyxd

New update today!
Changes:
New minigun (tripleminigun) (This item is not op i didn't touch the dmg on the decorate)
New BFG
Classic mode Reeskined on Beta! (taste it by your own risky, and told me what do you thinks )

Reply Good karma+3 votes
SheToldMeSheCouldFly
SheToldMeSheCouldFly

The new minigun is much better!

Reply Good karma Bad karma+1 vote
Phenixtri
Phenixtri

hardly its remedial by design .... id take sgt marks original over this new abomination ANY day >_> everything else in the pack is brilliant tho.

Reply Good karma Bad karma+1 vote
Phenixtri
Phenixtri

on that note anyone know were I can get the old minigun from this pack? I really dont want to delete this addon from my collection because of a retarded triple minigun ....

Reply Good karma Bad karma+1 vote
SheToldMeSheCouldFly
SheToldMeSheCouldFly

The BD originals are nice too. But I meant the new chaingun is nicer than the all black one from the prior skins IMO. It's a triple threat, and I like skulls :-)

Did you delete the file for the prior version? You can try asking for a link to it if you prefer to roll back a version.

Reply Good karma Bad karma+1 vote
Jrmyxd Author
Jrmyxd

im gonna a upload v1 on mediafire with the black minigun then

Reply Good karma+1 vote
Jrmyxd Author
Jrmyxd Reply Good karma+2 votes
Jellyman1303
Jellyman1303

1) The Modern weapons now are much better (no more Toys R' Us BFG!)
2) Classic weapons are inconsistent (all weapons are on the right hand position except for the rocket launcher. The plasma rifle's plasma fires as if its from a the center position)
4) I suggest finding the center position sprites for this weapons if possible
5) Overall, its an improvement!

Reply Good karma Bad karma+1 vote
Jrmyxd Author
Jrmyxd

Thanks for your suggestions bro!

Reply Good karma+1 vote
Azul73
Azul73

At the beginning of your Brutal Doom V20b Jrmyxd Arsenal Trailer, it shows you starting in a level that appears to be E1M1, but there seems to be a few additional rooms. What map pack are you using for that scene?

Reply Good karma Bad karma+1 vote
Jrmyxd Author
Jrmyxd

Map of chaos by DoomVideoVault
Moddb.com

Reply Good karma+1 vote
SarcasticDonut
SarcasticDonut

Script error, "BDv20b Jrmyxd Arsenal v3.pk3:blood.txt" line 610:
Expected ',', got 'l'.

Running latest GZDoom SVN release and got this error.

Reply Good karma Bad karma+1 vote
Jrmyxd Author
Jrmyxd

Dont run with BDv20b , only with BDv20b jrmyxd arsenal

Reply Good karma+1 vote
SarcasticDonut
SarcasticDonut

I didn't, I only ran your arsenal file. It has something to do with the latest SVN releases because they use the newest code from ZDoom 2.8.0 or something like that. I find that the weapon mods I like to use don't work like they're supposed to with the newest versions of GZdoom/ZDoom.

Reply Good karma Bad karma+2 votes
SarcasticDonut
SarcasticDonut

I updated my GZDoom SVN, but it still gave me the same error. Just making sure that the svn version is the problem.

Reply Good karma Bad karma+1 vote
Post a comment
Sign in or join with:

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.