Im currently away from the mod team for my wedding please contact another dev for mod support...thanks bane :)


No images, videos or audio files have been added to this gallery. Join now to share media with the community.

My Blogs

No blogs were found matching the criteria specified. We suggest you try the blog list with no filter applied, to browse all available.Join now to share your own content, and encourage our community to get involved and engaged.

Start a group Groups
ST Armada 3 Dev Group

ST Armada 3 Dev Group

19 members Developer & Publisher

The group developing the star trek armada 3 mod for sins of a solar empire rebellion.

The star trek Alliance

The star trek Alliance

24 members Hobbies & Interests

A group for people who are fans of star trek franchise and wish to interact with other fans regarding all matters star trek. This groups covers all and...

Post comment Comments
contrastyfaun5 Aug 15 2015 says:

hey i found a glitch that when im playing like 3-5 min into the game the mouse pointer disappears and a fresh instal dosnt help

+1 vote     reply to comment
mcflaps Feb 26 2015 says:

hi man,
sorry i am texting u here, but the game doesnt work at my system!
i am searching for a dev, who will take a look at the dump file, or who can help me!

+1 vote     reply to comment
ksiazeboguslaw Jan 24 2015 says:

Hig prior Message !!!! To Starfleet Command

I have finally found out !! What couses LAG/ frame rate drop
It is In Sound - "Volume Effect" - if turn off ( scrolled ) game runs quite smoothes
but when volume Effect is on the game Laggss dramaticlly

When playing battles with multi ships - Via couple dozens - with volume EFFECTS off i got 55 60 fps , but when it is On ( obvious) - it is sometimes even 12 fps !!!!
It is confirmed !!!! On my and friends Rig comp!

Maryny it is something with mod c++ but ... For sure not the main problem ..
My Rig
Gtx 980 MSI
I i7 4790k 4ghz
18 GB geil gaming
Win 8.1
Newest drivers
Steam in game off
Clean comp , registry and So on ...

+1 vote     reply to comment
Locutus_001 Aug 13 2014 says:

Hi Bane could you and your fellow DEVs make a re-model for the borg unicomplex ready for CTA release? when is upgraded its just a big tangled mess. I thought maybe you could use the nexus model from STA 2, its more compact, looks better, wont merge with other structures or planets and maybe add some borg shielding effects and to their ships. just an idea

+1 vote     reply to comment
Paradepartizan Jul 11 2014 says:

Damn, wrong chat ^^

+1 vote     reply to comment
Post a Comment
click to sign in

You are not logged in, your comment will be anonymous unless you join the community today (totally free - or sign in with your social account on the right) which we encourage all contributors to do.

2000 characters limit; HTML formatting and smileys are not supported - text only

Offline Since
Oct 6, 2015
United Kingdom United Kingdom
Member Watch
Track this member
Activity Points
2,034 of 534,948
2 members
Time Online
22 hours
Site Visits
Profile Visitors
2,976 (3 today)
Private Message
Send Now
Members Only
LeviathansWrath friends since Oct 15, 2014
Amargosa friends since Dec 1, 2014
zwood friends since Jun 12, 2014
_Draconis_ friends since Dec 24, 2014