Forum Thread
by member
  Posts  
Desura crashes before login after attempt at installing Half-Life 2 Mod (Forums : Support : Desura crashes before login after attempt at installing Half-Life 2 Mod) Locked
Thread Options
Dec 27 2012, 4:40am Anchor

Hello everyone,

I recently attempted to install the half-life 2 mod Aftermath:Source on Desura.

As it was I believe on the file validation step, Desura seemed to just disappear from my processes. When I tried restarting it, it crashed, and gave me the option to restart or force update.

I tried restarting first and got the same error. I tried the force update and also got the error. I tried exiting and using the force update exe myself and still that error.

At first it seemed to not be updating at all, saving my password and everything, but after a few force updates it now asks me to reenter my password after each update.

I have downloaded other half-life 2 mods on Desura before, including No More Room in Hell, Black Mesa, and The Stanley Parable. These all launch through steam, and are unaffected by this error, which is great, however I really like Desura and I would like to get it working again.

I have not tried reinstalling it. I have no purchases, however I'm afraid of losing my Black Mesa saves, so I'm not sure if reinstalling would be beneficial.

Any advice regarding this concern would be appreciated, and I thank you for your time.
-Diva

Okay well launching in Offline Mode doesn't cause crashing, but it's not very helpful for solving my problem (as I can't get rid of Aftermath or download new mods)

Dec 29 2012, 3:02pm Anchor

I did a clean reinstall for this problem, but I have no clue why I am getting it either. I just want to download HL2 wars already!

XenonFORT
XenonFORT Seriusly Humorist Player
Feb 13 2013, 11:31am Anchor

I have the same problem, I think I will try to make a clean install of the program but what a shame...

Edited by: XenonFORT

Henley
Henley the sun never sets on the eternally cool
Feb 13 2013, 6:25pm Anchor

Uninstall (by simply deleting the mod itself from your computer) the mod you just downloaded and try again, if that does not work navigate to C:\ProgramData\Desura\DesuraApp then delete the files that are not in any folders. Keep in mind that fix will make it so you need to verify the game installs again but it should fix any login issues you have.

Let me know how you go.

--

XenonFORT
XenonFORT Seriusly Humorist Player
Feb 14 2013, 9:01am Anchor

I Did a Clean install before seeing this post, and it solved it more or less. Verified Installed Mods, and installed some after. Aftermath: Source Triggered a crash again, but it seems that I can relog in without any further problems. Still, if I encounter the same problem I will try what you said before doing a clean install.

Also a way to figure how to dump correctly the app so I can send the info about what could be wrong with the app at the crash so it can be fixed in the near future would be really appreciated (Saw the Dumpexe, but didn't figured out how to use it correctly :() as I really like Desura and want to help in improving it ^^.

Anyway, again, thanks for your time and help, it's really appreciated ^^.

  • Edit: I just got it again, this time with Half-Life Wars.

After pressing the install buttom inside the web menu inside the Desura UI, it started to prepare the install, then asked for the user location on steam, selected it and after a bit it crashed, and now crashes everytime I try to log in, used Repair and Force update methods again without luck.

In Offline-Mode it displays the mod in the list as Not Ready (HL Wars). I think the problem can be in having Episode 2 Downloaded but never executed, going to try that.

  • Edit2: It Keeps Crashing, gonna try to delete what you said and see if it works ^^.

  • Edit3: Did what you wrote, and I finally managed to log in. Verified Half-Life 2, tried to execute HL Wars from the list and crashed again, but this time repairing worked. It seems that if I never exit Desura correctly, I don't have to delete the files you mentioned, that is, exiting always because the crash. If I ever exit normally Desura and then Log in and try to get HL Wars, it then keeps crashing at each log in, really weird. It always crashes after selecting my user folder on steam, tried sourcemods folder in that selection and had the same luck.

Maybe it needs to actually play a map on Episode 2, as I only executed the game but didn't started the campaing, or maybe it looks for the Half-Life 2 Folder which I haven't installed on my account, maybe I could get it on other account and copy paste the folder but don't know if that would help and would be much trouble just for nothing.

If I can do something to help to solve this strange killing bug I would like to help ^^, until that, I think I will have to have special care with HL2 mods that use HL2 content.

Again, thanks for your time and help ^^


  • Last Edit I Hope: Made Edits more Visible IMHO :P

Edited by: XenonFORT

Henley
Henley the sun never sets on the eternally cool
Feb 14 2013, 6:36pm Anchor

Half Life Wars actually needs alien swarm to play.

--

XenonFORT
XenonFORT Seriusly Humorist Player
Feb 15 2013, 2:42pm Anchor

Yes, but aftermath:source gave me the error too, not sure what needs that one. Installed Alien Swarm and downladed manually the Wars mod, don't want to have to revalidate yet again all the things I have installed. Anyway, it should just show an advice about it needing it. Not Crashing Desura every time you try to login after trying to install it from desura :/.

Jun 22 2013, 3:56am Anchor

how do u uninstall without being online i have the same problems as well

Reply to Thread
click to sign in and post

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.