Forum Thread
by member
  Posts  
Desura Connection Problems (Forums : Tech Support : Desura Connection Problems) Locked
Thread Options
Apr 4 2013, 1:23pm Anchor

So I've recently got desura back to download and install some mods but there is a problem when I try to download a mod.


This happens when I am trying to install some mods for Command and Conquer 3: Tiberium Wars, I have tried installing mods for the other games i have but it still comes up with this.
I run a windows 8 laptop.
The only reason I don't download direct that much is because it's slow whereas on Desura it's much faster that's why I use it for mods.
Please if there is a fix for this can I know it, I've tried the Internet explorer trick and it did nothing. I can't find any other fixes out there.
I cannot post the logs because of the new member anti spam thing.
All i can say is it keeps saying "Cannot connect to Peer"
I have given Desura Administrator rights and it's still not working.

Reply to Thread
click to sign in and post

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.