Forum Thread
by member
  Posts  
Ceiling Lighting Problem in Unity (Forums : Level Design : Ceiling Lighting Problem in Unity) Locked
Thread Options
Jul 8 2013, 9:52am Anchor

Hello there Community,
I am facing a problem with my Ceiling Lights in Unity, you can see that the corners are "dark" and not lit as they should be, it's like light isn't reaching there:

(Right Click>Open image in new tab, to see it clearly)

Now, these are my options and settings for the Light:

And these are my settings for the Ceiling Mesh.

I hope someone can help me on this as I've spent hours trying to figure it out!
Thanks in advance everyone!
-Dan

Jul 8 2013, 8:17pm Anchor

In crease the strength/radius, turn off shadows, or move the light down.

Jul 8 2013, 8:38pm Anchor

@Squared55

Increasing the Intensity or the Range don't help.
The Shadows don't have anything to do with it.
Moving the light down would make the light source look unatural as the source must be on the ceiling.
Thanks a lot for your time mate :) if you have anything else in mind I'd really appreciate it!
-Dan

Jul 8 2013, 8:48pm Anchor

I find that moving it down/away works fine; players (and likely you given enough time) won't notice. If you must, add a lens flare in the proper position. The lights in my game are about a foot in front of their light source; the lights in the second picture are in front of the monitors by several meters. I can provide more examples, if you want. :)

Or, you could use lightmapping and increase the light bounces.

User Posted Image

User Posted Image

Edited by: Squared55

Jul 8 2013, 8:59pm Anchor

I could move the Lights lower, but the following problems show up,
The ceiling light isn't us bright as before.
The Floor is extra bright and looks weird.
It doesn't really fix the problem a lot.

This is getting really annoying because as you notice, the dark corners make it look unatural :/
Also I can not have an Unlit shader because the plaer will be able to turn off the lights.

Jul 8 2013, 9:09pm Anchor

Does that problem persist if you only move it down a little bit?

Also, I said Lightmapping, not unlit. I beleive there is a way to disable a lightmap at a specific index via script, although I'm not 100& sure. :)

Or, maybe put tiny lights in the corners?

Edited by: Squared55

Jul 8 2013, 9:20pm Anchor

Moving it down or up won't help.
Also I am not experienced in lightmapping, so i am afraid I can't do it, I suppose the tiny lights may work :/

Jul 8 2013, 9:24pm Anchor

Step 1: Open the lightmapping window under "Windows"
Step 2: Adjust settings is you want, Hit Bake
Step 3: ??????
Step 4: Profit!

Look here as well :):
Docs.unity3d.com

For disabling the lights, well:
Google.ca

Edited by: Squared55

Jul 8 2013, 9:32pm Anchor

E-mail you :)

Reply to Thread
click to sign in and post

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.