Post news RSS The Dwarf Holds is released!

The Dwarf Holds version 0.5 is released for BFME 1!

Posted by on

Good afternoon, everyone!

Well, here we are at last. Over the last few months, we have worked hard towards this day, and we’re all very thrilled that it has finally come.
Unfortunately, Nertea has gotten ill recently, so in his stead Matias and I will be managing and overseeing the release today, making sure your downloading will all go smoothly.

We are offering the mod from two locations away from Revora in order to keep the server alive, both of which can be found on the downloads section of our
new website (only ModDB is available as of yet):


The mod is fully organized into an installer, which checks to make sure your copy of the Battle for Middle-earth is updated to patch 1.03 (which the mod requires), and an updater utility through which we may release future patches. This can be found under the The Dwarf Holds tab created by the installer. These functions should reduce installation problems to a bare minimum, but should you still face issues, you can post these problems, along with any bugs you might find, in the new Bugs and Issues category under our forums.

Thank you ever so much for all your patience and support. We hope you enjoy The Dwarf Holds, and we hope to meet you in battle through our dedicated Hamachi network, TheDwarfHolds. (pass: tdh)

~ The Dwarf Holds team.

*opens a can of beer*

Comments
freakinwat
freakinwat

Well I guess it's time to reinstall BFME!

Reply Good karma Bad karma+1 vote
Post a comment
Sign in or join with:

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.