Post news RSS Star Wars - Galaxy At War - 0.6

New Public release, v0.6 and what has changed since v0.49? The following article will list the most prominent changes and additons since v0.49

Posted by on

New Public release, v0.6

What has changed since 0.49 (below you will find a list of the most prominent changes and additions)

- we added multiplayer back in (4 factions, CIS, Empire, Rebels, Republic) The Republic has been seperated into the following sub factions (501st, 212th, 65th, 21st, 104th)
***multiplayer is currently infantry only based, only speeders are available to use, we are going to add more vehicles with the next update.

- we added AI (Bot) support to mulitplayer and local games (requirenment Airborne DLC)

- the mod is now english only with a more complete translation (weapons, units, items, etc. have now a proper translation)

- new maps (+ overhaul of all sw multiplayer maps)

- new breeds (editor)

- a variety of new props (+ CTA props)

- new turrets (+ Rebel DF9 turret, Rebel Medium Tower, Gi-19 turret)

- new vehicle (+ Haifire Droid)

- new weapons

- general fixes (+ broken assets have been either fixed or removed)

- fixes for Spanish Warriors Missions* (+ they now contain the proper text files)

- Weapon Balance Overhaul (we basically re-balanced all existing weapons to be more balanced for multiplayer, those changes are going to translate over to missions and general editor gameplay)

- new multiplayer mechanics (+ the technician can place turrets and cover, the officer can place a supply droid)

- new Star Wars inspired HUD (+ Icons)

Comments
Domino_5555
Domino_5555

When will the Steam Workshop get the update?

Reply Good karma Bad karma+6 votes
Guest
Guest

This comment is currently awaiting admin approval, join now to view.

Johnny595
Johnny595

Hailfire droid, our boy is back <3

Reply Good karma Bad karma+2 votes
Guest
Guest

This comment is currently awaiting admin approval, join now to view.

Fedaygin
Fedaygin

Big thanks for this :) Sharing word around Wicked Wide Web <3 Wish you relaxed Ancient Viking's Yule Holidays & launch for Next Year 6021 :)

- Fedaygin -

Reply Good karma Bad karma+1 vote
Guest
Guest

Hi i have somthing wrong when i get on the game and i want to aply the mod it says i need a difrent version of the game i have v3.260.1

Reply Good karma Bad karma0 votes
heAd3r Author
heAd3r

update the game to the latest game version

Reply Good karma+1 vote
Guest
Guest

This comment is currently awaiting admin approval, join now to view.

Guest
Guest

This comment is currently awaiting admin approval, join now to view.

Post a comment
Sign in or join with:

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.