Post news RSS Please report errors and crashes here...

...so that the main comments page would not get swarmed by them. Thank you.

Posted by on

There are numerous reasons for crashing in M&B, most common would probably be lack of Ram. And i dont mean that you simply dont have enough, main problem is that M&B unaltered can only access 2gb of Ram. I personally have 8 so it aint much of an wonder that the game aint very stable, now is it?

Comments  (0 - 50 of 97)
daanwiemers
daanwiemers

it crashed when i entered a cantina

Reply Good karma Bad karma+2 votes
DarthMongolTheUnwise Author
DarthMongolTheUnwise

That might have been just an random crash, they do happen sometimes. Has there been other crashes?

Reply Good karma+1 vote
mrjtg12
mrjtg12

Yes, each time I get into a battle with anyone my game crashes with no other explanation than it has stopped responding. These crashes happened when I tried to get in a fight with a dude that didn't like me, and when I was attacked by clone deserters.

Reply Good karma Bad karma+1 vote
mrjtg12
mrjtg12

I also received a crash from selecting 'Galactic Conquest' too. I couldn't find the load textures on demand option in the launcher, either.

Reply Good karma Bad karma+1 vote
DarthMongolTheUnwise Author
DarthMongolTheUnwise

I think that load textures on demand is only for Warband, sorry about that. It was my mistake. Well, i dont know what is your games problem, the general guide for crashing issues is trying to turn graphics lower, i dont know if it helps, but it might. Also try DX7 mode instead of DX9. Have you been succesfully playing SWC before?

Reply Good karma+1 vote
mrjtg12
mrjtg12

Yup! I played it on normal Mount and Blade without any crashing or errors before switching it on over to Warband when they made it compatible. I'll try switching it to DX7, see if that helps.

Reply Good karma Bad karma+1 vote
mrjtg12
mrjtg12

Well, it didn't crash when I was in a battle or fighting when I put it on DX7. When I pressed exit game it crashed.

Reply Good karma Bad karma+1 vote
DarthMongolTheUnwise Author
DarthMongolTheUnwise

If i were you i would simply ignore that. What it even matters if the game crashes upon exiting?

Reply Good karma+1 vote
mrjtg12
mrjtg12

I guess it doesn't really matter if it does that, thanks for your assistance! This is great fun!

Reply Good karma Bad karma+2 votes
scar1029
scar1029

I have an issue where I keep spawning inside other people at the start of battles. I then get stuck inside of them and we both get uncontrollably flung across the map.

Reply Good karma Bad karma+1 vote
DarthMongolTheUnwise Author
DarthMongolTheUnwise

Have you used that camera mode which allows spectating allies after falling? I remember it getting you stuck in people. You should try and find a party of something easy to kill and attack, i think the error should end if you remain from using the spectate mode.

Reply Good karma+1 vote
TheQuintessential
TheQuintessential

I have an error to report, tournament at dac is faulty during a fight some of the combatants go invisible and you are unable to damage them also majour errr frame rate drop when this is happerning, i think its the character models clipping into the arena floor as sometimes you can just see a pair of legs running around! haha like the top half of the character has been sucked into the floor it has happened to my character as well

Reply Good karma Bad karma+1 vote
DarthMongolTheUnwise Author
DarthMongolTheUnwise

Just fought in one on Dac, (lucky there happened to be one there) and it seems it worked just as it should.

Reply Good karma+1 vote
TheQuintessential
TheQuintessential

hmm dunno what wrong with mine then other tournements hve worked fine

Reply Good karma Bad karma+1 vote
shadowyuiop
shadowyuiop

Can't even launch it....I feel as though I'm installing it incorrectly. Please help

Reply Good karma Bad karma+1 vote
DarthMongolTheUnwise Author
DarthMongolTheUnwise

That doesnt help me, be more specific. Have you installed other mods for M&B before?

Reply Good karma+1 vote
TheQuintessential
TheQuintessential

Just started crashuing all the time when itry to join a battle an ally is haveing i click charge the enermy and mount and blade stops working i've tried tweaking all graphics options and setting them to lowest but nothing works?

Reply Good karma Bad karma+1 vote
DarthMongolTheUnwise Author
DarthMongolTheUnwise

Have you tried Large Adress aware method? If not, you should. It will most likely stop crashing nearly completely for you. That is, if your pc is combatible with it. It doesnt work for everyone, especially low end pcs with less than 3 gb of RAM.

Reply Good karma+1 vote
TheQuintessential
TheQuintessential

my laptop's fairly new high end i think do you have a link for it i cat seem to find one

Reply Good karma Bad karma+1 vote
Grimval
Grimval

it crashes everytime i launch the mod

Reply Good karma Bad karma+1 vote
DarthMongolTheUnwise Author
DarthMongolTheUnwise

No error message of any kind, just stops working and goes to desktop...?

Reply Good karma+1 vote
DarthMongolTheUnwise Author
DarthMongolTheUnwise

Moddb.com

TRY THIS IF HAVING CONSTANT CRASHES

Reply Good karma+1 vote
TheQuintessential
TheQuintessential

?I have a good old games version of mount & blade will this work for that

Reply Good karma Bad karma+1 vote
DarthMongolTheUnwise Author
DarthMongolTheUnwise

As long as you have a legitimate code for the game, or maybe even if you dont, you know the Yarrrr stuff, it should work. Hell i dont know, try and find out!

Reply Good karma+1 vote
TheQuintessential
TheQuintessential

ha ha ok it worked i can nw fight battles without it crashing but now i have the error where my character gets stuck in another allied character then they both move quickly all around the map and if i kill the character i'm attached to i can move with the mouse looking around and fire but cant move forwards or backwards :S

Reply Good karma Bad karma+1 vote
DarthMongolTheUnwise Author
DarthMongolTheUnwise

DONT USE THE SPECTATE MODE WHEN YOU DIE. IT DOES THAT; STICKS YOU TO ANOTHER PERSON.

Reply Good karma+1 vote
saphir35890
saphir35890

I'm having crash message "Unable to restore vertex buffer".

Any ideas/solutions to make the mod work for me ?

Reply Good karma Bad karma+1 vote
TheQuintessential
TheQuintessential

does it happen all the time or can youplay the game for awhile before it happens? the error happens to me a few times just go into graphics settings and turn all the settings to disabled or very low and it should help playibility i think its an error that happens base game but not a hundread percent on that

Reply Good karma Bad karma+1 vote
Guest
Guest

I have a question, involving the Yavin 4 Map.

Is it in anyway large, and or big for a battle? Because when I was given the choice to fight Deserters on Yavin 4, the game begins to crash immediately. My units aren't big, and when I fight on the ship everything seem's perfectly fine. I as well tested this on the M&B Original Star wars:Conquest mod. It runs perfectly, and expiriences NO Crashes.

Any advice and or methods? Because I cannot in any way battle on Yavin, no matter how much I try.

The other planets such as Coruscant seem to allow me to battle fine.

Reply Good karma Bad karma+1 vote
DarthMongolTheUnwise Author
DarthMongolTheUnwise

Yavin is quite large map, but i know no reason it would cause a crash on you. If that is the only map, and you dont too much care where you fight, you could try and replace the battlescene with another. I assume you dont kow how so reply this message if you need advise with it.

Reply Good karma+1 vote
Guest
Guest

Yeah, it is the only map I can't battle on.
I've fought on other maps, and they seem to run just fine.
But, if I can replace the battlescene with something else, i'd like to do that.

So yeah, i'd like some advice to replace it (taking into consideration that it may or may not cause an error within the mod its self)

Reply Good karma Bad karma+1 vote
DarthMongolTheUnwise Author
DarthMongolTheUnwise

All right. So, what i explain here is how to replace a scene, in case such comes necessary, as for the Guest lad/lass here.

First thing if to find out the name of file you must replace. Because you'd need to access the map in question ive done that for you.

scn_mainplanet_yavin_iv_land_battle.sco

Planet Yavin IVs Battlescene, ^ this is the physical file that you need to replace OUT of game in order to access Battles on Yavin IV. It is located in "Clone Wars Conquest/SceneObj"

Now, if you already know, what planet you want to have Yavin be replaced by, the next step will be easy. To ease the search for the right scene, you can search with term "land" in the folder. This will show you the list of planets with that in name, incluiding all "land battles".
Locate the one you want, and copy it. Then you can either move scn_mainplanet_yavin_iv_land_battle.sco to desktop or remove it, BUT you need the name of it. So copy the name if you remove the file. Then, you change the name of the copied system you wanted take Yavins place, to "scn_mainplanet_yavin_iv_land_battle"

Now if you did all right, you should have replaced the physical battlefield of Yavin Iv with the battlefield of your choice.

This can be applied to any scene causing crashes or other problems, and ive replaced some that caused problems for me, such as Mandalore, since it caused always a crash for me, rendering its scenes unplayable.

Now, i hope ive managed to be helpful.

Reply Good karma+1 vote
warmang4ming
warmang4ming

Attempting to simply launch the game brings me to the loading screen, which loads correctly up until setting data. It suddenly crashes saying something about C++. I can post the full error code if you ask.

Happy new year!

Reply Good karma Bad karma+1 vote
DarthMongolTheUnwise Author
DarthMongolTheUnwise

Yes, do.

Reply Good karma+1 vote
warmang4ming
warmang4ming

Installing the expanded edition fixed the problem, but here's the error:

Assertion Failed!

Program: InstallDirectory\mount&blade;.exe File: e:\develop\mborg\program\src\../../rgl/rglBody.h

Line: 393
Expression: num_edges > 0

For information on how your program can cause an assertion error, see the visual C++ documentation on asserts.

Reply Good karma Bad karma+3 votes
warmang4ming
warmang4ming

Each time I try to close the message another pops up with the same error except with a different line number, eg. 394, 396, 397, 398

Reply Good karma Bad karma+1 vote
DarthMongolTheUnwise Author
DarthMongolTheUnwise

Assertion Failed errors have a whole number of causes with no specific answer to all of them. I took a quick look around forums and found atleast 5 different solutions but unsure of if any of those would help in your case.
Did you change the directory where the Enhanced edition would install? If you did, reinstall it and DONT change it. Someone states this causing errors. If not, answer back and well try to figure this out.

Reply Good karma+1 vote
miguelgutierrez2001
miguelgutierrez2001

eyy your mods keeps crashing on start-up and say assertion failed

Reply Good karma Bad karma+1 vote
Guest
Guest

im having a problem when i lunch the game it crashes and yes its the yarrr stuff

Reply Good karma Bad karma0 votes
DarthMongolTheUnwise Author
DarthMongolTheUnwise

Then i suppose i cant help with it.

Reply Good karma+1 vote
miguelgutierrez2001
miguelgutierrez2001

why ? is it only the bought version ??

Reply Good karma Bad karma+1 vote
DarthMongolTheUnwise Author
DarthMongolTheUnwise

Im not trying to portrait myself as some kind of a saint or anything, but i prefer to stay clean with Law. If it is a pirate, youre on your own Guest.

Reply Good karma+1 vote
Uxernome
Uxernome

I'm getting a Vertex Buffer error every time I enter battle or browse the market. Those are errors I've never had prior to trying this mod. (I have the enhanced version of mount&blade;)

Reply Good karma Bad karma+1 vote
DarthMongolTheUnwise Author
DarthMongolTheUnwise

Unable to restore vertex buffer? See this site
Answers.yahoo.com buffer error mount and blade

Reply Good karma+1 vote
Uxernome
Uxernome

I tried but it still doesn't work. It's strange because star wars conquest work perfectly :S I've tried other mods as well and it's really only happening here. Besides, it's beyond the point, I've always had 70 max battles, I tried reducing it to 50 as for the rest rag dolls and corpses were already turned off :S. As I said before, I also have the problem while trying to buy stuff, so I think there's a problem with the textures or models or some rogue code is making things weird, I don't know.

Reply Good karma Bad karma+1 vote
DarthMongolTheUnwise Author
DarthMongolTheUnwise

Humm... i havent added new codes, nor really altered existant ones. All coding changes ive done is with animations and these alterations should be safe. It is strange that so many find issues with this module, not sure what to do about it. Currently im planning to seek out other modders planning to work on SWC once it is open source. Also doing some jobs for Bear Force II mod.

Reply Good karma+1 vote
GreenGreenGun
GreenGreenGun

Sir the expanded edition fixed the visual C++ problem, but i have a new problem now

my game crashing when i fight on the planet but i can fight on the ship only

maybe it start crashing when i shoot the blaster on planet

please help me

i really love ur mod.

Reply Good karma Bad karma+1 vote
DarthMongolTheUnwise Author
DarthMongolTheUnwise

"maybe it crash when i shoot blaster" it is known that shooting a blaster when you dont have bolts equipped causes a crash. Also i read from forums that hitting shields with blasters can cause crashing, so try to see if its either of these and report back

Reply Good karma+2 votes
CT-1284
CT-1284

The same problem - constantly crashes. 15-20min of play, and that's it. First 5-10 min everything is perfect, a can fight on a ship an on a planet, but when 15-20min expire, here it comes - a crash.

The same problem was with Star Wars Conquest when they just finished 0.9.0.3 version, but than they fixed it somehow.

I love your mod, its awesome, but I can't fully enjoy it because of the abovementioned

Reply Good karma Bad karma+1 vote
DarthMongolTheUnwise Author
DarthMongolTheUnwise

Try using that enhanced mount and blade version of the game
Moddb.com Install it, and replace mount&blade; exe with the one in the rar file. If,this works, it is likely to help. But its working is not guaranteed.

Reply Good karma+1 vote
Post a comment
Sign in or join with:

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.