Post news RSS Mafia Titanic Mod - Part One Released!

The Titanic mod is now available for download! Who knew I'd ever type these words. Get your copy now!

Posted by on

Release poster


Even I couldn't imagine this moment taking place. But it's finally there, after 15 years of development. The Titanic mod is now available for download! It's only Part One of course, but still, this is a big day for the mod.

DOWNLOAD


Part One includes the first sequence of the storyline and a freeroam option of the ship at sea, and the Central Island Docks. The sinking is NOT yet included in Part One.

Marked blue on this map shows the interior included in Part One

IMPORTANT NOTE

The installer MUST be executed as an administrator. Otherwise it may not overwrite the necessary files.

TECHNICAL REQUIREMENTS

  • A CLEAN installation of Mafia with no other mods installed. Including the widescreen fix. There can be no modifications whatsoever prior to installing the mod.
  • A copy of "Mafia - City of Lost Heaven" (2002), Vanilla, Steam or GOG. This mod is NOT compatible with "Mafia: The Definitive Edition" (2020).
  • 64bit Windows. This mod is not compatible with 32bit PC's.
  • 2GB of HDD storage.
  • A dedicated GPU card with at least 1GB of RAM. Intel HD graphics or other integrated graphics cards are not recommended.
  • 4GB of RAM.
  • 3Ghz Processor.

KNOWN ISSUES

Reloading a scene after death may cause assets and NPC's to be misplaced or take T poses. This is an engine limitation due to the high amount of assets ingame. Reloading the scene from the menu may fix this.

See you all onboard!


Game 2021 07 26 20 10 20 79

Comments
taze1629455077
taze1629455077

Morning Robville,

I've ran as admin and installed successfully but when i load the game, it only takes me to the graphics settings page and there's no option to continue to the game itself. I have the steam edition - fresh install. Any ideas? Happens regardless of whether I run the graphics settings or the game itself in the steam options.

Thanks,

Taze

Reply Good karma Bad karma+2 votes
MrRobville Author
MrRobville

Hi there, I'm currently looking into this issue. It seems to be related to Mafia in general with some people. Basically the registry isn't updating properly by the game.

In the meantime, could you try removing Mafia entirely, closing Steam, and opening Steam as an administrator? Then after you install the game, before you install the mod, run the game to see if it now saves the settings. If it does, you can go ahead with the mod.

Reply Good karma+2 votes
MrRobville Author
MrRobville

The problem has been found! It was due to a setup.exe inconsistency with Steam versions. I've uploaded the hotfix here: Moddb.com

Simply copy the setup.exe into your Mafia root folder and replace the original. It should then work.

Reply Good karma+4 votes
Marek33
Marek33

Congratulation to the release! After such a long time, I hope that everybody will enjoy this demo, as much as I enjoyed the original game, which is one of my favorite games out there.

Reply Good karma Bad karma+3 votes
SilentlyWeeps
SilentlyWeeps

Any chance you can get the Steam Overlay to work with it ?

Reply Good karma Bad karma+2 votes
MrRobville Author
MrRobville

I fear that kind of functionality is hardcoded into the game's executable. Aside of tweaking it, it's not possible to add new functionality like that unfortunately.

Reply Good karma+3 votes
GoodGriefer
GoodGriefer

Hey man this is so awesome! When I get home I'm gonna try this out. Much cheers!

Reply Good karma Bad karma+3 votes
zbigniewpancerfaust
zbigniewpancerfaust

Hi, i have a problem just after click on game.exe - "Bad version - engine:395 client:384". Could you tell me what is wrong? I have a clear version of mafia. With old Game.exe everything is ok.

Reply Good karma Bad karma+1 vote
MrRobville Author
MrRobville

Hotfix 1 should be able to fix that. This error occurs if the custom DLL files haven't been installed. Sometimes Windows Defender blocks those on some people's PC's.

Reply Good karma+1 vote
AMango123
AMango123

Hello! Where do we find hotfix 1? I am encountering an error where it says DLL files are missing

Reply Good karma Bad karma+1 vote
Post a comment
Sign in or join with:

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.