Post news RSS Info

Game version needed to download the mod when it is out

Posted by on

I found out that the mod only works on computers where version 1.2 of the game has been installed and unpacked, if you have already done that you are fine. If you havent and dont know how to you can find the download and sitructions on how to get it working and unpacked at Medieval2.heavengames.com

Post a comment
Sign in or join with:

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.