Post news RSS Imperial Conquest now Compatible with Version 0.76

Imperial Conquest can now be played with Version 0.76 if downloaded on Steam

Posted by on

Hello everyone

After testing I am pleased to announce that Imperial Conquest is now compatible with Galaxy at War Version 0.76, players of this mod no longer need to rely on Version 0.6 anymore, as Imperial Conquest is now able to be played with the latest version of Galaxy at War, the link to the latest update to Galaxy at war will be provided on the mod page so that people can easily have access to it.

However, be known that you still have to activate Imperial Conquest first, before you do Galaxy at War for the bugs to be overloaded.

Thank you for listening...

~2091riveraisrael...

Post a comment
Sign in or join with:

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.