A mod for Mount and Blade Warband set in Sengoku era, Japan. Based on Phlipp's amazing mod "Gekokujo".

Post news Report RSS ATTENTION

An information about the Warband Script Enhancer 3.2.0

Posted by on

Hello everyone! With the release of the new version, I've introduced a lot of new features. Siege with gates is one of them. But it seems that for some players that feature can be glitched. The thing is, I've been playing this mod (yes I like playing my own mod :D ) for a long time, even before the official release of it. And I've tested the features over and over again without encountering the bug that some players encounter. My companions dont switch with my char, and all the sieges work as intented. Then I realised that WSE might be the reason. See I'm using WSE every time I play Warband, simply because It enables the good old feature called "unlimited bodies on the battlefield". I like seeing all the fallen men on the field. And WSE also supports Warband engine to prevent random crashes. Fixes hardcoded bugs, Frees up ram as you play through.

So I advised people to use WSE 3.2.0 or Warband Tamer, but now I want people to use it to avoid problems in my mod. That siege bug bothers me a lot simply because It is taken from Marty's code from Gekokujo 3.1Beta, I didnt alter anything related to that script and it works for me bug free. Gekokujo 3.1 Beta doesnt need WSE, I know. So why I want you to use it? Because I've introduced so many features like executing the lords, wound system, taunts etc one of them might need WSE in order to work without any bugs. So please consider using it for a more enjoyable Gekokujo experience. However that doesnt mean I wont try to find the exact cause of the gate bug or companion bug. Wish I could experience it myself so I could examine the situation and the OPCodes. Because the said OPCode "1779" might be related to WSE. So I advise, really, I ADVISE you to use WSE. :) :)

Anyway, thank you for playing the mod, have fun!

Link to WSE:

Forums.taleworlds.com

Comments
Guest
Guest

This comment is currently awaiting admin approval, join now to view.

Maly_007
Maly_007

Isn't WSE continued? Like newest version is WSE v4.5.6, just by another author.

Reply Good karma Bad karma+3 votes
Elmarioo
Elmarioo

download from this page Forums.taleworlds.com

Reply Good karma Bad karma+1 vote
bluewario
bluewario

Yeah which version do I install? Btw thanks for the warning Aruda.

Reply Good karma Bad karma+1 vote
Aruda Author
Aruda

I shared the link of v3.2.0 because it is the version that I use. I didnt want to you to use the version that I havent tried. :) If 4.5.6 is compatible then go ahead. :)

Reply Good karma+3 votes
zReclaimer
zReclaimer

The v3.2.0 download link isn't working anymore so the rest of us who hasn't gotten WSE will have to do with the v4.5.6 one. Thank you for letting us know though :)

Reply Good karma Bad karma+3 votes
Aruda Author
Aruda

Really? I hope it works without problems. I will try it myself, If I encounter any problems I will upload 3.2.0 for you guys.

Edit : I tried 4.5.6 it seems to work without problems. But it ignored and used native loading screens and inventory screens rather than using my own textures. Strange :D

Edit 2 : Renaming TexturesHD folder in M&B Warband brought back my textures back. It seems new exe overrides my loadscreens and replaces them with HD ones from Native Warband. It seems to be working without problems now.

Reply Good karma+8 votes
Guadaña
Guadaña

Lol @Aruda, you just saved me a headache.

I was actually using WSE for other mod, and I saw the same issue with the textures.

I came here just to see what was going on with your mod (congrats and thank you so much for the release, I've been waiting for this a long time!) and you just provided the solution!

Reply Good karma Bad karma+1 vote
Guest
Guest

This comment is currently awaiting admin approval, join now to view.

Broshevik
Broshevik

When i tried the new WSE its said that i haven install 1.17 but infact mine is 1.172. Im using steam version btw. can anyone help?

Reply Good karma Bad karma+2 votes
zReclaimer
zReclaimer

WSE v.4.5.6 unfortunately only supports 1.170 so you need to download this Dropbox.com to get it working properly.

Reply Good karma Bad karma+3 votes
Peaceable
Peaceable

Thanks buddy

Reply Good karma Bad karma+1 vote
Broshevik
Broshevik

thx broo

Reply Good karma Bad karma+1 vote
Elmarioo
Elmarioo

I have the same problem with steam version :(

Reply Good karma Bad karma+1 vote
Aruda Author
Aruda

Download the .exe files too.It only supports 1.170

Reply Good karma+2 votes
Guest
Guest

This comment is currently awaiting admin approval, join now to view.

Thezombinator
Thezombinator

The Problem with making M&B Warband go back to 1.170 is the fact that some mods (notably sayazn and a few others) need the latest version of the game to play so you will have to either make a copied warband or switch out the exes whenever you play them

Reply Good karma Bad karma+2 votes
Guadaña
Guadaña

No fam, it works! 1.170 and 1.172 are absolutely compatible. Just rename "TexturesHD" folder in the main M&B directory to something while you execute WSE 4.5.6 and you'll be fine.

The update from 1.170 to 1.172 just changed that. I can attest this because I'm using 1.172 mods as well. Hope it helps!

Reply Good karma Bad karma+2 votes
Guest
Guest

I have been enjoying your mod for a few months now. It is great, but unfortunately, I do not have WSE. The download link for that Talesworld page also does not work. Is it possible that you will integrate WSE into your next release of the mod? Thanks.

Reply Good karma Bad karma+3 votes
redsimonDE
redsimonDE

WSE does not work with Steam version. And I don't know where to find Warband tamer.

Reply Good karma Bad karma+2 votes
kuudou
kuudou

Found a download of Warband Script Enhancer 3.2.0 that still works from a Steam Community Thread: Steamcommunity.com

EDIT: Do be aware though that it seems like this version only works with 1.5.x version of the Warband executable.

Reply Good karma Bad karma+1 vote
byaialele
byaialele

Someoene PLEASE make a wiki page for Daimyo edition! The normal gekokujo wiki works but theres lots missing / changed. Thanks!!

Reply Good karma Bad karma+1 vote
Guest
Guest

I really want to play this mod, but I don't understand what I have to do to get WSE working.

I downloaded the latest WSE files because I have Warband on Steam But when I click on WSEloader.exe I get an error saying I'm missing a .dill file. I'm useing windows10.

I wish there was clear instructions for using WSE. The instructions just say download and click on that exe. No ref to any problem one might face trying to use it.

Reply Good karma Bad karma+3 votes
Guest
Guest

This comment is currently awaiting admin approval, join now to view.

ethylesuperiorserv
ethylesuperiorserv

Someone else having crashes when removing clothes from women? no pun intended :v

Reply Good karma Bad karma+1 vote
Post a comment
Sign in or join with:

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.

Follow Report Profile
Icon
Mount & Blade: Warband
Creator
Aruda
Contact
Send Message
Release date
Mod watch
Follow
News
Browse
News
New
Post news
Report
Report
Share
Related Games
Mount & Blade: Warband
Mount & Blade: Warband Role Playing
Got it!

We have recently updated our privacy policy and terms of use in-line with GDPR requirements. More Info?